Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problemas con Compiz + driver gráfica Nvidia
  #1  
Antiguo 24-abr-2011, 10:09
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Exclamation Problemas con Compiz + driver gráfica Nvidia

En mi PC de sobremesa he instalado OpenSUSE 11.4 32 bits GNOME, y el problema viene al activar los efectos de escritorio del gestor de ventanas Compiz, que básicamente es que no renderiza bien el entorno al 100%, apreciándose algunos defectos en algunas líneas en las ventanas de cualquier aplicación, haciendo que las formas o el texto si lo hubiera no se viese como es debido, por ejemplo, haciendo que el texto que aparezca en una línea afectada aparezca cortado por la mitad, o que cada vez que se abra una ventana en modo maximizado aparezca una línea negra que recorre toda la parte inferior de la ventana. Son defectos que desaparecen si demaximizas y vuelves a maximizar una ventana, pero es muy molesto tener que hacerlo siempre.

La tarjeta gráfica de mi equipo es una Nvidia 6200 GS TurboCache, y he probado a utilizar los drivers x11-video-nvidiaG02 (260.19.44-24.1), x11-video-nvidiaG01 (173.14.28-28.1) y x11-video-nvidia (96.43.19-26.1) con los módulos correspondientes al kernel default de OpenSUSE 11.4, así como con los módulos correspondientes al kernel desktop, sin que en ningún caso haya mejorado la experiencia.
En el único caso en que la experiencia fue distinta (para peor) fue en el caso del driver x11-video-nvidia (con el módulo nvidia-gfx-kmp-default), con el que al activar los efectos de escritorio desaparecían completamente los bordes de todas las ventanas, y volvían a aparecer al desactivar los efectos.

Decir también que la aplicación de los Ajustes de NVIDIA del servidor X (nvidia-settings) solo he podido abrirla usando el driver x11-video-nvidia (96.43.19-26.1), mientras que con los otros drivers al querer abrirla desde el menú, el clickar sobre ella no tiene ningún efecto, y al ejecutarla por consola me salta el siguiente mensaje:

Código:
varyheavy@VaryComputer:~> nvidia-settings

ERROR: The attribute 'ForceGenericCpu' specified on line 26 of configuration
       file '/home/varyheavy/.nvidia-settings-rc' cannot be assigned (it is a
       read-only attribute).
También he probado a instalar el xorg-x11-driver-video-nouveau junto con el mesa-nouveau3d pero no sé cómo hacer para que el sistema pase a utilizar este driver :S, ¿cómo se hace el cambio de driver gráfico teniendo más de uno instalado?
Y lo más importante: ¿Qué podría hacer para resolver el problema del renderizado de las ventanas con Compiz?
En Mandriva también estuve usando en su día GNOME + Compiz y nunca tuve problemas de este tipo, todas las ventanas se mostraban correctamente. ¿Qué puede estar pasando en OpenSUSE?

Última edición por VaryHeavy; 24-abr-2011 a las 10:19
Responder Citando
  #2  
Antiguo 24-abr-2011, 13:08
Avatar de jesusx
jesusx jesusx está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 06-enero-2008
Ubicación: Castellón
Versión: Tumbleweed+Kde
Mensajes: 3.386
Agradecimientos: 328
Agradecido 486 Veces en 402 Mensajes
Poder de Credibilidad: 13
jesusx está en el buen camino
Hola, decirte que mi experiencia con Gnome+Compiz no fué del todo grata. En mi opinión, Compiz falla mucho y no te digo Emerald, que todo lo que tiene de bonito lo tiene de fallas XD...
Para el tema de efectos, Kwin en kde cada día está mejor, aunque no tiene tantas pijaditas.
El tema del driver, desinstalando todo lo de Nvidia te cargará el driver libre por defecto, o eso era como solía pasar antes de que se dejara de escribir en el xorg.conf.
Espero serte de ayuda, salu2
__________________

Si tienes el vibrato de BB King, el tapping de Van Halen, la velocidad de Malmsteen y la guitarra de Vai... enhorabuena eres un gran imitador.
Responder Citando
  #3  
Antiguo 24-abr-2011, 13:57
Avatar de xisco
xisco xisco está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 23-marzo-2006
Ubicación: Sector Horchata
Versión: La ultima estable
Mensajes: 1.685
Agradecimientos: 29
Agradecido 157 Veces en 129 Mensajes
Poder de Credibilidad: 13
xisco está en el buen camino
hola
igual con los ultimos drivers de nvidia la version 271 creo. No estan en el repo de nvidia de opensuse todavia, pero los puedes bajar como binario de la web de nvidia

Salu2
Responder Citando
  #4  
Antiguo 26-abr-2011, 07:06
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Cita:
Iniciado por xisco Ver Mensaje
hola
igual con los ultimos drivers de nvidia la version 271 creo. No estan en el repo de nvidia de opensuse todavia, pero los puedes bajar como binario de la web de nvidia

Salu2
He intentado instalarlo, pero me da error la instalación.
Responder Citando
  #5  
Antiguo 27-abr-2011, 11:09
jcsl jcsl está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 18-mayo-2008
Versión: Tumbleweed
Mensajes: 2.104
Agradecimientos: 0
Agradecido 973 Veces en 587 Mensajes
Poder de Credibilidad: 12
jcsl llegará a ser famoso muy pronto
Hola.

Cita:
Iniciado por VaryHeavy Ver Mensaje
La tarjeta gráfica de mi equipo es una Nvidia 6200 GS TurboCache, y he probado a utilizar los drivers x11-video-nvidiaG02 (260.19.44-24.1), x11-video-nvidiaG01 (173.14.28-28.1) y x11-video-nvidia (96.43.19-26.1) con los módulos correspondientes al kernel default de OpenSUSE 11.4, así como con los módulos correspondientes al kernel desktop, sin que en ningún caso haya mejorado la experiencia.
En el único caso en que la experiencia fue distinta (para peor) fue en el caso del driver x11-video-nvidia (con el módulo nvidia-gfx-kmp-default), con el que al activar los efectos de escritorio desaparecían completamente los bordes de todas las ventanas, y volvían a aparecer al desactivar los efectos.
Tu tarjeta de vídeo es reciente, solo deberías usar la versión G02. Supongo también que desinstalarías una versión antes de instalar otra.

Cita:
Iniciado por VaryHeavy Ver Mensaje
Decir también que la aplicación de los Ajustes de NVIDIA del servidor X (nvidia-settings) solo he podido abrirla usando el driver x11-video-nvidia (96.43.19-26.1), mientras que con los otros drivers al querer abrirla desde el menú, el clickar sobre ella no tiene ningún efecto, y al ejecutarla por consola me salta el siguiente mensaje:

Código:
varyheavy@VaryComputer:~> nvidia-settings

ERROR: The attribute 'ForceGenericCpu' specified on line 26 of configuration
       file '/home/varyheavy/.nvidia-settings-rc' cannot be assigned (it is a
       read-only attribute).
Cambia el nombre al archivo y vuelve a ejecutarlo a ver si funciona. Posiblemente está relacionado con haber instalado versiones del controlador que no corresponden con el modelo de tu tarjeta.

Cita:
Iniciado por VaryHeavy Ver Mensaje
También he probado a instalar el xorg-x11-driver-video-nouveau junto con el mesa-nouveau3d pero no sé cómo hacer para que el sistema pase a utilizar este driver :S, ¿cómo se hace el cambio de driver gráfico teniendo más de uno instalado?
Borrando todos los paquetes de NVIDIA se activa el controlador de nouveau automáticamente. Por otro lado, instalar cosas para ver si suena la flauta lleva en más ocasiones a estropicio que a algo positivo (aunque a veces pasa XD). De momento el 3D para el controlador de nouveau (mesa-nouveau3d) se considera experimental y puede no funcionar en absoluto, producir artefactos gráficos o funcionar perfectamente.

Cita:
Iniciado por VaryHeavy Ver Mensaje
Y lo más importante: ¿Qué podría hacer para resolver el problema del renderizado de las ventanas con Compiz?
En Mandriva también estuve usando en su día GNOME + Compiz y nunca tuve problemas de este tipo, todas las ventanas se mostraban correctamente. ¿Qué puede estar pasando en OpenSUSE?
Prueba cambiando las opciones de configuración. Desactiva todos los efectos sin desactivar Compiz y comprueba si se ve bien. Si es así los vas activando uno a uno hasta dar con el que produce el fallo. Yo lo estuve usando un tiempo en sustitución de Kwin y funcionaba perfectamente.

Cita:
Iniciado por VaryHeavy Ver Mensaje
He instalado Compiz de ese repo pero hay dependencias que no están ahí, como por ejemplo el imprescindible compiz-manager, el cual solo está disponible en los repositorios principales y pide como dependencia la versión de Compiz que viene en los repos principales, así que probé a instalar el paquete compiz-manager desde los repositorios principales junto con el Compiz del repo que me has facilitado ignorando las dependencias, y aunque puedo abrir el CCSM, no me deja activar los efectos de escritorio, se ve que lo intenta porque el escritorio hace cosas raras, pero no es capaz de activar los efectos.
Mezclar paquetes de distintas versiones no es una buena idea.

Cita:
Iniciado por VaryHeavy Ver Mensaje
He intentado instalarlo, pero me da error la instalación.
¿Cuál? ¿Qué comandos has usado para instalarlo?

Un saludo.
Responder Citando
  #6  
Antiguo 07-may-2011, 09:01
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Cita:
Iniciado por jcsl Ver Mensaje
¿Cuál? ¿Qué comandos has usado para instalarlo?
El ejecutable de la web oficial de Nvidia para Linux. Y el comando que utilicé para ejecutarlo es:
Código:
# ./nombre_del_controlador
Responder Citando
  #7  
Antiguo 24-abr-2011, 16:03
Avatar de arag
arag arag está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 08-agosto-2010
Ubicación: Venezuela
Versión: Ultima estable con kde
Mensajes: 2.371
Agradecimientos: 204
Agradecido 380 Veces en 327 Mensajes
Poder de Credibilidad: 10
arag está en el buen camino
Enviar un mensaje por MSN a arag Enviar un mensaje por Skype™ a arag
en este repo tienen una version mas estable de compiz que la que viene por defecto
Responder Citando
  #8  
Antiguo 26-abr-2011, 07:05
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Cita:
Iniciado por arag Ver Mensaje
en este repo tienen una version mas estable de compiz que la que viene por defecto
He instalado Compiz de ese repo pero hay dependencias que no están ahí, como por ejemplo el imprescindible compiz-manager, el cual solo está disponible en los repositorios principales y pide como dependencia la versión de Compiz que viene en los repos principales, así que probé a instalar el paquete compiz-manager desde los repositorios principales junto con el Compiz del repo que me has facilitado ignorando las dependencias, y aunque puedo abrir el CCSM, no me deja activar los efectos de escritorio, se ve que lo intenta porque el escritorio hace cosas raras, pero no es capaz de activar los efectos.

Última edición por VaryHeavy; 26-abr-2011 a las 07:10
Responder Citando
  #9  
Antiguo 26-abr-2011, 09:28
Avatar de arag
arag arag está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 08-agosto-2010
Ubicación: Venezuela
Versión: Ultima estable con kde
Mensajes: 2.371
Agradecimientos: 204
Agradecido 380 Veces en 327 Mensajes
Poder de Credibilidad: 10
arag está en el buen camino
Enviar un mensaje por MSN a arag Enviar un mensaje por Skype™ a arag
prueba con este otro repo
Responder Citando
  #10  
Antiguo 26-abr-2011, 16:11
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Cita:
Iniciado por arag Ver Mensaje
prueba con este otro repo
Tampoco es perfecto, pero al menos el Compiz de ese repo va un poco mejor, al menos ya no se ven las líneas defectuosas en medio de la pantalla, aunque siga estando presente la línea negra en las ventanas maximizadas por defecto.

Última edición por VaryHeavy; 26-abr-2011 a las 16:13
Responder Citando
Respuesta

Marcadores

Etiquetas
compiz, gnome, nvidia


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Problema con mi placa de Sonido en OpenSuse 11.2 Prideone Hardware 10 21-ene-2010 11:18
driver nvidia problemas resolucion korn_head Software 13 24-nov-2009 07:58
Xorg 7.2 no soporta 2 tarjetas graficas [SOLUCIONADO] spokkazo Software 43 30-oct-2008 12:29
ayuda con laptop HP dv6420la y driver Nvidia zchronos Hardware 6 28-feb-2008 10:54
Error driver NVidia en openSUSE 10.3 Clufis Hardware 8 12-nov-2007 15:54



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 13:08.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba