Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > General OpenSUSE


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problema al iniciar demonios en el arranque
  #1  
Antiguo 31-mar-2010, 16:07
Avatar de fbon
fbon fbon está desconectado
Aforado
 
Fecha de Ingreso: 31-marzo-2010
Ubicación: Uruguay
Versión: 11
Mensajes: 1
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
fbon está en el buen camino
Enviar un mensaje por MSN a fbon
Question Problema al iniciar demonios en el arranque

Estoy con Suse 11 y me ocurrio lo siguiente:
Instale PostgreSQL 8.3 en el servidor. Luego de las configuraciones basicas y de asegurarme que estaba funcionando correctamente, verifique si el servicio levantaba al iniciar el servidor.
Lo que descubrí es que si bien existia el script /etc/init.d/postgresql este no estaba correctamente configurado (solucionado sin problemas ) y ademas no existian los links correspondientes en rc3.d y rc5.d (que es lo que a mi me interesaba).

Creo los links con el comando ln, obteniendo un resultado similar al de otros servicios que si estaban levantando.
hice : ln -s ../postgresql S12postgresql y no pude hacerlo funcionar.
Si funcionó cuando utilice el comando chkconfig. Este comando me creo los links S07postgresql y K01postgresql.

Mi pregunta especificamente es :
1) porque ambos metodos no son equivalentes ?
2) que mas hace el chkconfig ?
3) La documentacion encontrada me indico que el numero siguiente a la S o la K del link es simplemente para establecer el "orden" de encendido o apagado del servicio. Entonces, ¿ en base a que es chkconfig elabora dichos indices ?

Muchas gracias por sus aportes.
__________________
KERNEL Consultores
Fabio Bon
Desarrollo de Sistemas
Zabala 1327 Of. 402
Tel. (+598 2) 9159336 9156563 Int. 25
bon@kernel.net.uy
Responder Citando
Respuesta

Marcadores

Etiquetas
chkconfig, inicio, runlevel, servicios


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Activado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
problema iniciar suse reky Hardware 2 25-dic-2008 19:51
Problema de red al iniciar SUSE Jugon Internet, Redes y Wireless 6 21-may-2008 01:26
Problema de arranque con GRUB ahorrill Instalación y Actualizaciones 3 04-mar-2008 16:10
iniciar vsftpd en el arranque jaimematsu Software 4 22-mar-2007 19:09
Problema de arranque Suse 9.0 y Xp Gontxall Instalación y Actualizaciones 13 01-ene-2005 01:54



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 12:18.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba