Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problema al ejecutar amarok, yast, ...
  #1  
Antiguo 21-feb-2008, 00:01
0zzy0sbourne 0zzy0sbourne está desconectado
Habitual
 
Fecha de Ingreso: 15-marzo-2005
Mensajes: 155
Agradecimientos: 1
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 10
0zzy0sbourne está en el buen camino
Problema al ejecutar amarok, yast, ...

Hola, estuve mirando por google pero no encontre nada.

La cuestion es la siguiente cuando ejecuto por ejemplo yast o amarok, me da este error:

"symbol_ZSt16__ostream_insertIcSt11char_traitsIcEE RSt13basic_ostreamIT_T0_ES6_PKS3_i, version GLIBCXX_3.4.9 not defined in file libstdc++.so.6 with link time reference"

Como no me deja abrir el yast, con el dvd de instalacion actualice gcc, gccg++, etc.

Alguien me ayuda?

Gracias.
Responder Citando
  #2  
Antiguo 21-feb-2008, 14:53
RedDwarf RedDwarf está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 11-mayo-2006
Versión: openSUSE 12.1
Mensajes: 1.531
Agradecimientos: 0
Agradecido 28 Veces en 25 Mensajes
Poder de Credibilidad: 9
RedDwarf está en el buen camino
- Que hiciste para provocarlo?
- Versión de openSUSE?
- Pasa con cualquier programa hecho en C++?
- rpm -q libstdc++42
- etc.
Responder Citando
  #3  
Antiguo 21-feb-2008, 17:11
0zzy0sbourne 0zzy0sbourne está desconectado
Habitual
 
Fecha de Ingreso: 15-marzo-2005
Mensajes: 155
Agradecimientos: 1
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 10
0zzy0sbourne está en el buen camino
Cita:
Iniciado por RedDwarf
- Que hiciste para provocarlo?
- Versión de openSUSE?
- Pasa con cualquier programa hecho en C++?
- rpm -q libstdc++42
- etc.
Instale gcc3.4 que me hacia falta para que funcionara pemu (aplicacion para emular pix de cisco), ya que decian que no era compatible con gcc4.X, no desinstale gcc4.x.

Tambien me pasa cuando lanzo el yast.

no puedo hacer lo del rpm ahora, que estoy en el trabajo y no tengo mi maquina aqui.
Responder Citando
  #4  
Antiguo 21-feb-2008, 18:35
RedDwarf RedDwarf está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 11-mayo-2006
Versión: openSUSE 12.1
Mensajes: 1.531
Agradecimientos: 0
Agradecido 28 Veces en 25 Mensajes
Poder de Credibilidad: 9
RedDwarf está en el buen camino
Cita:
Iniciado por 0zzy0sbourne
Instale gcc3.4
De que repositorio? O lo hiciste a mano?
Si lo instalaste de un repositorio "rpm -qa --last | head -n 50" vendría bien.
Si lo instalaste a mano probablemente con reinstalar libstdc++42 se solucione. Pero con un "rpm -vV libstdc++42" la cosa quedaría más clara.
Responder Citando
  #5  
Antiguo 21-feb-2008, 19:02
0zzy0sbourne 0zzy0sbourne está desconectado
Habitual
 
Fecha de Ingreso: 15-marzo-2005
Mensajes: 155
Agradecimientos: 1
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 10
0zzy0sbourne está en el buen camino
Cita:
Iniciado por RedDwarf
De que repositorio? O lo hiciste a mano?
Si lo instalaste de un repositorio "rpm -qa --last | head -n 50" vendría bien.
Si lo instalaste a mano probablemente con reinstalar libstdc++42 se solucione. Pero con un "rpm -vV libstdc++42" la cosa quedaría más clara.
Me lo descargue de un ftp de la pagina de gcc.

./configure
make
make install.
Responder Citando
  #6  
Antiguo 23-feb-2008, 11:11
0zzy0sbourne 0zzy0sbourne está desconectado
Habitual
 
Fecha de Ingreso: 15-marzo-2005
Mensajes: 155
Agradecimientos: 1
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 10
0zzy0sbourne está en el buen camino
Cita:
Iniciado por RedDwarf
De que repositorio? O lo hiciste a mano?
Si lo instalaste de un repositorio "rpm -qa --last | head -n 50" vendría bien.
Si lo instalaste a mano probablemente con reinstalar libstdc++42 se solucione. Pero con un "rpm -vV libstdc++42" la cosa quedaría más clara.
Al poner rpm -q libstdc++42, sale lo siguiente libstdc++42-4.2.1_20070724-17.


Con rpm -vV libstdc++42 lo siguiente:

........ /usr/lib/libstdc++.so.6
........ /usr/lib/libstdc++.so.6.0.9


Gracias.
Responder Citando
  #7  
Antiguo 23-feb-2008, 11:23
0zzy0sbourne 0zzy0sbourne está desconectado
Habitual
 
Fecha de Ingreso: 15-marzo-2005
Mensajes: 155
Agradecimientos: 1
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 10
0zzy0sbourne está en el buen camino
Si ejecuto el yast desde consola ocurre esto:
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2wfm.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2wfm.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2scr.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2scr.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2UI.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2UI.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libscr.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libscr.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libycp.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libycp.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libycp.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/liby2.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/liby2.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/liby2.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libycpvalues.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libycpvalues.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libycpvalues.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libblocxx.so.4)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libblocxx.so.4)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libblocxx.so.4)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/liby2util.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/liby2util.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/liby2util.so.3)
/usr/lib/YaST2/plugin/libpy2ncurses.so.2: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2ncurses.so.2)
/usr/lib/YaST2/plugin/libpy2ncurses.so.2: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2ncurses.so.2)
/usr/lib/YaST2/plugin/libpy2ncurses.so.2: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2ncurses.so.2)
/usr/lib/YaST2/plugin/libpy2ncurses.so.2: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2ncurses.so.2)
/usr/lib/YaST2/plugin/libpy2ncurses.so.2: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2UI.so.2)
/usr/lib/YaST2/plugin/libpy2ncurses.so.2: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2UI.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2wfm.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2wfm.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2scr.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2scr.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2UI.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/YaST2/plugin/libpy2UI.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libscr.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libscr.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libycp.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libycp.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libycp.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/liby2.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/liby2.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/liby2.so.2)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libycpvalues.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libycpvalues.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libycpvalues.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libblocxx.so.4)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libblocxx.so.4)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/libblocxx.so.4)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/liby2util.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/liby2util.so.3)
/usr/lib/YaST2/bin/y2base: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/liby2util.so.3)
/usr/lib/YaST2/bin/y2base: relocation error: /usr/lib/liby2.so.2: symbol _ZSt16__ostream_insertIcSt11char_traitsIcEERSt13ba sic_ostreamIT_T0_ES6_PKS3_i, version GLIBCXX_3.4.9 not defined in file libstdc++.so.6 with link time reference



Y si ejecuto amarok

amarok: /usr/local/lib/libstdc++.so.6: no version information available (required by amarok)
amarok: /usr/local/lib/libstdc++.so.6: no version information available (required by amarok)
amarok: /usr/local/lib/libstdc++.so.6: no version information available (required by amarok)
amarok: /usr/local/lib/libstdc++.so.6: no version information available (required by /opt/kde3/lib/libkdeui.so.4)
amarok: /usr/local/lib/libstdc++.so.6: no version information available (required by /opt/kde3/lib/libkdeui.so.4)
amarok: /usr/local/lib/libstdc++.so.6: no version information available (required by /opt/kde3/lib/libkdecore.so.4)
amarok: /usr/local/lib/libstdc++.so.6: no version information available (required by /opt/kde3/lib/libkdecore.so.4)
amarok: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/qt3/lib/libqt-mt.so.3)
amarok: /usr/local/lib/libstdc++.so.6: no version information available (required by /usr/lib/qt3/lib/libqt-mt.so.3)
amarok: /usr/local/lib/libstdc++.so.6: no version information available (required by /opt/kde3/lib/libDCOP.so.4)
amarok: /usr/local/lib/libstdc++.so.6: no version information available (required by /opt/kde3/lib/libDCOP.so.4)
amarok: /usr/local/lib/libstdc++.so.6: no version information available (required by /opt/kde3/lib/libkdefx.so.4)
amarok: /usr/local/lib/libstdc++.so.6: no version information available (required by /opt/kde3/lib/libkdefx.so.4)
amarok: relocation error: amarok: symbol _ZSt16__ostream_insertIcSt11char_traitsIcEERSt13ba sic_ostreamIT_T0_ES6_PKS3_i, version GLIBCXX_3.4.9 not defined in file libstdc++.so.6 with link time reference
Responder Citando
  #8  
Antiguo 23-feb-2008, 13:12
RedDwarf RedDwarf está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 11-mayo-2006
Versión: openSUSE 12.1
Mensajes: 1.531
Agradecimientos: 0
Agradecido 28 Veces en 25 Mensajes
Poder de Credibilidad: 9
RedDwarf está en el buen camino
Vale. Pues borra cualquier cosa relacionada con libstdc++.so.6 de /usr/local/lib y ejecuta "ldconfig".
Con esto debería volver a usar la versión de /usr/lib, que del rpm -vV se ve que está en buen estado, y todo arreglado.
Responder Citando
  #9  
Antiguo 23-feb-2008, 13:35
0zzy0sbourne 0zzy0sbourne está desconectado
Habitual
 
Fecha de Ingreso: 15-marzo-2005
Mensajes: 155
Agradecimientos: 1
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 10
0zzy0sbourne está en el buen camino
Cita:
Iniciado por RedDwarf
Vale. Pues borra cualquier cosa relacionada con libstdc++.so.6 de /usr/local/lib y ejecuta "ldconfig".
Con esto debería volver a usar la versión de /usr/lib, que del rpm -vV se ve que está en buen estado, y todo arreglado.
Solucionado. graciñas.
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Propuesta de solución a la lentitud del YAST keops General OpenSUSE 27 11-oct-2007 19:58
Problema Beryl,errores al ejecutar beryl-manager suses Escritorios: KDE, Gnome, otros... 1 16-mar-2007 20:24
Problema al ejecutar Mplayer shaft_dark Software 4 21-feb-2007 13:56
Yast no Actualiza las fuentes!! neocore General OpenSUSE 2 29-may-2006 10:19
Problema con librerias para ejecutar firefox Fox Software 13 29-ago-2004 23:21



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 10:28.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba