Ver Mensaje Individual
Procedimiento más detallado
  #3  
Antiguo 31-ago-2017, 20:55
juanchusjuan juanchusjuan está desconectado
Aforado
 
Fecha de Ingreso: 04-abril-2014
Versión: 13.1
Mensajes: 10
Agradecimientos: 0
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 0
juanchusjuan está en el buen camino
Procedimiento más detallado

Buenas Tardes, Diablorojo.
Te comento qué pasos son los que sigo:

.Instalación limpia de Opensuse (tanto Tumbleweed como Leap 42.3)

.Luego del primer reinicio (sin drivers privativos y con nouveau que no reconoce la tarjeta gráfica por ser demasiado nueva), ctrl+alt+f2 (terminal)

.Procedo a realizar un zypper ref, luego zypper up, y reiniciar.

.Nuevamente ctrl+alt+f2, terminal, y activo los repositorios de nvidia, packman y libdvdcss.
zypper ref
zypper dup --from packman-inode-at.suse (cambia la versión de varias aplicaciones por las de Packman)
zypper inr (instala las aplicaciones recomendadas).
En el caso de Nvidia, hasta la versión 42.2, en el momento de ejecutar este comando, se instalaba la versión correspondiente del controlador. En la versión 42.3 se debe elegir por separado:
zypper in x11-video-nvidiaG04. Reinicio.

.La resolución por defecto queda en 3840x2160, tanto en sddm como en el escritorio.

.Me identifico con mi usuario, cambio la resolución a 1920x1080 (lo prefiero al escalado), cambio servidor opengl a 3.1, cambio el suavizado de fuentes, cambio la velocidad de los efectos un poco más rápidos, cambio el puerto de salida de sonido hdmi de nvidia (opensuse no lo hace automáticamente, otras distros sí) y controlo el tearing.... horrible.

.Ejecuto nvidia-settings en modo gráfico y genero un archivo xorg.conf (que en la opción metamodes se genera con la resolución elegida por mí. Guardo el archivo como 20-nvidia.conf (arch wiki).

.Abro la terminal, copio como administrador tal archivo en /etc/X11/xorg.conf.d/ o en /usr/share/X11/xorg.conf.d.

.En los escritorios plasma de Debian, Arch, Manjaro, Chakra, Kubuntu, obtengo un sddm de 1920x1080, igual que en el escritorio. El tearing desaparece y mi escritorio es totalmente funcional.

.En Opensuse Leap 42.3, o en Tumbleweed (instalando Nvidia a la "hard way"), el resultado será pantalla negra, consola, letras que titilan, imposibilidad de escribir mi usuario y contraseña. Al reiniciar, en modo seguro, el mismo resultado.
Me queda iniciar con una distro live tipo Ubuntu, PartedMagic u otra, borrar el archivo 20-nvidia.conf y cruzar los dedos para que Opensuse no se me haya "ofendido mucho".

.He probado cambiando la definición en metamodes a auto. Las X inician, pero con la máxima resolución, no como en el caso de las distros nombradas arriba, que respetan lo que mi archivo de configuración indica.

. Las versiones de nvidia varían entre la 370 y la 384, siendo Opensuse la única que usa esta última por defecto. El próximo intento será ver cómo cambiar la versión a una más antigua, como la que usan en las otras distros.

Hice la prueba de nvidia-xconfig -query-gpu-info y la respuesta es la correcta,
Number of GPUs: 1

GPU #0:
Name : GeForce GTX 1050 Ti
UUID : GPU-d127e0d8-89ad-ec87-f2fb-0ed055f18495
PCI BusID : PCI:1:0:0

Number of Display Devices: 1

Display Device 0 (TV-1):
EDID Name : SAMSUNG
Minimum HorizSync : 15.000 kHz
Maximum HorizSync : 81.000 kHz
Minimum VertRefresh : 24 Hz
Maximum VertRefresh : 75 Hz
Maximum PixelClock : 594.000 MHz
Maximum Width : 4096 pixels
Maximum Height : 2160 pixels
Preferred Width : 3840 pixels
Preferred Height : 2160 pixels
Preferred VertRefresh : 30 Hz
Physical Width : 1050 mm
Physical Height : 590 mm
Responder Citando