Ver Mensaje Individual
SuSE 9.2, monitor nuevo, out of range: ni por esas
  #1  
Antiguo 01-sep-2006, 02:19
kuser
Invitado
 
Mensajes: n/a
SuSE 9.2, monitor nuevo, out of range: ni por esas

Saludos , soy nuevo en el foro. Y aunque tengo nociones básicas de linux (¿cuánto será lo básico en linux?) no llevo mucho tiempo peleándome con el. Después de indagar por la red, creo que mi problema es bastante común, y aun así las diferentes soluciones que he encontrado no han solucionado mi problema: cúando arranco mi SuSE 9.2 la pantalla se pone negra, aparece el mensaje "out of frecuency" y no aparecía la pantalla para logear. Explicaré como he intentado solucionarlo y agradeceré si alguien sabe que puedo hacer. Disculpas con antelación por la chapa que voy a meter.

Al principio, mi entrada en el grub era este:
kernel (hd0,5)/boot/vmlinuz root=/dev/hda6 selinux=0 x11i=vesa splash=silent resume=/dev/hda5 desktop elevator=as showopts

Primero cambie a "splash=0" o native, por si acaso, cosa que tampoco sirvió para solucionarlo, pero lo he dejado así porque para el caso creo que es mejor.

Luego intente poner el arranque en modo texto, para lo cual quité la referencia "x11i=vesa" y puse "textmode=1" (lo saqué observando el arranque de Knoppix), también probé con "x11i=textmode" y "x11i=text", sin conseguir nada; así que desistí de desviar el problema y arrancarlo en modo texto.

Leí por ahí que podría solucionarse cambiando la resolución con "ctrl+alt+(+,-)" que tampoco funciono. Además estoy bastante seguro de que el problema deriva de la frecuencia de refresco, ya que la pantalla de "out of frecuency" da unos valores de refresco de frecuencia que he comprobado que mi monitor no soporta.

Luego leí que a muchos les funciona el problema poniendo "vga=normal" en el comando de arranque, así que he borrado el "x11i" y lo he dejé asi:
kernel (hd0,5)/boot/vmlinuz root=/dev/hda6 selinux=0 vga=normal splash=0 resume=/dev/hda5 desktop elevator=as showopts

De este modo, "vga=normal", no me salé la pantalla "out of frecuency" y veo como se va cargando el kernel; pero cuando debería aparecer la pantalla gráfica, la pantalla se funde en negro y no puedo logear; tampoco cambiaba a la consola de comandos con "ctrl+alt+F1, F2...", aunque tampoco sería solucionar el problema sino esquivarla.

Luego leí por ahí que se podría solucionar dando valores a "vga" segun la resolución y paleta de colores que puede soportar el ordenador, por ejemplo "vga=791" para 1024x768 a 16 bits, que según la documentación del monitor soporta. De este modo, al arrancar sigue poniéndose la pantalla en negro con el mensaje "out of range"; pero después de cargar el kernel, desaparece el mensaje justo para cargar la pantalla gráfica del login. Pero es una solución a medias, y tampoco veo la carga del kernel y los posibles errores.

Después de haber conseguido cargar el SuSE de una vez, siguiendo otros consejos que encontré en Internet, he ejecutado mediante YaST el SaX2 y confirmado que la tarjeta gráfica estaba bien, que las frecuencias y resoluciones son las que el monitor soporta y recomienda. Incluso he puesto las mismas propiedades tanto en el SaX2 como en el menú del Grub. También he confirmado que los datos del monitor en el archivo XF86config son correctos (sin hacer cambios). Pero esto no ha cambiado nada.

Por lo tanto, en este momento, esta es la entrada en el Grub:
kernel (hd0,5)/boot/vmlinuz root=/dev/hda6 selinux=0 vga=791 splash=0 resume=/dev/hda5 desktop elevator=as showopts

¿Alguien sabe que está mal?
Gracias.
Responder Citando