Ver Mensaje Individual
  #2  
Antiguo 24-feb-2015, 19:54
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.842
Agradecimientos: 2.038
Agradecido 1.534 Veces en 1.290 Mensajes
Poder de Credibilidad: 10
mikrios llegará a ser famoso muy pronto
Hola:

Por lo de la actualización es normal (en mi caso de la versión del día 5 de este mes, ayer actualice y me salieron 473 actualizaciones , con los mismos repos que tu tienes, y eso que tu partes de una versión anterior ) .

Están todas en /usr y te ha mantenido algunas de las aplicaciones de la 12.3 y por eso presenta conflicto.

Ya sea por medio de zypper o bien desde yast (pueden que algunas aparezcan en rojo, si es así las que estén en rojo dale actualizar a una versión superior o actualizar siempre (no se si te saldrá alguna ventana para indicarte que es lo que tienes que hacer ) .

No se si es una buena idea, pero desde Yast en mi configuración siempre tengo en opciones puesto o marcado que limpie durante la eliminación de paquetes (ademas de modo verificación del sistema y lo del cambio de proveedor ).

En extras Yast (del instalador de software) tienes lo de restablecer los conflictos de dependencias ignorados y en dependencias lo de comprobar ahora.

El tema es que esos archivos de la 12.3 tienen que eliminarse, ya sea mediante zypper o yast y sustituirlos por las versiones de tumbleweed .

( de ahí esta porque prefiero una actualización nueva, mediante la instalación nueva, conservando el home y sus configuraciones, es por eliminar toda la basura y programas de versiones anteriores y dejar una raíz completamente nueva) .

En mi caso para eliminar paquetes o actualizar (o arreglar dependencias), busco la aplicación y no sus librerías .

Creo que la 1ª pueda ser
Código:
X79-PRO:~ # zypper search --provides --match-exact db48-utils
Loading repository data...
Reading installed packages...

S | Name       | Summary                                               | Type   
--+------------+-------------------------------------------------------+--------
i | db48-utils | Command Line tools for Managing Berkeley DB Databases | package
La 2ª
Código:
X79-PRO:~ # zypper se -si   bundle-lang-gnome
Loading repository data...
Reading installed packages...

S | Name                 | Type    | Version   | Arch   | Repository
--+----------------------+---------+-----------+--------+-----------
i | bundle-lang-gnome-en | package | 13.2-7.21 | noarch | repo-oss  
i | bundle-lang-gnome-es | package | 13.2-7.21 | noarch | repo-oss
Creo que la afectada solo sea la de bundle-lang-gnome-en


Estas creo que es la actual y las otras entran en conflicto con la anterior.

Una prueba podría ser reinstalar de nuevo eso o forzar las instalación (no se si pudiera funcionar), puede que salga que entra en conflicto con tal cosa, pues elijo que instale eso y que borre las otras (que me supongo que serán la de la versión 12.3) .

Si no es primordial y no va afectar al sistema, podría eliminarla (con la opción que dije antes de limpiar al eliminar) y después volverla a instalar (pero si veo que puede afectar a partes del sistema, intento buscar otra solución, bueno de ahí si que echo de menos la opción de yast de mostrar la información del sitema de resolución , actualmente indisponible , por problemas de dependencias) .

Casi todas las dependencias que tienes o conflicto son sobre esas 2, creo que cumpliendo las principales, las otras se eliminan y se pueda resolver el conflicto (sería una lata hacerlo una por una, pero la mayoría están ligadas a db48-utils y bundle-lang-gnome-en) .

Vamos a ver las otra que creo que es libkipi11-14.12.2-1.1.x86_64(repo-oss) , que por ahora no he podido comprobarla por consola por un problema de verificación (de la cual voy abrir un tema en el foro, sobre esto, por si le sucede a alguien mas y que medidas debemos tomar ) .

Resumiendo creo que son 3 las implicadas y que resolviendo esto todas las demás (66) queden solucionadas .

Saludos cordiales

Edito:
Ahora mismo está saliendo una actualización de bundle-lang-gnome (mira si eso puede resolver el problema con él y se quita una del problema de las dependencias) .
Bueno el problema, cuando estaba comprobando las librerías de las que tienes afectadas es que cambio la suma de verificación de los repositorios, dando una señal de alerta (pero es que estaba pendiente algunas actualizaciones que resolvía ese problema y la alerta ya se quito .
Código:
Warning: Digest verification failed for file 'app-icons.tar.gz'
[/var/cache/zypp/raw/repo-osskLbX5O/suse/setup/descr/app-icons.tar.gz]

  expected 54d352c8ad74c4365457c5006c159dade7f97de2c2e4008fb86169ebd2d40350
  but got  6a0e7824426c20f1fda9fd3a499b21e92946cacd613e80739675bd40f64ad408

Accepting packages with wrong checksums can lead to a corrupted system and in extreme cases even to a system compromise.

However if you made certain that the file with checksum '6a0e..' is secure, correct
and should be used within this operation, enter the first 4 characters of the checksum
to unblock using this file on your own risk. Empty input will discard the file.

Unblock or discard? [6a0e/? shows all options] (discard):
Creo que fue algún cambio del repo de oss (al actualizar se quito , no creo que sea necesario abrir tema de esto ) .

La 3ª es esta :
Código:
X79-PRO:~ # zypper se -si libkipi11
Loading repository data...
Reading installed packages...

S | Name      | Type    | Version     | Arch   | Repository
--+-----------+---------+-------------+--------+-----------
i | libkipi11 | package | 14.12.2-1.1 | x86_64 | repo-oss
Esas 3 son las implicadas y las que he puesto, incluida está última creo que serían las que deben estar .

Saludos

Última edición por mikrios; 24-feb-2015 a las 21:10 Razón: añadir
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
enae (25-feb-2015)