Ver Mensaje Individual
  #18  
Antiguo 26-mar-2015, 06:43
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.551
Agradecimientos: 1.916
Agradecido 1.417 Veces en 1.187 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Hola:

Pues claro.

1º - Para saber si hay actualizaciones openSUSE, te las va a notificar a medida que salgan.

2º - Ya de ahí puedes elegir el método que quieras usar :

a) -- Desde el propio notificador .
b) -- Desde preferencias del sistema , por medio de apper
c) -- Sin hacer nada desde Yast ( si tienes configurado las auto actualizaciones automaticas) .
d) -- Desde Yast en actualizaciones en linea.
e) -- Desde consola (zypper ref ---> refrescas los repositorios y zypper up ---> actualizas el sistema .

El sistema tiene programado unos tiempos, desde los cuales revisa si hay cambios o versiones nuevas, también se pone en marcha cada vez que enciendes el pc ( Packagekit ) ; mientras ese proceso está en marcha (no te va a dejar hacer actualizaciones desde consola , ni de yast ). Por que así es como esta configurado por defecto . en su caso , tendrías que matar ese proceso para tu actualizar desde consola o poder abrir el actualizador de yast .

Código:
X79-PRO:~ # zypper se -si PackageKit
Loading repository data...
Reading installed packages...

S | Name                           | Type    | Version   | Arch   | Repository      
--+--------------------------------+---------+-----------+--------+-----------------
i | PackageKit                     | package | 1.0.5-1.1 | x86_64 | openSUSE:Factory
i | PackageKit                     | package | 1.0.5-1.1 | x86_64 | repo-oss        
i | PackageKit-backend-zypp        | package | 1.0.5-1.1 | x86_64 | openSUSE:Factory
i | PackageKit-backend-zypp        | package | 1.0.5-1.1 | x86_64 | repo-oss        
i | PackageKit-browser-plugin      | package | 1.0.5-1.1 | x86_64 | openSUSE:Factory
i | PackageKit-browser-plugin      | package | 1.0.5-1.1 | x86_64 | repo-oss        
i | PackageKit-gstreamer-plugin    | package | 1.0.5-1.1 | x86_64 | openSUSE:Factory
i | PackageKit-gstreamer-plugin    | package | 1.0.5-1.1 | x86_64 | repo-oss        
i | PackageKit-gtk3-module         | package | 1.0.5-1.1 | x86_64 | openSUSE:Factory
i | PackageKit-gtk3-module         | package | 1.0.5-1.1 | x86_64 | repo-oss        
i | libpackagekit-glib2-18         | package | 1.0.5-1.1 | x86_64 | openSUSE:Factory
i | libpackagekit-glib2-18         | package | 1.0.5-1.1 | x86_64 | repo-oss        
i | libpackagekitqt4-0             | package | 0.9.5-1.2 | x86_64 | openSUSE:Factory
i | libpackagekitqt4-0             | package | 0.9.5-1.2 | x86_64 | repo-oss        
i | typelib-1_0-PackageKitGlib-1_0 | package | 1.0.5-1.1 | x86_64 | openSUSE:Factory
i | typelib-1_0-PackageKitGlib-1_0 | package | 1.0.5-1.1 | x86_64 | repo-oss        
i | PackageKit-branding-openSUSE   | package | 13.2-5.4  | noarch | openSUSE:Factory
i | PackageKit-branding-openSUSE   | package | 13.2-5.4  | noarch | repo-oss
El tema es que se podría pensar que PackageKit, tienen una función en el sistema en la parte del cron , eso es cierto pero no está habilitado, pero en la parte de su configuración lo hace, a pesar de que este no lo esta ( ejemplo de ello lo podemos ver en yast en /etc/sysconfig); en el apartado de system---cron---PakageKit , ahí vemos que no está habilitado) .

Pero creo que eso está corriendo en 2º plano (backgraund) y por eso no lo apreciamos, (hace tiempo di con el archivo de configuración que era el que seleccionaba el método de actualización pero al no tomar nota, pues ya no me acuerdo cual era) .

Pero se que cada cierto tiempo hace una comprobación de si existen actualizaciones (algunos de los ejemplos los podemos encontrar en /etc/yast2 y si es de los repositorios que tenemos añadidos en /etc/zypp/repos.d/.

El tema es que openSUSE, sin necesidad del usuario, siempre es notificado de que existe actualizaciones, en los archivos de configuración esta de forma que una vez avisado devuelve el control al usuario (es decir que estas se tienen que hacer de forma manual ) y este debe proceder a usar los puntos que se indican a),b),c),d) y e) .

Es decir todo es automático , pero el control después es manual ; excepto que se programe en Yast, la actualización de forma automática sin control del usuario (el sistema se actualiza sin necesidad de ninguna operación del usuario, claro esta que algunas requieren que se cierre la sesión, o de posibles reinicio del pc, para que surjan efecto, ejemplo el del kernel y alguna otra) .

La versión de tumbleweed, es una versión tipo 13.2 estable, de la cual utiliza las últimas versiones de los programas estables (cada cierto tiempo se hace un test del sistema, openQA, de ahí pasa después otras pruebas y de ellas se hace una iso nueva ).

No es necesario actualizar desde la iso, sencillamente cuando se crea una iso nueva , la actual que tienes instalada, salen o el notificador te informa que hay actualizaciones, una vez que la actualices el sistema tuyo pasa o tener la versión de esa iso .

Si estas en kde lo puedes ver como cambia la versión de tumbleweed en la pagina principal de KinfoCenter, o bien desde consola con algún otro comando, un ejemplo podría ser este :
Código:
X79-PRO:~ # cat /etc/issue
Welcome to openSUSE 20150319 "Tumbleweed" - Kernel \r (\l).
O sea tengo la versión de la fecha de 19-03-2015 , esto suele coincidir con las versiones que te encuentras en : http://download.opensuse.org/tumbleweed/iso/ y corresponde a la instantánea que se ha hecho de openSUSE-Tumbleweed-DVD-x86_64-Snapshot20150319-Media.iso ; aunque te bajes la openSUSE-Tumbleweed-DVD-x86_64-Current.iso , en realidad es la misma (puedes ver su md5, para ellos haces click en detalles y lo puedes ver, ademas puedes ver los ficheros de texto donde se informa de los cambios de esa versión ) .

Los compañeros y los moderadores te han dado unos consejos muy importantes (ademas que hay algunos tutoriales hecho por ellos que informan de estas cosas) , teniendo eso configurado correctamente , uno puede dejar de preocuparse del tema de las actualizaciones (el sistema se va encargar de todo y puedes estar años con el sin ningún tipo de contratiempo ) .

Uno de los que se te ha comentado es lo de las prioridades en los repositorios (eso es muy importante para evitar conflictos, el ejemplo de poner a packman a 70 (número mas bajo es prioridad mas alta), es para que cuando actualices coja las versiones de ese repositorio y no de otro (a pesar de que el otro tenga una versión superior)

Packman provee del software o programas sin las limitaciones legales que no puede incluir ese otro repositorio, como por ejemplo los codecs multimedia (es preferible el tener un programa que puede reproducir todo tipo de archivos de vídeo a otro que no lo puede hacer por esa limitación legal) .

Otro consejo que han dado en el foro, es que si instalas un programa desde la paginas de descargas de openSUSE y el repositorio de esa programa no es oficial, pues no mantener ese repositorio en la lista de configuración de tu sistema (para que una posible actualización del mismo, no pueda crear conflictos con los repos oficiales ) .

También si instalas repositorios como puedan ser el del kernel estable estándar, el de impresión, el de VirtualBox de Oracle, también le aumentes la prioridad a ellos .

Una vez configurado eso, ya uno puede dejar de preocuparse de tener conflictos .

También puedes configurar la actualización en linea , para que el sistema se encargue de actualizar de forma automática , para ello es necesario instalar : yast2-online-update-configuration :



Vamos openSUSE, ofrece muchas opciones, por la cual uno puede despreocuparse, de estar continuamente buscando actualizaciones, si las hay, ten por seguro que se te van a notificar, si no quieres preocuparte de instalarlas, o pasar por el tema de hacerlo cuando se te avisa, pues puedes dejar al sistema que lo haga por ti.

Espero que esto te aclare un poquito mas lo que se ha comentado .

Saludos cordiales

Última edición por mikrios; 26-mar-2015 a las 06:50 Razón: corregir
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
joakoej (27-mar-2015)