Ver Mensaje Individual
AMD Catalyst 13.11 Beta V6 Driver for Linux
  #1  
Antiguo 06-nov-2013, 00:47
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-julio-2005
Ubicación: Atlántida
Versión: leap 42.1
Mensajes: 851
Agradecimientos: 187
Agradecido 323 Veces en 221 Mensajes
Poder de Credibilidad: 13
soyasi está en el buen camino
AMD Catalyst 13.11 Beta V6 Driver for Linux

AMD Catalyst 13.11 Beta V6 Driver for Linux

Código PHP:
Build the RPM package now ... |/-\|/-\| 

ln -s aticonfig /usr/src/packages/BUILDROOT/fglrx64_xpic_SUSE123-13.25.18-1.x86_64/usr/bin/amdconfig
install -m 644 usr/include/ATI/GL/glx.h usr/include/ATI/GL/glxext./usr/src/packages/BUILDROOT/fglrx64_xpic_SUSE123-13.25.18-1.x86_64/usr/include/ATI/GL
install -m 644 usr/include/GL/glATI.h usr/include/GL/glxATI./usr/src/packages/BUILDROOT/fglrx64_xpic_SUSE123-13.25.18-1.x86_64/usr/include/GL
install -m 755 usr/lib64/dri/fglrx_dri.so /usr/src/packages/BUILDROOT/fglrx64_xpic_SUSE123-13.25.18-1.x86_64/usr/lib64/dri
rm -rf usr/lib64/dri
install -m 755 usr/lib64/fglrx/switchlibGL usr/lib64/fglrx/switchlibglx /usr/src/packages/BUILDROOT/fglrx64_xpic_SUSE123-13.25.18-1.x86_64/usr/lib64/fglrx
rm -rf usr/lib64/fglrx
install -m 755 usr/lib64/xorg/modules/drivers/fglrx_drv.so /usr/src/packages/BUILDROOT/fglrx64_xpic_SUSE123-13.25.18-1.x86_64/usr/lib64/xorg/modules/drivers
install -m 755 usr/lib64/xorg/modules/linux/libfglrxdrm.so /usr/src/packages/BUILDROOT/fglrx64_xpic_SUSE123-13.25.18-1.x86_64/usr/lib64/xorg/modules/linux
install -m 755 usr/lib64/xorg/modules/updates/extensions/fglrx/fglrx-libglx.so /usr/src/packages/BUILDROOT/fglrx64_xpic_SUSE123-13.25.18-1.x86_64/usr/lib64/xorg/modules/updates/extensions/fglrx
rm -rf usr/lib64/xorg/modules/drivers usr/lib64/xorg/modules/linux usr/lib64/xorg/modules/updates
install -m 755 usr/lib64/xorg/modules/amdxmm.so usr/lib64/xorg/modules/glesx.so /usr/src/packages/BUILDROOT/fglrx64_xpic_SUSE123-13.25.18-1.x86_64/usr/lib64/xorg/modules
rm -rf usr/lib64/xorg
install -m 755 usr/lib64/hsa usr/lib64/libAMDXvBA.cap usr/lib64/libAMDXvBA.so.1.0 usr/lib64/libOpenCL.so.1 usr/lib64/libXvBAW.so.1.0 usr/lib64/libamdocl64.so usr/lib64/libamdsc64.so usr/lib64/libatiadlxx.so usr/lib64/libaticalcl.so usr/lib64/libaticaldd.so usr/lib64/libaticalrt.so usr/lib64/libatiuki.so.1.0 /usr/src/packages/BUILDROOT/fglrx64_xpic_SUSE123-13.25.18-1.x86_64/usr/lib64
install
omitting directory 'usr/lib64/hsa'
errorBad exit status from /var/tmp/rpm-tmp.vP6fCF (%install
Hoy he ido a probar el nuevo driver Beta y me ha dado este error, a alguien mas le ha pasado antes de reportarlo, no se que sea un fallo mio, que últimamente no ando muy fino jejejeje

Cita:
fglrx-kernel-build.sh

Used CPUs/Cores for compilation => [ 4 ]


************************************************** ******************************
* *
* Kernel: 3.12.0-1.ge8fa6b4-desktop *
* Source: /lib/modules/3.12.0-1.ge8fa6b4-desktop/build *
* Include: /lib/modules/3.12.0-1.ge8fa6b4-desktop/source/include *
* *
************************************************** ******************************



file /lib/modules/3.12.0-1.ge8fa6b4-desktop/source/include/../arch/x86/include/asm/compat.h says:COMPAT_ALLOC_USER_SPACE=arch_compat_alloc_use r_space
/usr/src/kernel-modules/fglrx/2.6.x /usr/bin
rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
make: Entering directory `/usr/src/linux-3.12.0-1.ge8fa6b4-obj/x86_64/desktop'
LD /usr/src/kernel-modules/fglrx/2.6.x/built-in.o
CC [M] /usr/src/kernel-modules/fglrx/2.6.x/firegl_public.o
CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_acpi.o
CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_agp.o
CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_debug.o
CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_ioctl.o
CC [M] /usr/src/kernel-modules/fglrx/2.6.x/kcl_io.o
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function 'KCL_GetEffectiveUid':
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:1750:5: error: incompatible types when returning type 'kuid_t' but 'KCL_TYPE_Uid' was expected
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function 'KCL_GetInitKerPte':
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2624:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2627:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2632:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function 'KCL_GetPageTableByVirtAddr':
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2691:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2696:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2702:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function 'KCL_GetPageSizeByVirtAddr':
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2760:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2765:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:2771:5: warning: return makes integer from pointer without a cast [enabled by default]
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c: In function 'KCL_GetEffectiveUid':
/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.c:1754:1: warning: control reaches end of non-void function [-Wreturn-type]
make[3]: *** [/usr/src/kernel-modules/fglrx/2.6.x/firegl_public.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[2]: *** [_module_/usr/src/kernel-modules/fglrx/2.6.x] Error 2
make[1]: *** [sub-make] Error 2
make: *** [all] Error 2
make: Leaving directory `/usr/src/linux-3.12.0-1.ge8fa6b4-obj/x86_64/desktop'

******************************
Build of kernel module failed!
******************************

rm -rf *.c *.h *.o *.ko *.a .??* *.symvers
/usr/bin
Calling 'depmod -a 3.12.0-1.ge8fa6b4-desktop' this may take a while...


Summary report:
================================================== ==============================

Kernel => 3.12.0-1.ge8fa6b4-desktop
Detected => RPM package
Build => [ FAILURE ]
Install => [ FAILURE ]
Pues nada, no hay forma, solo he podido generarlo sin problemas hasta el kernel 3.11.6
__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 42.1 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)

Última edición por soyasi; 08-nov-2013 a las 21:31
Responder Citando