Ver Mensaje Individual
Problemas con IOMMU y AMD
  #1  
Antiguo 23-sep-2013, 04:51
Avatar de netSys
netSys netSys está desconectado
Aforado
 
Fecha de Ingreso: 15-agosto-2012
Ubicación: España, Islas Canarias.
Versión: Tumbleweed
Mensajes: 20
Agradecimientos: 33
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
netSys está en el buen camino
Enviar un mensaje por Skype™ a netSys
Unhappy Problemas con IOMMU y AMD

Buenas, cada vez que arranco el sistema en el dmesg me aparecen los siguientes mensajes:

Cita:
[ 0.000000] Your BIOS doesn't leave a aperture memory hole
[ 0.000000] Please enable the IOMMU option in the BIOS setup
[ 0.170649] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[ 0.241938] ACPI: Using IOAPIC for interrupt routing
[ 1.073861] hpet0: at MMIO 0xfed00000, IRQs 2, 8, 0
[ 1.785493] PCI-DMA: More than 4GB of RAM and no IOMMU
[ 1.785495] More than 4GB of memory but GART IOMMU not available.
[ 1.785497] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[ 1.785500] software IO TLB [mem 0xbb8bd000-0xbf8bcfff] (64MB) mapped at [ffff8800bb8bd000-ffff8800bf8bcfff]
[ 1.835941] libphy: Fixed MDIO Bus: probed
[ 7.948652] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 9.220049] ACPI Warning: 0x0000000000000b00-0x0000000000000b07 SystemIO conflicts with Region \_SB_.PCI0.SMBS.SMB0 1 (20120913/utaddress-251)
[ 9.227334] AMD IOMMUv2 driver by Joerg Roedel <joerg.roedel@amd.com>
[ 9.227338] AMD IOMMUv2 functionality not available on this system
[ 9.330415] acpi-cpufreq: overriding BIOS provided _PSD data
[ 16.416619] vboxpci: IOMMU not found (not registered)
Y la verdad me preocupa porque sobre todo utilizo el portátil para trabajar con software de virtualización como VirtualBox, y según esto IOMMU no aparece habilitado y mucho menos no "lo encuentra"....

Ya he probado activarlo mediante los siguientes parámetros en la línea de kernel:
  • iommu=on
  • iommu=calgary
  • iommu=noagp

Y sin resultado.

Cita:
[ 0.000000] Please enable the IOMMU option in the BIOS setup
En la BIOS del portátil, aparece un menú sobre activar las extensiones de virtualización AMD-V las cuales están activadas pero no muestra nada de IOMMU....

Añado que la BIOS está actualizada a la versión reciente. F.26

BIOS.txt Información sacada de dmidecode

uname -a: Linux linux-the0.site 3.7.10-1.16-desktop #1 SMP PREEMPT Fri May 31 20:21:23 UTC 2013 (97c14ba) x86_64 x86_64 x86_64 GNU/Linux

Sistema: openSUSE 12.3 (Dartmouth) (x86_64)

¿Alguna ayudita? ¡Gracias!
Responder Citando