Ver Mensaje Individual
Problema cliente NFS no monta carpetas en el booteo(Solucionado)
  #1  
Antiguo 14-oct-2010, 14:34
Gustavok Gustavok está desconectado
Aforado
 
Fecha de Ingreso: 01-octubre-2010
Versión: 11
Mensajes: 4
Agradecimientos: 1
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
Gustavok está en el buen camino
Post Problema cliente NFS no monta carpetas en el booteo(Solucionado)

Hola comunidad, quería compartir con ustedes un problema que me llevó varios días de googlear hasta poder encontrarle una solución.

El problema se da cuando configuramos el cliente NFS para que monte carpetas al iniciar el sistema.

Lo que ocurre es que cuando iniciamos sesión ,las carpetas montadas no están accesibles, teniendo que reiniciar el servicio NFS para que se monten correctamente.

Esto es un gran problema si una de las carpetas que montamos desde el servidor es la carpeta /home, ya que al loguearse no se puede levantar el escritorio y nos da el siguiente error

"kstartupconfig4 does not exist"

teniendo que abrir una terminal como root para reniciar nfs

LA SOLUCION:
entramos a una terminal
$ su
$ pass de root
$ vi /etc/init.d/nfs

apretamos la letra i para entra en modo insert
nos movemos con las flechitas del cursor hasta la linea que dice:
echo -n "Starting NFS client services: y escribimos abajo sleep 30, nos quedaría así:

echo -n "Starting NFS client services:
sleep 30

luego apretamos ESC para salir de modo insert
luego :w para guardar
y luego :q para salir

Ahora reiniciamos y comprobamos que las carpetas se montan correctamente al iniciar el sistema

Lo que hacemos con sleep 30 es darle unos segundos al sistema para que inicie correctamente la interfaz de red para luego poder montar las carpetas del nfs

Si aun no se montan pueden probar con sleep 60

Última edición por Gustavok; 15-oct-2010 a las 21:50
Responder Citando