ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   General OpenSUSE (http://www.forosuse.org/forosuse/forumdisplay.php?f=23)
-   -   Problema en el Reloj con Tumbleweed (Snapshot: 2016-09-28)... (http://www.forosuse.org/forosuse/showthread.php?t=33729)

camibohp 01-oct-2016 06:08

Problema en el Reloj con Tumbleweed (Snapshot: 2016-09-28)...
 
Recientemente instalé la snapshot 2016-09-28 de Tumbleweed, en mi laptop ThinkPad R61i. Pero en esta oportunidad, no lo hice como una actualización directa (zypper dup o up). Sinó que quise hacer una instalación desde cero, usando una USB con esta snapshot, con el fin de instalar LXDE como único entorno de escritorio, ya que con KDE la laptop demanda mucho recurso de procesamiento, y en consecuencia quien sufre es la batería.

El problema está en que al finalizar la instalación, el reloj del sistema, se fija forzozamente en UTC y no permite ajustar el reloj a mi zona horaria (UTC -05:00). :confused:

En la captura de pantalla que pueden observar a través de este link en google drive, se puede apreciar en segundo plano, la zona horaria para la cual se supone está configurado mediante YaST (Bogotá, Colombia). Y en primer plano, el resultado de los comandos 'hwclock' y 'date'.

En lo que respecta a la configuración de NTP para el ajuste del reloj a través de internet, tengo configurado solo dos servidores...
  • 'horalegal.inm.gov.co': Este servidor es el que emite la hora legal en todo Colombia.
  • 'time.nist.gov': Servidor de contingencia en caso de que el primero no se encuentre disponible.
...El ajuste por NTP lo tengo configurado a intervalos de 15 minutos, esto con el fin de no saturar los servidores.

Intenté una instalación por defecto con LXDE, sin realizar ninguna personalización ni un posterior cambio en la configuración, pero el problema persiste.

A alguien le está sucediendo, o le ha sucedido lo mismo ???... Saben como, solucionarlo ???

De antemano, les agradezco cualquier ayuda.

DiabloRojo 01-oct-2016 15:59

Parece un bug si no te deja ajustar el reloj a mi zona horaria, supongo que es la opción Hardware Clock...

camibohp 02-oct-2016 05:36

Solucionado el problema...
 
El bug que menciona @Diablo (Y que logré encontrar anoche mismo), no es más que el enlace simbólico 'localtime' ubicado en '/etc' y que estaba direccionado hacia una ruta y archivo inexistentes.

Fue sólo cuestión de borrar el enlace defectuoso, y crear un nuevo enlace está vez apuntando a '/usr/share/zoneinfo/America/Bogota' y voilà !!!

Ubicado en '/etc' con el usuario 'root' el comando que usé fue:

Cita:

Código:

root@host:/etc/# ln -s /usr/share/zoneinfo/America/Bogota localtime

Si alguien tiene el mismo problema, es sólo cuestión de que sigan el mismo procedimiento, y al comando para crear el enlace, le modifican la ruta, según su zona horaria. Revisen el contenido de la carpeta 'zoneinfo' para poder estar seguros de su zona horaria.

Espero mi solución les sea de utilidad !!!


La franja horaria es GMT +2. Ahora son las 08:50.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!