ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   Hardware (http://www.forosuse.org/forosuse/forumdisplay.php?f=4)
-   -   Necesito ayuda con el arranque del kernel (http://www.forosuse.org/forosuse/showthread.php?t=33618)

jabyr 02-ago-2016 02:03

Necesito ayuda con el arranque del kernel
 
hola buenas. hace algunas semanas que instale opensuse y me di cuenta que se demoraba en iniciar el sistema pense que se debia a procesos de kde como graficos y efectos de menu etc. pero me percate que no era eso por que un dia inicie el sistema con el supergrub 2 ya que se me habia dañado el grub. y me cargo con el detalle de los servicios y procesos del sistema. la cosa es que me salia un directorio con extencion (device) donde tenia que esperar 1:30 para que siguiera cargando. que puedo hacer para reparar ese problema gracias

inicio de kernel por defecto 4.1

DiabloRojo 02-ago-2016 13:46

¿Que usas Leap o Tumbleweed?. Este tema te dará información util para ver los tiempos de los procesos. Cuando hablas de que esta dañado un directorio, explicate y reporta los mensajes.

jabyr 03-ago-2016 02:20

escribí el siguiente comando como decia en el post y me aparece la siguiente info uso open suse leap 42.1 que puedo hacer para arregrar la carga de dicho driver saludos



systemd-analyze blame
6.333s dev-sda6.device
2.264s systemd-rfkill@rfkill0.service
2.165s postfix.service
1.994s systemd-rfkill@rfkill1.service
1.914s systemd-fsck@dev-disk-by\x2duuid-7ba...8110d.s ervice
1.714s display-manager.service
1.386s dev-hugepages.mount
1.386s systemd-journald.service
1.384s sys-kernel-debug.mount
1.332s systemd-rfkill@rfkill3.service
1.330s systemd-modules-load.service
1.325s systemd-udev-trigger.service
1.310s dev-mqueue.mount
1.156s SuSEfirewall2.service
1.135s SuSEfirewall2_init.service
1.001s systemd-tmpfiles-setup-dev.service
921ms home.mount
852ms ModemManager.service
799ms systemd-rfkill@rfkill2.service
721ms user@1000.service
632ms polkit.service
580ms systemd-readahead-replay.service
563ms vboxdrv.service
519ms apparmor.service
402ms systemd-fsck-root.service
352ms vboxadd.service
323ms systemd-readahead-collect.service
314ms systemd-sysctl.service
289ms kmod-static-nodes.service
257ms wpa_supplicant.service
249ms bluetooth.service
168ms systemd-udev-root-symlink.service
148ms systemd-udevd.service
144ms rtkit-daemon.service
138ms systemd-vconsole-setup.service
138ms systemd-remount-fs.service
117ms systemd-tmpfiles-setup.service
113ms iscsi.service
90ms NetworkManager.service
80ms plymouth-read-write.service
51ms systemd-logind.service
47ms udisks2.service
41ms plymouth-start.service
37ms systemd-journal-flush.service
37ms rc-local.service
30ms systemd-readahead-done.service
15ms systemd-user-sessions.service
14ms auditd.service
11ms alsa-restore.service
9ms upower.service
4ms iscsiuio.service
4ms systemd-update-utmp-runlevel.service

Krovikan 03-ago-2016 11:26

Esos tiempos que tienes no son nada (a mi el Network Manager me tarda 28 segundos)

Ya mataría yo por tener esos tiempos.


Saludos

DiabloRojo 03-ago-2016 15:06

Cita:

Iniciado por jabyr (Mensaje 192669)
escribí el siguiente comando como decia en el post y me aparece la siguiente info uso open suse leap 42.1 que puedo hacer para arregrar la carga de dicho driver saludos

Sigo sin aclararme nada, ¿cual es el problema o el driver que te causa problemas?.

Cita:

Iniciado por Krovikan
Ya mataría yo por tener esos tiempos.

Yo, también. :afirmar:

jabyr 05-ago-2016 07:15

el sistema se demora como 3:30 en iniciar y se debe a eso mismo no se cual es el servicio o proceso que atrasa todo el arranque del sistema y no se como saber cual es , si me dan alguna ayuda para poder publicarlo en un post la info de todo el arranque del kernel, saludos

DiabloRojo 05-ago-2016 08:29

Sera el escritorio (¿cual usas?) que se esta cargando pero parece ser que no sale una pantalla de carga o anunciadora. ¿es eso?.

jabyr 05-ago-2016 09:19

uso kde plasma 5

DiabloRojo 05-ago-2016 13:40

Pues no te saldrá la ventana anunciadora de Plasma 5, pero por los buenos tiempos que informas parece que no tienes ningún problema

mikrios 05-ago-2016 16:36

Hola:

Pulsa la tecla escape, para ver que es lo que detiene el arranque.

Las secuencias largas de arranque pueden variar y la mayoría de las veces no tiene nada que ver el kernel, si no algún servicio que no ha terminado de empezar o de acabar.

El encargado del arranque es systemd, este puede o no arrancar un firmware, después arranca el loader o grub, seguido del kernel +initrd y el espacio de usuario, donde termina de cargar todo y finaliza en la sesión gráfica.

Código:

X-79-PRO:~ # systemd-analyze
Startup finished in 32min 31.592s (firmware) + 3.188s (loader) + 3.456s (kernel) + 2.990s (initrd) + 31.145s (userspace) = 33min 12.372s

Hace unos días no llegaba al minuto, aunque de ese tiempo, no suele se muy real, eso lo puedes ver de forma gráfica o bien con un systemd-analyze blame :_
Código:

X-79-PRO:~ # systemd-analyze  blame
        10.752s home.mount
          5.189s SuSEfirewall2.service
          5.049s apparmor.service
          4.716s wicked.service
          4.114s dev-sda3.device
          3.281s systemd-udev-settle.service
          2.475s ModemManager.service
          2.397s cups.service
          2.300s display-manager.service
          2.037s postfix.service
          1.972s ntpd.service
          1.905s systemd-remount-fs.service
          1.766s lm_sensors.service
          1.603s nscd.service
          1.581s SuSEfirewall2_init.service
          1.431s rc-local.service
          1.306s mcelog.service
          1.283s avahi-daemon.service
          1.112s udisks2.service
          1.092s systemd-journal-flush.service
          1.012s autofs.service                                                                                                                                       
          818ms polkit.service                                                                                                                                       
          743ms systemd-udevd.service                                                                                                                               
          733ms upower.service                                                                                                                                       
          725ms dev-mqueue.mount                                                                                                                                     
          704ms lvm2-activation-net.service                                                                                                                         
          509ms systemd-journald.service                                                                                                                             
          480ms wickedd-auto4.service                                                                                                                               
          480ms wickedd-dhcp4.service                                                                                                                               
          479ms wickedd-dhcp6.service                                                                                                                               
          475ms dev-sda2.swap                                                                                                                                       
          437ms var-log.mount                                                                                                                                       
          428ms var-spool.mount                                                                                                                                     
          417ms sys-kernel-debug.mount                                                                                                                               
          404ms tmp.mount                                                                                                                                           
          396ms boot-efi.mount                                                                                                                                       
          395ms kmod-static-nodes.service

Pienso que es lo que comenta @D.Rojo, es mas hay herramientas suficientes para detectar el problema (journalctl, systemd-analyze, y algunas mas ) .

Si el sistema no termina de arrancar, pero systemd ya está iniciado, puedes abrir un terminal virtual de TTY (Ctrl+Alt+Fn siendo n de la F1 a la F6, la F7 te devuelve al terminal gráfico) te logeas como root y ejecutas los comandos , por ejemplo systemctl list-jobs o bien systemctl --failed , o journalctl -b |more , o simplemente sin hacer nada pulsar la tecla escape al principio y ver lo que pasa.

Saludos cordiales


La franja horaria es GMT +2. Ahora son las 19:16.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!