ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   Instalación y Actualizaciones (http://www.forosuse.org/forosuse/forumdisplay.php?f=2)
-   -   A alguien más le falló el kernel 3.16.7-24-desktop (http://www.forosuse.org/forosuse/showthread.php?t=32780)

Egux 15-ago-2015 11:00

A alguien más le falló el kernel 3.16.7-24-desktop
 
Acaba de terminar de actualizar Opensuse y ese kernel no me inicio la compu se reiniciaba y no cargaba ni el plymouth. Los demás funcionan bien y no tienen errores con el mkinit .
Uso kde4 y OpenSUSE 13.2

El thread lo edite para aportar algo, por si ha alguien mas le pasa y no sabe como volver abrir el sistema sin reinstalarlo. Agrego que soy algo nuevo usando OpenSUSE por lo que si conocen métodos más eficientes y efectivos pueden escribirlos.

En el grub vas a opciones avanzadas OpenSuse y seleccionas el kernel anterior.

Si quieres desactivar el kernel anterior una forma sencilla es abrir Dolphin (Dolphin es el gestor de archivos de KDE se puede usar cualquier gestor de archivos en modo superusuario) como super usuario
Abrir el punto de raíz ir a la carpeta(punto de montaje) boot
Crear una carpeta, está que se puede llamar "actualización que no me funcionó"
Poner una barra de filtros con dolphin, ctrl + i
Escribir el numero del kernel que te fallo en mi caso fue 3.16.7-24 en la barra de filtros de Dolphin
Mover todo los archivos que tienen ese numero a la carpeta que hiciste anteriormente si usaste algún filtro solo veras esos archivos
Pasar el mkinit, debe ejecutarse como super usuario.
Seguir con el kernel anterior y probar si la próxima actualización te funciona mejor.

También se puede probar instalando el kernel vainilla si es mucha la versionitis.

Este método lo usaba en Fedora cuando no tenia tiempo para batallar y trastear un rato a veces que me fallaba.
** Si sueles usar el zypper clean, puedes guardar en una carpeta los kernels que sabes que te funcionan bien. **
Si se sabes los comandos básicos de la terminal también puede hacerse desde ella sin problema alguno.

Esto debe realizarse con cuidado de copiar solo los archivos de esa versión de ese kernel y no mover otro que pueda dañarlos todos

DiabloRojo 15-ago-2015 11:27

Bienvenido al foro, por favor, lee las normas del foro donde aprenderás cosas útiles como aportar datos, hacer preguntas, como buscar.... es como una guía para los novatos. Fíjate lo que dice resaltado y en negrita la norma 5.

No es un fallo del kernel sino una implantación de dracut que da los warnings (avisos) del kernel, se supone que lo revisara para el próximo kernel. Hay otro tema idéntico a tuyo a mismo tiempo: http://www.forosuse.org/forosuse/showthread.php?t=32744

Como eres nuevo, preséntate en la sección de Presentaciones y, por favor, lee las normas.

http://images2.hiboox.com/images/061...a01a15fff2.gif

mikrios 16-ago-2015 04:49

Hola:

No es muy recomendable usar el kernel vanilla (ver info en wiki o en el foro, ademas muchas de las cosas que incluye ese kernel, no son necesarias, por ejemplo para arquitectura X86 )

Se puede usar en plan ariesgado (y mucho menos que el vanilla) el kernel HEAD, que es el último ya compilado para openSUSE.

Pero mucho mas comprobado y que se puede usar para todas las versiones de openSUSE es el kernel estable estandar (el HEAD mas bien queda para el tema de factory ), digamos que es el resultado de lo que sale del HEAD.

Ademas cada versión de openSUSE tiene su propio repositorio de kernel, excepto TW que este actualiza a la última (TW = Tumbleweed) .

Se puede ver mas o menos un seguimiento en el "http://kernel.opensuse.org/cgit/kernel/" ( GIT Browse) .

Para la 13.2 se puede usar el "http://download.opensuse.org/repositories/Kernel:/openSUSE-13.2/standard/" (mirar si corresponde con las actualizaciones de drivers de las gráficas, es decir con las versiones de los repositorios de estas ) .

Y el estable estandar que sería : "http://download.opensuse.org/repositories/Kernel:/stable/standard/" ya ahí no se si cumple con el tema de los rpm de los drivers o de VirtualBox . (para eso se puede usar este conjuntamente con dkms ) .

Saludos cordiales

Edito:

Interesa que aportes mas información , como por ejemplo que arquitectura estas usando ( Intel o AMD ) equipo etc. en mi caso no tengo fallos con esa versión de kernel en Intel.

Saludos


La franja horaria es GMT +2. Ahora son las 15:57.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!