ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   Instalación y Actualizaciones (http://www.forosuse.org/forosuse/forumdisplay.php?f=2)
-   -   sin internet luego de actualizar kernel (http://www.forosuse.org/forosuse/showthread.php?t=32562)

jhonny_ese 25-abr-2015 15:59

sin internet luego de actualizar kernel
 
Buenos días, luego de actualizar el kernel desde el repositorio de la comunidad Kernel:estable a la versión 4.0.0.3, no tengo conexión a Internet.
Hasta el 4.0.0.2 estaba todo bien, de hecho estoy escribiendo esta consulta luego de reiniciar con él.
Alguna sugerencia?

mikrios 25-abr-2015 20:59

Hola:

A mi me estuvo pasando una temporada, pero ya de eso dejo de pasarme.

Lo que hacia era entrar en yast editar de nuevo las configuraciones de red, y sin hacer ningún cambio, volver a salvar estas (creo que refrescaba el archivo de configuración ) y recuperaba de nuevo la conexión .

Pero ahora creo que esta centralizado en una unidad de systemd : Wicked el cual cambia o reemplaza a ifup .

En systemd lo puedes ver como wickedd y en la 13.2 aparece al final antes de cargar el entorno del usuario .

Así que creo que habría que remitirse a lo que muestre de journalctl y comprobar el estado con systemctl (el estado del servicio) .

Un ejemplo :

Código PHP:

X79-PRO:~ # systemctl list-units |grep -i wickedd
wickedd-auto4.service                                                                                 loaded active running   wicked AutoIPv4 supplicant service
wickedd
-dhcp4.service                                                                                 loaded active running   wicked DHCPv4 supplicant service
wickedd
-nanny.service                                                                                 loaded active running   wicked network nanny service
wickedd
.service                                                                                       loaded active running   wicked network management service daemon 

Y usar las herramientas o comandos para saber lo que pasa (ifconfig, etc) .

No he observado que se pierda las configuraciones de internet en la 13.2 con los cambios de kernel (tanto en equipos instalados como en los que ejecuto en virtualbox) :

En virtualbox ahora en este equipo estoy con el :
Código:

13-2vbox:~ # uname -r
4.0.0-3.geee4e07-desktop

y listo para actualizar a la :
Código:

The following 8 NEW packages are going to be installed:
  kernel-default-devel-4.0.0-4.1.g27299c0 kernel-desktop-4.0.0-4.1.g27299c0 kernel-desktop-devel-4.0.0-4.1.g27299c0 kernel-devel-4.0.0-4.1.g27299c0 kernel-pv-devel-4.0.0-4.1.g27299c0
  kernel-source-4.0.0-4.1.g27299c0 kernel-syms-4.0.0-4.1.g27299c0 kernel-xen-devel-4.0.0-4.1.g27299c0

The following package is going to be upgraded:
  kernel-macros

1 package to upgrade, 8 new.
Overall download size: 147.4 MiB. Already cached: 0 B  After the operation, additional 763.0 MiB will be used.
Continue? [y/n/? shows all options] (y):

Al kernel kernel-desktop-4.0.0-4.1.g27299c0

Y en equipos de prueba idem lo mismo, mira de reconfigurar el archivo de red, a través de yast .

Comenta ademas si es que estas usando networmanager (en mi caso uso solo el de yast), lo comento por si hay algo por la red o en los forum (que pueda indicar algún problema ) .

O sea en mi caso no he tenido problemas de red, con los cambios de kernel (y de eso desde hace mucho tiempo ) .

Saludos cordiales

jhonny_ese 26-abr-2015 08:57

Gracias mikrios, sobre todo por lo de Wicked.
Al actualizarse a la versión 4.0.0-4.g27299c0-default resolvieron el problema.


La franja horaria es GMT +2. Ahora son las 13:32.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!