ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   Software (http://www.forosuse.org/forosuse/forumdisplay.php?f=3)
-   -   Instalación driver AMD ATI X86_64 (http://www.forosuse.org/forosuse/showthread.php?t=29217)

metalpocas 05-ene-2013 05:00

Instalación driver AMD ATI X86_64 [Solucionado]
 
Hola, verán me he bajado de aquí: http://geeko.ioda.net/mirror/ati/raw-src/ los archivos:
  1. amd-driver-installer-catalyst-12.10-x86.x86_64.run
  2. makerpm-amd-12.10.sh

Primeramente intenté hacer la instalación manual con:
sh ./amd-driver-installer-catalyst-12.10-x86.x86_64.run
Todo bien me sale la ventanita del instalador, le doy continue y de repente ventana salvaje aparece diciendo:
"One or more tools required for instalation cannot be found on the system. Install the required tools before installing the fglrx driver. Optionally run the installer with --force option to install without the tools. Forcing intall disable AMD hardware acceleration and may make your system unstable. Not recommended. See /usr/share/ati/fglrx-install.log for more details."

Bueno luego me voy a ver el archivito este y dice:

"Supported adapter detected.
Supported adapter detected.
Check if system has the tools required for installation.
fglrx installation requires that the system have kernel headers. /lib/modules/3.4.6-2.10-desktop/build/include/linux/version.h cannot be found on this system.
One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
Optionally, run the installer with --force option to install without the tools.
Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.
"

Reviso el directorio mensionado y efectivamente "/lib/modules/3.4.6-2.10-desktop/" no posee build por lo que el archivito este de "version.h" tampoco, leí una página en inglés y dice algo sobre actualizar los headers de kernel algo asi como:
zypper install linux-headers-3.4.6-2.10-desktop

pero nada, alguien que me ayude? por favor.

gvcastellon 05-ene-2013 06:39

Saludos <metalpocas>:

El tema se a tocado bastante yo reciente por otras razones estuve tratando varias formas, por eso te voy a dejar las mejores opciones que a mi me funcionaron, con mi ATI (en mi firma puedes ver lo que tengo).

Opciones.

1- http://forums.opensuse.org/content/1...w-version.html (para mi la mejor, porque luego es solo cuestion de hacer un "atiupgrade" en el terminal.)

2- http://www.guiadelcamaleon.blogspot....-opensuse.html

Si buscas en el Forum, hay muchísima información al respecto. Espero esto te pueda ayudar. :adios:

metalpocas 06-ene-2013 03:16

Hola gvcastellon, me sirvió con la primer opción, muchisimas gracias.

gvcastellon 06-ene-2013 14:06

Cita:

Iniciado por metalpocas (Mensaje 159622)
Hola gvcastellon, me sirvió con la primer opción, muchisimas gracias.

Un placer haber podido guiarte hasta donde estaba una solución, (una vez mas agradecido, a los amigos de ese Forum en espeical a "please try again"

Salu2. :adios:


La franja horaria es GMT +2. Ahora son las 15:42.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!