ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   Multimedia (http://www.forosuse.org/forosuse/forumdisplay.php?f=9)
-   -   Sin audio por Hdmi (http://www.forosuse.org/forosuse/showthread.php?t=28587)

Nhelo 09-ago-2012 23:10

Sin audio por Hdmi
 
Hola... hace un tiempo ya que empece a probar OpenSuse instalando la versión 12.1, el tema es que no logro que salga audio por la salida HDMI. Tengo una tarjeta de vídeo Radeon HD 6470m. He intentado colocar también "radeon.audio=1" en el cargador de arranque de yast como dice en las notas de versión pero tampoco he tenido éxito. Al irme a sonido solo me aparece una tarjeta de sonido. He instalado los controladores de propietarios de AMD pero no me sirvió para solucionar este problema. Soy novato aun en linux, he probado otras distribuciones en las cuales el audio por HDMI me iba bien, aunque aquellas no terminaron por gustarme. Ya no he encontrado solución en google, no se si se me paso por alto alguna, pero ya me tiene con bastantes dolores de cabeza este problema.

jncruces 09-ago-2012 23:45

Tienes que instalar el paquete 'pavucontrol' y luego con dicha aplicación eliges que programa quieres que salga por el HDMI.

en.opensuse.org/SDB:Connecting_to_TV_Monitor

arag 09-ago-2012 23:54

eso no lo sabia gracias por compartir

Nhelo 10-ago-2012 01:07

Disculpas si no lo mencione antes, ya tenia instalado el pavucontrol, desde el yast lo había colocado hace un tiempo. Me aparecen en configuración los perfiles a elegir en donde 2 son de HDMI (Estéreo Digital (HDMI)output y Estereo Digital (HDMI)output + Estéreo Analógico Input, he probado ambas). He jugado un poco con las opciones que aparecen pero sin éxito... aun no puedo hacer que salga el audio hacia el LCD. :confused:

jncruces 10-ago-2012 01:25

Antes de seguir indagando en openSUSE que es algo más complicado, ¿no sera que la configuración del LCD esté mal?

Mi LCD puedo elegir el audio que escoge con el HDMI y ponerle audio por conectores RCA, solo por probar.

Nhelo 10-ago-2012 07:47

Lo he probado en 2 LCD distintas verificando la configuración como dices tu. Incluso he conectado a ambas otro notebook en el cual tengo instalado linux mint y no tiene ningún problema en dejar salir el audio por el HDMI.

El audio del notebook que tengo instalado OpenSuse se escucha perfectamente... es cuando quiero hacer que salga por via HDMI que tengo problemas.

jncruces 10-ago-2012 11:38

Vamos a necesitar más datos.

¿Tienes los drivers de fábrica de Ati?

¿Es un sistema operativo de 32 o 64 bits?

Aquí tienes los drivers originales de ATI.

Nhelo 10-ago-2012 23:58

Muchas gracias por el interés en mi problema. SI si tengo los drivers de Ati, los había sacado de la misma fuente que me has dado.
Bueno el sistema que tengo instalado es el OpenSuse 12.1 de 64 bits. Intente en un principio instalar con livecd esta versión pero con Gnome Shell, como tenia el mismo problema de audio preferí volver a instalarlo pero desde el DVD, aunque no soluciono nada. Ahora el escritorio que utilizo es CInnamon.

Otra pregunta. En yast hay una opción para la configuración del sonido, pero aquí solo me aparece una tarjeta de sonido. Cuando hago una prueba de reproducción solo sale el sonido por los parlantes del notebook. ¿ Debería aparecer aquella tarjeta solamente?

julioeep 11-ago-2012 00:37

Bueno, tuve una laptop la cual no me daba audio por hdmi de ninguna forma, despúes de mucho batallar descubrí que el bendito no tenia salida de audio por hdmi solo vídeo, en ese caso era una nvidia (no recuerdo el apellido ahora), en todo caso no hay ninguna opción en Catalyst para el audio HDMI?

PD: Gnome-Shell y Cinnamon son Shellś para Gnome, ergo en ambos casos usas Gnome.

Defton 11-ago-2012 00:56

con el comando alsamixer verifica que las salidas s/pdif no enten en mute:

http://i-host.oversec.org/?di=313446392623


La franja horaria es GMT +2. Ahora son las 11:24.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!