ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   General OpenSUSE (http://www.forosuse.org/forosuse/forumdisplay.php?f=23)
-   -   Problema cliente NFS no monta carpetas en el booteo(Solucionado) (http://www.forosuse.org/forosuse/showthread.php?t=24928)

Gustavok 14-oct-2010 15:34

Problema cliente NFS no monta carpetas en el booteo(Solucionado)
 
Hola comunidad, quería compartir con ustedes un problema que me llevó varios días de googlear hasta poder encontrarle una solución.

El problema se da cuando configuramos el cliente NFS para que monte carpetas al iniciar el sistema.

Lo que ocurre es que cuando iniciamos sesión ,las carpetas montadas no están accesibles, teniendo que reiniciar el servicio NFS para que se monten correctamente.

Esto es un gran problema si una de las carpetas que montamos desde el servidor es la carpeta /home, ya que al loguearse no se puede levantar el escritorio y nos da el siguiente error

"kstartupconfig4 does not exist"

teniendo que abrir una terminal como root para reniciar nfs

LA SOLUCION:
entramos a una terminal
$ su
$ pass de root
$ vi /etc/init.d/nfs

apretamos la letra i para entra en modo insert
nos movemos con las flechitas del cursor hasta la linea que dice:
echo -n "Starting NFS client services: y escribimos abajo sleep 30, nos quedaría así:

echo -n "Starting NFS client services:
sleep 30

luego apretamos ESC para salir de modo insert
luego :w para guardar
y luego :q para salir

Ahora reiniciamos y comprobamos que las carpetas se montan correctamente al iniciar el sistema

Lo que hacemos con sleep 30 es darle unos segundos al sistema para que inicie correctamente la interfaz de red para luego poder montar las carpetas del nfs

Si aun no se montan pueden probar con sleep 60


La franja horaria es GMT +2. Ahora son las 05:59.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!