ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   Hardware (http://www.forosuse.org/forosuse/forumdisplay.php?f=4)
-   -   Problemas con configuración de NVidia en SuSE 9.3 Pro (http://www.forosuse.org/forosuse/showthread.php?t=1960)

reynierpm 24-jun-2005 17:21

Problemas con configuración de NVidia en SuSE 9.3 Pro
 
Hola:
Tengo una tarjeta de video "NVidia Quadro FX 500" en mi PC. Cuando instale SuSE el me la reconoció perfectamente como una "NVidia Quadro FX 500/600" y todo perfecto pero resulta que cuando iba a usar las potencialidades de la misma como el 3D no podía. Me di a la tarea de leer un poco y encontré que debía instalar los drivers correspondientes. Fui a la página de NVidia y descargue los mismos. La última versión era esta "NVIDIA-Linux-x86-1.0-7664-pkg1.run". Luego para instalarla segui los siguientes pasos:
1. Ir al directorio /etc y buscar el fichero inittab. Editarlo y ponerlo a que iniciara en modo 1.
2. Dirigirme al directorio donde estaba el driver y poner en el bash # sh NVIDIA-Linux-x86-1.0-7664-pkg1.run
Ahi me dijo que iba a instalar los drivers y todo correcto, asi lo hizo. Ahora nuevamente edite el fichero inittab y lo puse a runlevel 5 para iniciar en gráfico.
Cuando el sistema trata de iniciar las X da error. Entonces traté de configurarlo con el Sax pero me da este error:
WW: The directory "/usr/X11R6/lib/x11/fonts/xtext" does not exits
WW: Open APM failed (/dev/apm_bios)(no such device)

Me puede indicar alguien que hice mal?? Resulta que ahora no puedo iniciar las X porque me da problemas en el fichero xorg.conf.
Salu2 :dedosarri

DiabloRojo 24-jun-2005 18:23

Cita:

Iniciado por reynierpm
Cuando el sistema trata de iniciar las X da error. Entonces traté de configurarlo con el Sax pero me da este error:
WW: The directory "/usr/X11R6/lib/x11/fonts/xtext" does not exits
WW: Open APM failed (/dev/apm_bios)(no such device)

Son Warning, avisos sin importancia, no son errores.
Cita:

Me puede indicar alguien que hice mal?? Resulta que ahora no puedo iniciar las X porque me da problemas en el fichero xorg.conf.
Hecha un vistazo a log de la ejecucion en /var/log/Xorg.o.log. tb a Sax.log. Intenta recuperar el anterior xorg.conf que ahora se llamara xorg.conf.saxsave y te dejara como estaba antes de utilizar la ultima vez sax2, lo encontraras en /etc/X11.

Marcel 24-jun-2005 18:27

Cita:

Iniciado por reynierpm
Hola:
Tengo una tarjeta de video "NVidia Quadro FX 500" en mi PC. Cuando instale SuSE el me la reconoció perfectamente como una "NVidia Quadro FX 500/600" y todo perfecto pero resulta que cuando iba a usar las potencialidades de la misma como el 3D no podía. Me di a la tarea de leer un poco y encontré que debía instalar los drivers correspondientes. Fui a la página de NVidia y descargue los mismos. La última versión era esta "NVIDIA-Linux-x86-1.0-7664-pkg1.run". Luego para instalarla segui los siguientes pasos:
1. Ir al directorio /etc y buscar el fichero inittab. Editarlo y ponerlo a que iniciara en modo 1.
2. Dirigirme al directorio donde estaba el driver y poner en el bash # sh NVIDIA-Linux-x86-1.0-7664-pkg1.run
Ahi me dijo que iba a instalar los drivers y todo correcto, asi lo hizo. Ahora nuevamente edite el fichero inittab y lo puse a runlevel 5 para iniciar en gráfico.
Cuando el sistema trata de iniciar las X da error. Entonces traté de configurarlo con el Sax pero me da este error:
WW: The directory "/usr/X11R6/lib/x11/fonts/xtext" does not exits
WW: Open APM failed (/dev/apm_bios)(no such device)

Me puede indicar alguien que hice mal?? Resulta que ahora no puedo iniciar las X porque me da problemas en el fichero xorg.conf.
Salu2 :dedosarri

QUe no seguiste las instrucciones de SuSE:

ftp://ftp.suse.com/pub/suse/i386/sup...D64-HOWTO.html

Despues de instalar: "make", "gcc" y los "kernel-source", debes actualizar por YOU, luego reinicias y vas a la consola matando las X.
init 3

Luego instalas el driver:
modprobe agpgart
sh NVIDIA-Linux-x86-1.0-7667-pkg1.run -q

Luego inicias sax:
sax2 -m 0=nvidia
(0 es un número no una letra!)

No te olvides de configurar ahi tu monitor y probar antes de salir.

Y ya esta reinicia y listo.

reynierpm 24-jun-2005 19:07

Excelente pero ...
 
Excelente Marcel y DiabloRojo ya he solucionado el problema con las dichosas X y NVidia pero otros han surgido. Cuando inicia en la interfaz gráfica me pone un splash feísimo, yo diría que es como XMFC o algo por el estilo. Me saca una consola pequeña en la parte inferior izquierda con estos mensajes:
Cita:

Error: selinux kernel: nurm: loading NVidia linux x86 NVI dia kernel module 1.0-7664
error: selinux kernel: end_request: I/O error, dev fd0, sector 0
y el ultimo error es que antes cuando daba terminar en KDE me ponia varias opciones ahora solo me pone "Terminar sesión y cancelar". Son estos problemas comunes o problemas de configuración??

Salu2 :scratchch

PD: Como puedo hacer para que el Foro me reporte cuando se me responda algún mensaje??

kaleimn 24-jun-2005 19:11

por lo general con solo actualizar por el you la aceleradora de nVida queda funcionando.

DiabloRojo 24-jun-2005 19:48

Leete este hilo y los que recomienda internamente:
http://www.forosuse.org/forosuse/sho...ghlight=trucha

reynierpm 24-jun-2005 20:21

Pues
 
Solucione efectivamente el problema de la sesion por defecto pero ahora me pasa que no hayo esta ruta en mi YAST:
Yast-->Sistema-->Desktop-->Displaymanager-->Displaymanager-->Sustituir XDM por KDM.

Me podrian dar alguna alternativa o la solucion??
Salu2 :scratchch

kaleimn 24-jun-2005 21:08

Cita:

Iniciado por reynierpm
Solucione efectivamente el problema de la sesion por defecto pero ahora me pasa que no hayo esta ruta en mi YAST:
Yast-->Sistema-->Desktop-->Displaymanager-->Displaymanager-->Sustituir XDM por KDM.

Me podrian dar alguna alternativa o la solucion??
Salu2 :scratchch

sip desde consola, con el yast eliminar x11 e instalarlo de nuevo, capas te funque

DiabloRojo 24-jun-2005 21:09

Yast-->Sistema-->Editor de archivos /etc/suseconfig-->Desktop-->Displaymanager-->Displaymanager-->Sustituir XDM por KDM.


La franja horaria es GMT +2. Ahora son las 21:31.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!