ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   Hardware (http://www.forosuse.org/forosuse/forumdisplay.php?f=4)
-   -   Mal rendimiento video Intel HD 4000 (http://www.forosuse.org/forosuse/showthread.php?t=31437)

fabrihack 18-abr-2014 21:38

Mal rendimiento video Intel HD 4000
 
Hola gente, soy nuevo en el foro. Hace 1 mes instalé OpenSUSE 13.1 x64, y me encanta esta distro. Pero estoy teniendo mal desempeño en lo que refiere a gráficos. Tengo delays (atrasos) y bajos fps. Por ejemplo, si tengo un cubo generado por computación gráfica, puedo picar en alguna parte del mismo y hacerlo que rote sobre si mismo manteniendo el clic apretado y moviendo el mouse. Aclaro, tengo dual boot, y esto en Windows 8.1 Pro funciona como debe ser, perfecto. Lo que sucede es que cuando mantengo el clic apretado y comienzo a moverlo, el movimiento se atrasa, en el sentido que si mantengo apretado y lo muevo por 4 segundos y luego suelto el clic, el cubo sigue moviéndose alrededor de 2 o 3 segundos más. Es decir, no sigue su movimiento rotatorio solidario al mouse, sino que se atrasa. Otros errores mas también se me presentan, pero ese fue un ejemplo de los mismos. Quisiera saber que me proponen para solucionar esto, ya que uso mucho la GPU por cuestiones universitarias, y esto no me permite seguir trabajando como debe ser en computación gráfica.
Mi GPU es una integrada, pues tengo una notebook lenovo G580 y viene con gráficos Intel HD 4000 incorporados. Quisiera saber que puedo hacer para dar una solución a esto, estoy seguro que es un problema de drivers, pero no sé por donde arrancar. Desde ya agradecería sus aportes, me parece una excelente comunidad. Saludos a todos!

RGB 19-abr-2014 00:01

Yo no tengo problemas en mi i3 con gráfica integrada HD4000. Pero uso el kernel 3.14. Prueba a actualizar el kernel desde este repo

http://download.opensuse.org/reposit...able/standard/

fabrihack 19-abr-2014 00:53

Hola, gracias por responder! Lamentablemente ya probé con esa instancia, mirá:

Cita:

fabrizio@linux-d79k:~> uname -r
3.14.1-1.geafcebd-desktop
Y no hubo cambios, quizás el retraso es menor, pero sigue retrasado y con errores gráficos.

mikrios 19-abr-2014 07:17

Probando el kernel 3.14 , observe mejoras , pero también observe perdida de rendimiento con respecto ala anteriores versiones ,las velocidades de los cores suelen estar un poco mas bajas , y no alcanzan su máximo .

Aunque el i7 6 cores (12 núcleos lo pase a otra placa ) con esta de 4 cores (8 núcleos ) , las frecuencias han bajado a lo mínimo (casi me iría por el repositorio del kernel del 13.1 en vez del estable estandar ) :

Código PHP:

X79PRO:~ # inxi -Fz
System:    HostX79PRO Kernel3.14.1-1.geafcebd-desktop x86_64 (64 bitDesktopN/
           Distro
openSUSE 13.1 (Bottle
Machine:   MoboASUSTeK modelP9X79 PRO vRev 1.xx BiosAmerican Megatrends v4608 date12/24/2013
CPU
:       Quad core Intel Core i7-3820 CPU (-HT-MCP-) cache10240 KB 
           Clock Speeds
11217 MHz 21217 MHz 31217 MHz 41217 MHz 51217 MHz 61217 MHz 71217 MHz
           8
1217 MHz
Graphics
:  CardNVIDIA GK107 [GeForce GTX 650]
           
Display ServerX.org 1.14.3.901 driversnouveau (unloadedfbdev,nv,vesa)
           
tty size191x51 Advanced DataN/for root
Audio
:     Card-1 NVIDIA GK107 HDMI Audio Controller driversnd_hda_intel 
           Card
-2 Intel C600/X79 series High Definition Audio Controller driversnd_hda_intel 
           Sound
Advanced Linux Sound Architecture vk3.14.1-1.geafcebd-desktop
Network
:   CardIntel 82579V Gigabit Network Connection drivere1000e
           
IF: eno1 stateup speed1000 Mbps duplexfull mac: <filter>
Drives:    HDD Total Size4120.8GB (15.0usedID-1: /dev/sda modelWDC_WD1002FAEX size1000.2GB
           ID
-2: /dev/sdb modelKINGSTON_SH103S3 size120.0GB ID-3: /dev/sdc modelST3000DM001 size3000.6GB
Partition
ID-1: / size41G used28G (71%) fsbtrfs dev: /dev/sda3 
           ID
-2: /home size890G used547G (62%) fsbtrfs dev: /dev/sda4 
           ID
-3swap-1 size2.15GB used0.00GB (0%) fsswap dev: /dev/sda2 
Sensors
:   System Temperaturescpu27.0C moboN/A gpu29.0 
           Fan Speeds 
(in rpm): cpuN/
Info
:      Processes284 Uptime1 day 16:24 Memory2737.1/64502.7MB ClientShell (bashinxi2.1.20 

Si te fijas todos están a 1217 MHZ y varían dependiendo de las aplicaciones ,

Como siga así cambio el repositorio por el del kernel 13.1 :
"http://download.opensuse.org/repositories/Kernel:/openSUSE-13.1/standard/"
Hasta que no se solucione el problema (con las otras versiones iban de 1217 a 3,9 GHZ ), en cambio aquí están muy bajas por defecto .

En la bios seleccione la opción en automática , por lo que puede sincronizar los cores o actuar core por core . .

Saludos cordiales

Edito mira un ejemplo de otro kernel :
Código PHP:

X79PRO:~ # inxi -Fz
System:    HostX79PRO Kernel3.12.5-1.g48b587a-desktop x86_64 (64 bitDesktopN/A DistroopenSUSE 13.1 (Bottle)
Machine:   MoboASUSTeK modelP9X79 PRO versionRev 1.xx BiosAmerican Megatrends version4502 date10/15/2013
CPU
:       Hexa core Intel Core i7-4930K CPU (-HT-MCP-) cache12288 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
           
Clock Speeds13300.00 MHz 23300.00 MHz 33300.00 MHz 43299.871 MHz 53299.871 MHz 63300.00 MHz 73298.324 MHz 83300.00 MHz 93300.00 MHz 103300.00 MHz 113300.00 MHz 123300.00 MHz
Graphics
:  CardNVIDIA GK107 [GeForce GTX 650
           
X.org1.14.3.901 driversnouveau (unloadedfbdev,nv,vesatty size191x51 Advanced DataN/for root 
Audio
:     Card-1NVIDIA GK107 HDMI Audio Controller driversnd_hda_intel SoundALSA verk3.12.5-1.g48b587a-desktop
           Card
-2Intel C600/X79 series High Definition Audio Controller driversnd_hda_intel 
Network
:   CardIntel 82579V Gigabit Network Connection drivere1000e 
           
IF: eno1 stateup speed1000 Mbps duplexfull mac: <filter>
Drives:    HDD Total Size4128.6GB (22.8used1id: /dev/sda modelWDC_WD1002FAEX size1000.2GB 
           2
id: /dev/sdb modelKINGSTON_SH103S3 size120.0GB 3id: /dev/sdc modelST3000DM001 size3000.6GB 
           4
USB id: /dev/sdd modelDataTraveler_112 size7.7GB 
Partition
ID: / size41G used8.7G (23%) fsbtrfs ID: /home size890G used6.4G (1%) fsbtrfs 
           ID
swap-1 size2.15GB used0.00GB (0%) fsswap 
RAID
:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors
:   System Temperaturescpu35.0C moboN/A gpu26.0 
           Fan Speeds 
(in rpm): cpuN/
Info
:      Processes349 Uptime0:00 Memory844.1/48342.5MB ClientShell (bashinxi1.9.17 

X79PRO
:~ # inxi -F
System:    HostX79PRO Kernel3.11.10-14.g4c507e1-desktop x86_64 (64 bitDesktopN/A DistroopenSUSE 13.1 (Bottle)
Machine:   MoboASUSTeK modelP9X79 PRO versionRev 1.xx serial120700387401694
           Bios
American Megatrends version4607 date12/02/2013
CPU
:       Hexa core Intel Core i7-4930K CPU (-HT-MCP-) cache12288 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
           
Clock Speeds11200.00 MHz 21200.00 MHz 31200.00 MHz 41200.00 MHz 51500.00 MHz 61200.00 MHz 71200.00 MHz 82900.00 MHz 92600.00 MHz 102800.00 MHz 111200.00 MHz 122800.00 MHz
Graphics
:  CardNVIDIA GK107 [GeForce GTX 650
           
X.org1.14.3.901 driversnouveau (unloadedfbdev,nv,vesatty size191x51 Advanced DataN/for root 
Audio
:     Card-1NVIDIA GK107 HDMI Audio Controller driversnd_hda_intel SoundALSA verk3.11.10-14.g4c507e1-desktop
           Card
-2Intel C600/X79 series High Definition Audio Controller driversnd_hda_intel 
Network
:   CardIntel 82579V Gigabit Network Connection drivere1000e 
           
IF: eno1 stateup speed100 Mbps duplexfull mac30:85:a9:95:88:65
Drives
:    HDD Total Size4120.8GB (2.5used1id: /dev/sda modelWDC_WD1002FAEX size1000.2GB 
           2
id: /dev/sdb modelKINGSTON_SH103S3 size120.0GB 3id: /dev/sdc modelST3000DM001 size3000.6GB 
Partition
ID: / size41G used22G (56%) fsbtrfs ID: /home size890G used76G (9%) fsbtrfs 
           ID
swap-1 size2.15GB used0.00GB (0%) fsswap 
RAID
:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors
:   System Temperaturescpu28.0C moboN/A gpu25.0 
           Fan Speeds 
(in rpm): cpuN/
Info
:      Processes330 Uptime8:53 Memory3749.8/64502.7MB ClientShell (bashinxi1.9.18 

Sobre todo en la frecuencia de los cores (con este están sincronizados y por defecto al máximo y el otro dependiendo de las aplicaciones que ejecutes varian su frecuencia ) .
Con el último que han sacado estan al minimo por defecto (ya había notificado ese error , y se corrigio , pero han vuelto a las andadas ) .

Pero ten por seguro que cada nueva versión que sale tiene muchas mejoras ; aunque suele tener altibajos en otras cosas (lo bueno de openSUSE , es que son muy ŕapidos corrigiendo errores , en dos días cosecutivos actualice el kernel ,por salir nuevas versiones )

Saludos

fabrihack 19-abr-2014 15:31

Hola, muchas gracias por responder, el tema del desempeño del kernel es relativo, y lo digo porque con en kernel original que trajo (3.11) el problema mio seguía, o sea, kernel nuevo o kernel viejo sigo con el problema. Lo que si, es que se vé que un repositorio está colisionando con el repo de kernel stable porque aun teniendo la ultima version del kernel, hay un repo distinto al que me pasaron (de los que vienen por defecto) que me sigue notificando una nueva versión del kernel y me muestra para descargar la versión antigua, dejo captura:


http://k42.kn3.net/5/D/4/4/8/B/305.png

DiabloRojo 19-abr-2014 19:50

Yo tambien tengo un pobre rendimiento de la grafica integrada Intel y, de vez en cuando, se pixela la pantalla cuando uso Kate o Kwrite o algún programa de KDE 4.

Sobre el kernel, danos la salida del comando
zypper lr -u

:adios:

fabrihack 19-abr-2014 20:37

Aqui está la salida:

Cita:

fabrizio@linux-d79k:~/Descargas> zypper lr -u
# | Alias | Nombre | Habilitado | Actualizar | URI
---+---------------------------+------------------------------------+------------+------------+----------------------------------------------------------------------------------------
1 | Packman | Packman | No | Si | http://packman.inode.at/suse/openSUSE_12.3
2 | Wireless | Wireless | No | Si | http://download.opensuse.org/reposit.../openSUSE_13.1
3 | kernel-repo | kernel-repo | Si | Si | http://download.opensuse.org/reposit...able/standard/
4 | openSUSE-13.1-1.10 | openSUSE-13.1-1.10 | No | Si | hd:///?device=/dev/disk/by-id/usb-Kingston_DT_101_II_000AEB91BCA6BA703000056E-0:0-part1
5 | repo-debug | openSUSE-13.1-Debug | No | Si | http://download.opensuse.org/debug/d...13.1/repo/oss/
6 | repo-debug-update | openSUSE-13.1-Update-Debug | No | Si | http://download.opensuse.org/debug/update/13.1/
7 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No | Si | http://download.opensuse.org/debug/update/13.1-non-oss/
8 | repo-non-oss | openSUSE-13.1-Non-Oss | Si | Si | http://download.opensuse.org/distrib.../repo/non-oss/
9 | repo-oss | openSUSE-13.1-Oss | Si | Si | http://download.opensuse.org/distrib...13.1/repo/oss/
10 | repo-source | openSUSE-13.1-Source | Si | Si | http://download.opensuse.org/source/...13.1/repo/oss/
11 | repo-update | openSUSE-13.1-Update | Si | Si | http://download.opensuse.org/update/13.1/
12 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Si | Si | http://download.opensuse.org/update/13.1-non-oss/
También otra manera mas prolija:

Cita:

fabrizio@linux-d79k:~/Descargas> zypper repos -u
# | Alias | Nombre | Habilitado | Actualizar | URI
---+---------------------------+------------------------------------+------------+------------+----------------------------------------------------------------------------------------
1 | Packman | Packman | No | Si | http://packman.inode.at/suse/openSUSE_12.3
2 | Wireless | Wireless | No | Si | http://download.opensuse.org/reposit.../openSUSE_13.1
3 | kernel-repo | kernel-repo | Si | Si | http://download.opensuse.org/reposit...able/standard/
4 | openSUSE-13.1-1.10 | openSUSE-13.1-1.10 | No | Si | hd:///?device=/dev/disk/by-id/usb-Kingston_DT_101_II_000AEB91BCA6BA703000056E-0:0-part1
5 | repo-debug | openSUSE-13.1-Debug | No | Si | http://download.opensuse.org/debug/d...13.1/repo/oss/
6 | repo-debug-update | openSUSE-13.1-Update-Debug | No | Si | http://download.opensuse.org/debug/update/13.1/
7 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No | Si | http://download.opensuse.org/debug/update/13.1-non-oss/
8 | repo-non-oss | openSUSE-13.1-Non-Oss | Si | Si | http://download.opensuse.org/distrib.../repo/non-oss/
9 | repo-oss | openSUSE-13.1-Oss | Si | Si | http://download.opensuse.org/distrib...13.1/repo/oss/
10 | repo-source | openSUSE-13.1-Source | Si | Si | http://download.opensuse.org/source/...13.1/repo/oss/
11 | repo-update | openSUSE-13.1-Update | Si | Si | http://download.opensuse.org/update/13.1/
12 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Si | Si | http://download.opensuse.org/update/13.1-non-oss/
Edito: no me preguntén por qué sale esa URL en el repo 4 (debería borrarlo?) aunque no creo que sea ese la colisión de versión de kernels

DiabloRojo 20-abr-2014 09:24

Cita:

Iniciado por fabrihack (Mensaje 176309)
Edito: no me preguntén por qué sale esa URL en el repo 4 (debería borrarlo?) aunque no creo que sea ese la colisión de versión de kernels

El repo 4 es cuando instalastes openSUSE, no te aconsejo eliminarlo por si las moscas y en el futuro lo necesitas.

Otra cosa, los repositorios debugs y source (5, 6, 7 y 10) desmarca la actualización que es una perdida de tiempo descargar los indices si no estan habilitados.
El repo 1 de Packman, habilitalo. Te falta añadir un repositorio esencial, el de libdvdcss: http://opensuse-guide.org/repo/13.1/

Te aconsejo una lectura de mi guía: GUIA de Repositorios de openSUSE: Manejo y Funcionamiento

fabrihack 20-abr-2014 18:57

Listo, ya quite la actualizacion automatica de los 5,6 y 10. Nueva salida:

Cita:

fabrizio@linux-d79k:~> zypper repos -u
# | Alias | Nombre | Habilitado | Actualizar | URI
---+---------------------------+------------------------------------+------------+------------+----------------------------------------------------------------------------------------
1 | Packman | Packman | Si | Si | http://packman.inode.at/suse/openSUSE_12.3
2 | Wireless | Wireless | No | Si | http://download.opensuse.org/reposit.../openSUSE_13.1
3 | kernel-repo | kernel-repo | Si | Si | http://download.opensuse.org/reposit...able/standard/
4 | openSUSE-13.1-1.10 | openSUSE-13.1-1.10 | No | Si | hd:///?device=/dev/disk/by-id/usb-Kingston_DT_101_II_000AEB91BCA6BA703000056E-0:0-part1
5 | repo-debug | openSUSE-13.1-Debug | No | No | http://download.opensuse.org/debug/d...13.1/repo/oss/
6 | repo-debug-update | openSUSE-13.1-Update-Debug | No | No | http://download.opensuse.org/debug/update/13.1/
7 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No | No | http://download.opensuse.org/debug/update/13.1-non-oss/
8 | repo-non-oss | openSUSE-13.1-Non-Oss | Si | Si | http://download.opensuse.org/distrib.../repo/non-oss/
9 | repo-oss | openSUSE-13.1-Oss | Si | Si | http://download.opensuse.org/distrib...13.1/repo/oss/
10 | repo-source | openSUSE-13.1-Source | No | No | http://download.opensuse.org/source/...13.1/repo/oss/
11 | repo-update | openSUSE-13.1-Update | Si | Si | http://download.opensuse.org/update/13.1/
12 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Si | Si | http://download.opensuse.org/update/13.1-non-oss/
Ahora, porque hay que deshabilitar los source y debug? No sirven?

Edito: Todavía me sigue notificando para actualizar el kernel a un viejo (3.11) y tengo instalado el 3.14

fabrihack 20-abr-2014 20:26

Gente, les dejo un video de lo que sucede con el delay de la GPU Intel HD 4000, lo hice recien, espero que les oriente un poco más para solucionar esto:


http://youtu.be/1ygymSbEwVA




La franja horaria es GMT +2. Ahora son las 02:04.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!