ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   FAQs, Manuales y Tutoriales (http://www.forosuse.org/forosuse/forumdisplay.php?f=20)
-   -   Actualizar OpenOffice 2.0.x a 2.1 con repositorios (http://www.forosuse.org/forosuse/showthread.php?t=11275)

tomeu 26-feb-2007 18:19

Actualizar OpenOffice 2.0.x a 2.1 con repositorios
 
Nota: Por ahora solo funciona con SuSE 10.2; por el simple hecho de que no hay en los repos de las versiones anteriores (projects y apt) versiones compiladas de OOo-2.1

En el repositorio "projects" de OpenSuSE hay un directorio "OpenOffice.org" con el que se puede actualizar su suite ofimática que viene con la distro a la versión 2.1 (última estable actual).

En este mini-manual se indica cómo hacerlo con SMART por lo tanto si no se tiene instalado Smart hay que usar el buscador del foro y leer cómo hacerlo y desde dónde (o hacer clic en el enlace)

1.- Desde la línea de comandos:
a) Ante todo actualizamos la base de datos de smart, para que cuando la actualicemos con el nuevo "channel" no nos dé el coñazo:
Código:

smart update
b) Añadimos el channel:
Código:

smart channel --add OpenOffice2.1 type=rpm-md name="OpenOffice.org" baseurl=ftp://ftp.suse.com/pub/projects/OpenOffice.org/10.2-i386/
Otra alternativa a esa "baseurl" es la: ftp://ftp.gwdg.de/pub/linux/suse/ftp...org/10.2-i386/

c) Sincronizamos y actualizamos:
Código:

smart update OpenOffice2.1
Código:

smart upgrade OpenOffice_org\*
2.- Con la interfaz gráfica de Smart (--gui)
Si no la tenemos y la queremos poner:
Código:

rpm --import http://linux01.gwdg.de/~pbleser/guru-rpm.asc
Código:

smart install smart-gui
a) Abrimos la interfaz
Código:

smart --gui
b) Editar -> Canales -> Nuevo -> Método: proporciona información del canal
c) Tipo: RPM-Meta Data; Alias: OpenOffice2.1; Nombre: OpenOffice.org; URL base: ftp://ftp.suse.com/pub/projects/Open...org/10.2-i386/ (o la otra puesta arriba)
d) Aceptar -> Cerrar -> clic en icono de update
e) Ver -> Ocultar NO actualizaciones
f) Marcar las de OpenOffice 2.1 para instalar; clic en icono de aplicar

Después de actualizar a versión 2.1

* Puede ser que la primera vez que queramos lanzar cualquier aplicación de OpenOffice (por ejemplo un pps desde el correo, etc..) dé fallo. No hay que hacer nada en especial, pasa que la nueva versión tiene otro directorio /usr/lib/ooo-2.1 en lugar de /usr/lib/ooo-2.0. Pero basta con cerrar el entorno gráfico 1 vez y la siguiente vez que lo abramos los enlaces ya funcionan.
* Cuando comprobemos que todo funciona se puede eliminar el directorio ooo-2.0 de /usr/lib

larva_pro 13-sep-2007 00:17

Muchas gracias por el tutorial me a sido de mucha alluda. :dedosarri :dedosarri

tomeu 13-sep-2007 10:55

Me alegro. No obstante ese tutorial había quedado algo obsoleto, sobre todo en la forma de actualizar con SMART, ya que OpenOffice tiene repositorios nuevos y distintos.

Además la última versión estable es la 2.2, con varias actualizaciones menores en sus ramas. Así la última en español -estable- de las páginas de OOo es la 2.2.1, mientras que en inglés no hace mucho iban por la 2.2.3.

Y, aun más, resulta que en los repos nuevos de la distro para OOo, está la 2.2.3 con su traducción al español.

Las versiones compiladas solían tener algunos fallos (lo comprobé en Ubuntu y SuSE), uno de ellos -a modo de ejemplo- era que se cerraba inesperadamente la aplicación si se abría un archivo powerpoint desde el lector de correo y se miraba en modo diapositiva, y también otros parecidos en los documentos word con macros. Es decir, documentos importados de MsOffice. En las últimas ramas de la última versión compiladas (tanto Ubuntu como SuSE) he visto que esos fallos han desaparecido.

En definitiva, en el estado actual, considero más aconsejable actualizar el OpenOffice con sus repositorios. Otra cosa será, y ya veremos si las repos dan la talla, cuando se liberalice la versión 2.3. Entonces quizás este tuto vuelva a ser de actualidad.

Saludos.

xisco 14-sep-2007 10:00

Hola!
Pues al actualizar el smart el otro dia me agrego el solo el repositorio de openoffice stable y el unstable.
De todas formas ahora la instalo directamente de openoffice y no de suse, por cierto la 2.3 RC3 (yo la he instalado, creo que un RC es bastante estable) eso si en ingles:
http://download.openoffice.org/680/
Salu2

tomeu 14-sep-2007 11:58

Una RC con número avanzado de OOo suele ser siempre bastante estable.

Por otro lado, pegué patinazo en las ramas que puse en el anterior post: la última estable en español es la 2.2.0, mientras que en inglés (y también en español si se usa el repo) es la 2.2.1


La franja horaria es GMT +2. Ahora son las 07:08.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!