ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   Escritorios: KDE, Gnome, otros... (http://www.forosuse.org/forosuse/forumdisplay.php?f=5)
-   -   Conflictos al intentar instalar KDE 4.1 en Opensuse 11.0 [SOLUCIONADO] (http://www.forosuse.org/forosuse/showthread.php?t=17922)

McGiver 31-jul-2008 07:08

Conflictos al intentar instalar KDE 4.1 en Opensuse 11.0 [SOLUCIONADO]
 
Hola.

Intenté instalar KDE 4.1 en OpenSUSE 11.0 y se me presentan muchísimos conflictos.

Supongo que el problema es algo global y no con cada una de las dependencias en particular, pero realmente no sé que hacer. (Aunque siempre termino formateando y volviendo a inatalar todo :p )

Acá dejo un fragmento del archivo conflicts.txt que generó YAST2. Si es de utilidad me piden y posteo el archivo completo.

Cita:

#### YaST2 conflicts list - generated 2008-07-31 00:50:58 ####

kde4-plasma-addons-4.1.0-3.3.x86_64 requiere libkldap.so.4()(64bit), pero este requisito no puede cumplirse
proveedores no instalables: libkdepimlibs4-4.1.0-12.8.x86_64[http://download.opensuse.org/reposit...penSUSE_11.0/]
[x] no instalar kde4-plasma-addons-4.1.0-3.3.x86_64
[ ] Ignore some dependencies of kde4-plasma-addons
[ ] Se realizarán las siguientes acciones:
no instalar libkdepimlibs4-4.1.0-12.9.i586
no instalar kde4-knewsticker-4.1.0-13.11.i586
no instalar kde4-konqueror-4.1.0-17.7.i586

kde4-kpat-4.1.0-9.9.i586 requiere libkdegames.so.5, pero este requisito no puede cumplirse
proveedores no instalables: libkdegames4-4.1.0-9.9.i586[http://download.opensuse.org/reposit...penSUSE_11.0/]
[ ] cambio en la arquitectura de libkdegames4-4.0.4-16.1.x86_64 a libkdegames4-4.1.0-9.9.i586
[ ] Ignore some dependencies of kde4-kpat
[x] Se realizarán las siguientes acciones:
no instalar kde4-kpat-4.1.0-9.9.i586
no instalar kde4-kmahjongg-4.1.0-9.9.i586
no instalar kde4-kreversi-4.1.0-9.9.i586
no instalar kde4-kmines-4.1.0-9.9.i586

kde4-okular-4.1.0-19.3.i586 requiere libchm.so.0, pero este requisito no puede cumplirse
proveedores no instalables: chmlib-0.39-77.1.i586[repo-oss]
[ ] Se realizarán las siguientes acciones:
cambio en la arquitectura de chmlib-0.39-77.1.x86_64 a chmlib-0.39-77.1.i586
cambio en la arquitectura de libdjvulibre15-3.5.20-51.1.x86_64 a libdjvulibre15-3.5.20-51.1.i586
cambio en la arquitectura de ghostscript-library-8.62-17.1.x86_64 a ghostscript-library-8.62-17.1.i586
cambio en la arquitectura de gutenprint-5.0.2-13.1.x86_64 a gutenprint-5.0.2-13.1.i586
cambio en la arquitectura de libgimpprint-4.2.7-258.1.x86_64 a libgimpprint-4.2.7-258.1.i586
cambio en la arquitectura de libpoppler-qt4-3-0.8.2-1.3.x86_64 a libpoppler-qt4-3-0.8.2-1.3.i586
cambio en la arquitectura de libpoppler3-0.8.2-1.3.x86_64 a libpoppler3-0.8.2-1.3.i586
cambio en la arquitectura de gimp-2.4.5-41.1.x86_64 a gimp-2.4.6-1.5.i586
cambio en la arquitectura de gimp-plugins-python-2.4.5-41.1.x86_64 a gimp-plugins-python-2.4.6-1.5.i586
cambio en la arquitectura de ufraw-gimp-0.13-45.1.x86_64 a ufraw-gimp-0.13-45.1.i586
cambio en la arquitectura de libgtkimageview0-1.6.1-16.1.x86_64 a libgtkimageview0-1.6.1-16.1.i586
cambio en la arquitectura de ufraw-0.13-45.1.x86_64 a ufraw-0.13-45.1.i586
cambio en la arquitectura de libwmf-0.2.8.4-164.1.x86_64 a libwmf-0.2.8.4-164.1.i586
desactualización de libGraphicsMagick1-1.1.11-29.1.x86_64 a libGraphicsMagick1-1.1.11-27.2.i586
cambio en la arquitectura de libGraphicsMagick1-1.1.11-29.1.x86_64 a libGraphicsMagick1-1.1.11-27.2.i586
desactualización de koffice-illustration-1.6.3-157.1.x86_64 a koffice-illustration-1.6.3-81.2.i586
cambio en la arquitectura de koffice-illustration-1.6.3-157.1.x86_64 a koffice-illustration-1.6.3-81.2.i586
cambio en la arquitectura de libpoppler-qt2-0.8.2-1.3.x86_64 a libpoppler-qt2-0.8.2-1.3.i586
cambio en la arquitectura de libMagickCore1-6.4.0.4-20.1.x86_64 a libMagickCore1-6.4.0.4-20.1.i586
cambio en la arquitectura de libMagickWand1-6.4.0.4-20.1.x86_64 a libMagickWand1-6.4.0.4-20.1.i586
cambio en la arquitectura de ImageMagick-6.4.0.4-20.1.x86_64 a ImageMagick-6.4.0.4-20.1.i586
desactualización de koffice-1.6.3-157.1.x86_64 a koffice-1.6.3-81.2.i586
cambio en la arquitectura de koffice-1.6.3-157.1.x86_64 a koffice-1.6.3-81.2.i586 [x] no instalar kde4-okular-4.1.0-19.3.i586
[ ] Ignore some dependencies of kde4-okular

....
....
....

#### YaST2 conflicts list END ###
Desde ya agradezco su tiempo y dedicación.
Saludos.

DiabloRojo 31-jul-2008 09:21

Hola MacGyver, creo que ese es tu nombre, ¿no? :D

¿Que fue de tu navaja suiza?, ¿la has perdido o es no te sirve para solucionar el problema de dependencias con KDE4?. :D

Bienvenido y leete las normas del foro ya que te dara buenos consejos como novato, entre ellos como buscar.

Bueno, yo tambien tuve conflictos a pasar de la version 4.0.4 a la 4.1.0, la diferencia es que fueron 3 o 4 paquetes que tuve que decidir que hacer con ellos.

En tu caso, deberas leer los mensajes de error y tomar tus decisiones basando en dos premisas:
1.- La version que quieres tener es la 4.1.0; por ejemplo, deberas marcar la opcion:
[x] cambio en la arquitectura de libkdegames4-4.0.4-16.1.x86_64 a libkdegames4-4.1.0-9.9.i586
2.- No quiero instalar ningun paquete de 32 bits (i586) si existe de 64 bits (x86_64).
3.- Si tienes dudas, no instales el paquete pero apuntalo para saber despues para que sirve dicho paquete y prueba despues instalarlo manualmente.
4.- Nunca fuerces la instalacion de un paquete.

Un saludo.

PD: Una de las cosas que debe aprender todo usuario de openSUSE es resolver conflictos si pones bastantes repositorios. En mi 10.2 que funciona bien tengo 20 repositorios incluido KDE4 y en 11.0 estoy poco a poco añadiendo repositorios.

McGiver 31-jul-2008 16:47

Muchas garcias por tu respuesta DiabloRojo.

Si bien aquí soy novato, he pasado por otros foros y sé cuan mal cae cuando alguien pregunta cosas que ya han sido respondidas.
Busque en Google y en el buscador del foro. Pero partí de la premisa falsa de que lo que me sucedía era algo coyuntural y no un problema de dependencias por lo cual busqué problemas con KDE 4.1 y no encontre nada que asemeje al mio.

La duda que me queda de con respecto a tu respuesta es: ¿puedo sin temor instalar un paquete de 32 bits en mi instalación de 64 bits?

Lo de "4. Nunca fuerzes la instalación de un paquete." ya lo experimenté en carne propia. Resultado: Format.

Y lamentablemente la navaja suiza no sirve para estas cosas. :p

¡Gracias!

DiabloRojo 31-jul-2008 18:14

Cita:

Iniciado por McGiver
La duda que me queda de con respecto a tu respuesta es: ¿puedo sin temor instalar un paquete de 32 bits en mi instalación de 64 bits?

No te lo aconsejo salvo que no existe la version de ese paquete para 64 bits.
Mas que nada, te lo decía por por que si forzabas la instalación de kde4-okular ibas a cambiar muchos paquetes a 32 bits, cosa poco aconsejable.

Ivan de Leon 31-jul-2008 19:28

Tras algún conflicto similar, instalé el 4.1 por el sistema 1-click, y no he tenido problema alguno. Eso sí, el KDE4 así instalado está completo, pero sin algunas partes que, de echarlas de menos, puedes añadir desde YaST.

Saludos.

Guansito 01-ago-2008 11:06

Yo cuando instalé el kde 4.1 también tuve un montón de problemas de dependencias, las fuí repasando y la gran mayoría, por no decir todas era que trataba de instalar la version de 32 bits en lugar de la de 64. Así que cambié para instalar la de 64 y ya fué bien.

DiabloRojo 01-ago-2008 13:20

He comprobado que si utilizo el sistema 1-click de KDE4-Default del Factory me da muchas errores de dependecias, el listado es casi el mismo del 1er. post de esste Tema. :scratchch

El metodo de actualizacion de la version 4.0 a la 4.1 que utilice fue el comando "zypper refresh | zypper dup" despues de añadir el repositorio Factory de KDE4, los errores fueron 3 o 4 paquetes, nada en comparacion con el que me sale si utilizo el metodo de 1-click.

A ver si Guansito, nos explica que hizo exactamente para resolver tantas dependencias ya que el listado de errores es muy extenso.

karlggest 01-ago-2008 15:07

Teniendo openSUSE 11.0 con KDE 3.5 instalé KDE 4.1 desde Factory. No he tenido problemas de dependencias en la instalación, sólo en la selección de paquetes. Notable que sean paquetes que dan conflictos entre ellos, pero de todas formas en la selección de escritorios (filtro "patrones") no hay mayor inconveniente...

... XD XD XD XD ...

lo que significa que, por supuesto, no me funciona bien!!

XD XD XD XD

... va a ser que me tienen manía... :scratchch

Salud!!

Ivan de Leon 01-ago-2008 17:02

Añado que la versión que instalé por el 1-click fue la 4.1, en estado de pruebas (beta, creo), desde el repositorio Factory, a través del enlace "KDE 4.1" que sale en la lista de repositorios, en la descripción de la rama Factory. y teniendo instalada la 4.0.4 (medio instalada, porque la intenté quitar, y armé una buena xD).

La página es: http://en.opensuse.org/KDE4

Saludos.

DiabloRojo 01-ago-2008 20:01

Según el enlace que nos ha dado Ivan de Leon, parece que no funciona en sistemas 64 bits como el mio y de algunos. Asi que toca hacerlo a mano.
Cita:

Note: Currently there are known problems with using the 1-click installation on 64-bit systems. Add the repositories and install/update the packages manually if you have a 64-bit system.
Manualmente, copiar y pegar en un terminal de superusuario pero antes añadir el repositorio Factory de la 11.0, dichos paquetes son el contenido del archivo one-clic
Código:

LANG=C zypper in kde4-akregator kde4-ark kde4-dolphin kde4-gwenview kde4-kaddressbook kde4-kate kde4-kcalc kde4-kdepasswd kde4-kdessh kde4-kdf kde4-kdialog kde4-keditbookmarks kde4-kfind kde4-kfloppy kde4-kget kde4-kgpg kde4-kio_audiocd kde4-kio_sysinfo-branding-openSUSE kde4-kmag kde4-kmahjongg kde4-kmail kde4-kmines kde4-kmix kde4-knewsticker kde4-knotes kde4-konqueror kde4-konsole kde4-kontact kde4-kopete kde4-korganizer kde4-kpat kde4-krdc kde4-kreversi kde4-krfb kde4-kruler kde4-kscd kde4-ksnapshot kde4-ksudoku kde4-kwalletmanager kde4-kwikdisk kde4-kwin kde4-kwrite kde4-okular kde4-plasma-addons kdebase4 kdebase4-nsplugin kdebase4-openSUSE kdebase4-session kdebase4-workspace kdebase4-workspace-branding-openSUSE kdebase4-workspace-ksysguardd kdenetwork4-filesharing kdepim4-wizards kdepimlibs4 libakonadi4 libkdepimlibs4 libraptor1 libredland0 plasma-theme-aya strigi
[EDITADO] Me ha funcionado la ejecución del anterior comando, por si alguien tiene curiosidad, os informo que me ha instalado los siguientes paquetes ya que el resto lo tenia instalado con "zypper dup"
kde4-kwikdisk kde4-kruler kde4-kmag kde4-kdf kde4-kdepasswd kde4-kdessh kde4-kfloppy kde4-kdialog kde4-kate


La franja horaria es GMT +2. Ahora son las 21:45.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!