ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   Software (http://www.forosuse.org/forosuse/forumdisplay.php?f=3)
-   -   Miro en suse 13.1 (http://www.forosuse.org/forosuse/showthread.php?t=31402)

metalpocas 09-abr-2014 03:11

Miro en suse 13.1
 
Recién he instalado SUSE 13.1, vengo de la 12.3 y lo hice con la única esperanza de poder utilizar el miro player, pero me he topado con el mismo problema que tuve en la 12.3:

wilmar@dufrein:~> miro
using /usr/bin/gdb
2014-04-08 18:14:33,968 INFO root: Starting up Miro
2014-04-08 18:14:33,969 INFO root: Version: 5.0
2014-04-08 18:14:33,970 INFO root: Revision: git://github.com/pculture/miro.git - 347ed252
2014-04-08 18:14:33,971 INFO root: Builder: abuild@swkj04.site
2014-04-08 18:14:33,972 INFO root: Build Time: 1396651151.07
2014-04-08 18:14:33,973 INFO root: Debugmode: False
2014-04-08 18:14:33,973 INFO root: Reading HTTP Password list
2014-04-08 18:14:33,974 INFO root: Starting libCURL thread
2014-04-08 18:14:33,976 INFO root: Starting event loop thread
2014-04-08 18:14:33,979 INFO root: Installing deleted file checker...
2014-04-08 18:14:33,982 INFO root: Loading core extensions in /usr/share/miro/resources/extensions
2014-04-08 18:14:33,983 INFO root: Restoring database...
2014-04-08 18:14:33,986 INFO root: Sqlite3 version: 3.7.17
2014-04-08 18:14:33,990 INFO root: Loading user extensions in /home/wilmar/.miro/extensions
2014-04-08 18:14:33,991 INFO root: Pysqlite version: 2.6.0
2014-04-08 18:14:33,999 INFO root: opening database /home/wilmar/.miro/sqlitedb
2014-04-08 18:14:34,002 ERROR root: error when upgrading database: no such table: dtv_variables
Traceback (most recent call last):
File "/usr/lib64/python2.7/site-packages/miro/storedatabase.py", line 619, in upgrade_database
self._upgrade_database()
File "/usr/lib64/python2.7/site-packages/miro/storedatabase.py", line 692, in _upgrade_database
self.startup_version = current_version = self.get_version()
File "/usr/lib64/python2.7/site-packages/miro/storedatabase.py", line 1305, in get_version
return self.get_variable(VERSION_KEY)
File "/usr/lib64/python2.7/site-packages/miro/storedatabase.py", line 741, in get_variable
"WHERE name=?", (name,))
OperationalError: no such table: dtv_variables
2014-04-08 18:14:34,004 WARNING root: upgrade failed. Backing up database to /home/wilmar/.miro/failed_upgrade_database
2014-04-08 18:14:34,010 INFO root: Linux version: Linux 3.11.10-7-desktop x86_64
2014-04-08 18:14:34,011 INFO root: Python version: 2.7.6 (default, Nov 21 2013, 15:55:38) [GCC]
2014-04-08 18:14:34,011 INFO root: Gtk+ version: (2, 24, 22)
2014-04-08 18:14:34,011 INFO root: PyGObject version: (2, 28, 6)
2014-04-08 18:14:34,011 INFO root: PyGtk version: (2, 24, 0)
2014-04-08 18:14:34,011 INFO root: Language: [('LANG', 'es_ES.UTF-8')]
2014-04-08 18:14:34,048 INFO root: libtorrent: 0.16.11.0
2014-04-08 18:14:34,049 INFO root: pycurl: libcurl/7.32.0 OpenSSL/1.0.1e zlib/1.2.8 libidn/1.25 libssh2/1.4.3
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
/usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning: cannot register existing type 'GstObject'
from _gst import *
/usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning: g_once_init_leave: assertion 'result != 0' failed
from _gst import *

(miro.real:8559): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed
/usr/lib64/python2.7/site-packages/gst-0.10/gst/__init__.py:193: Warning: interface type 'GstImplementsInterface' or prerequisite type '<invalid>' invalid
from _gst import *

:( tal vez alguien pudiese ayudar con este tema, o dirigirme a algún lado para hacerlo

mikrios 09-abr-2014 05:55

De donde instalaste miro ? .

Este esta en Yast :
S Name Type Version Arch Repository
miro package 5.0-12.70 x86_64 Packman Repository
miro package 5.0-12.70 i586 Packman Repository
miro srcpackage 5.0-12.70 noarch Packman Repository
miro-debuginfo package 5.0-12.70 x86_64 Packman Repository
miro-debuginfo package 5.0-12.70 i586 Packman Repository
miro-debugsource package 5.0-12.70 x86_64 Packman Repository
miro-debugsource package 5.0-12.70 i586 Packman Repository
mirovideoconverter package 3.0.2-2.1 noarch home:XRevan86
mirovideoconverter srcpackage 3.0.2-2.1 noarch home:XRevan86

Saludos

metalpocas 09-abr-2014 17:14

Del primero en la lista:

miro package 5.0-12.70 x86_64 Packman Repository

mikrios 09-abr-2014 17:30

Procura que ese proveedor tenga prioridad alta (ejemplo 70 ) , puede que otras librerías estén de otro sitio y tengas problemas de dependencias .

procura también cambiar de proveedor a torrent :
Código:

X79PRO:~ # zypper info miro
Loading repository data...
Reading installed packages...


Information for package miro:
-----------------------------
Repository: Packman Repository
Name: miro
Version: 5.0-12.70
Arch: x86_64
Vendor: http://packman.links2linux.de
Installed: No
Status: not installed
Installed Size: 34.1 MiB
Summary: RSS Aggregator with Video Playback for watching Internet Video
Description:
Miro is a free application that turns your computer into an internet TV video
player.

It's a free, open source Internet TV and video player that can automatically
download videos from RSS-based channels. Features a built-in BitTorrent
client.

Dependencias de miro :
Código:


miro - RSS Aggregator with Video Playback for watching Internet Video


Versión:
5.0-12.70
Proporciona:
mimehandler(audio/mpeg)
mimehandler(audio/x-mp3)
mimehandler(application/ogg)
mimehandler(audio/x-mpegurl)
mimehandler(audio/x-wav)
mimehandler(audio/x-scpls)
mimehandler(audio/ogg)
mimehandler(audio/x-mpeg)
mimehandler(video/mpeg)
mimehandler(video/x-msvideo)
mimehandler(video/quicktime)
mimehandler(application/x-ogg)
mimehandler(video/x-ms-asf)
mimehandler(video/x-ms-wmv)
mimehandler(audio/vnd.rn-realaudio)
mimehandler(audio/x-pn-realaudio)
mimehandler(video/vnd.rn-realvideo)
mimehandler(audio/x-m4a)
mimehandler(video/x-mpeg)
mimehandler(application/vnd.rn-realmedia)
mimehandler(video/msvideo)
mimehandler(audio/x-ms-asx)
mimehandler(audio/x-ms-wax)
mimehandler(video/dv)
mimehandler(video/x-anim)
mimehandler(video/x-avi)
mimehandler(video/x-fli)
mimehandler(audio/x-ms-asf)
mimehandler(audio/x-pn-realaudio-plugin)
mimehandler(video/ogg)
mimehandler(application/x-matroska)
mimehandler(audio/x-pn-aiff)
mimehandler(audio/x-pn-au)
mimehandler(audio/x-pn-wav)
mimehandler(audio/x-pn-windows-acm)
mimehandler(audio/x-real-audio)
mimehandler(video/x-nsv)
mimehandler(video/x-flc)
mimehandler(application/x-bittorrent)
mimehandler(image/vnd.rn-realpix)
mimehandler(misc/ultravox)
mimehandler(application/x-democracy)
mimehandler(application/x-miro)
infolist.so()(64bit)
ngrams.so()(64bit)
pygtkhacks.so()(64bit)
webkitgtkhacks.so()(64bit)
xlibhelper.so()(64bit)
miro = 5.0-12.70
miro(x86-64) = 5.0-12.70
Presupone:
python = 2.7
Requiere:
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
/bin/sh
libc.so.6(GLIBC_2.14)(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libm.so.6()(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libstdc++.so.6()(64bit)
libstdc++.so.6(GLIBCXX_3.4)(64bit)
libstdc++.so.6(CXXABI_1.3)(64bit)
libgcc_s.so.1()(64bit)
libgcc_s.so.1(GCC_3.0)(64bit)
libglib-2.0.so.0()(64bit)
libgobject-2.0.so.0()(64bit)
libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
libX11.so.6()(64bit)
libz.so.1()(64bit)
/usr/bin/python
libgtk-x11-2.0.so.0()(64bit)
gstreamer-0_10-plugins-bad
libgdk-x11-2.0.so.0()(64bit)
libpango-1.0.so.0()(64bit)
python-gtk
gstreamer-0_10-plugins-good
libpython2.7.so.1.0()(64bit)
libtag.so.1()(64bit)
python-gstreamer-0_10
python-mutagen
libavcodec.so.52()(64bit)
libavcodec.so.52(LIBAVCODEC_52)(64bit)
libavutil.so.50()(64bit)
libavutil.so.50(LIBAVUTIL_50)(64bit)
gstreamer-0_10-plugins-ffmpeg
gstreamer-utils
libsoup-2.4.so.1()(64bit)
libavformat.so.52()(64bit)
libavformat.so.52(LIBAVFORMAT_52)(64bit)
python-gnome
python-libtorrent-rasterbar
/usr/bin/ffmpeg
python-curl
libwebkitgtk-1.0.so.0()(64bit)
python-webkitgtk
python-gnome-extras
python(abi) = 2.7
python = 2.7

Si esta todo correcto , puedo suponer que tenga un problema la aplicación , por lo que habría que notificarlo y esperar un corrección ; no estaría de mas darse una vuelta por su org , y faq , haber que dicen sobre ello .

Saludos

metalpocas 10-abr-2014 02:03

Me aparece en la pestaña de depencias del yast aparece tal como usted lo puso, sin embargo la versión instalada dice:
Por ejemplo notese que mimehandler(application/ogg) y la alternativa dice mimehandler(audio/mpeg) y así para muchas más

5.0-12.70
mimehandler(application/ogg)
mimehandler(application/x-ogg)
mimehandler(audio/mpeg)
mimehandler(audio/x-mp3)
mimehandler(audio/x-mpeg)
mimehandler(audio/x-mpegurl)
mimehandler(audio/x-scpls)
mimehandler(application/x-bittorrent)
mimehandler(application/x-matroska)
mimehandler(audio/ogg)
mimehandler(audio/vnd.rn-realaudio)
mimehandler(audio/x-ms-asx)
mimehandler(audio/x-pn-realaudio)
mimehandler(audio/x-wav)
mimehandler(video/mpeg)
mimehandler(video/msvideo)
mimehandler(video/quicktime)
mimehandler(video/x-avi)
mimehandler(video/x-mpeg)
mimehandler(video/x-ms-asf)
mimehandler(application/vnd.rn-realmedia)
mimehandler(audio/x-m4a)
mimehandler(audio/x-ms-asf)
mimehandler(audio/x-ms-wax)
mimehandler(audio/x-pn-aiff)
mimehandler(audio/x-pn-au)
mimehandler(audio/x-pn-realaudio-plugin)
mimehandler(audio/x-pn-wav)
mimehandler(audio/x-pn-windows-acm)
mimehandler(audio/x-real-audio)
mimehandler(image/vnd.rn-realpix)
mimehandler(misc/ultravox)
mimehandler(video/dv)
mimehandler(video/vnd.rn-realvideo)
mimehandler(video/x-anim)
mimehandler(video/x-flc)
mimehandler(video/x-fli)
mimehandler(video/x-ms-wmv)
mimehandler(video/x-msvideo)
mimehandler(video/x-nsv)
infolist.so()(64bit)
mimehandler(application/x-democracy)
mimehandler(application/x-miro)
mimehandler(video/ogg)
ngrams.so()(64bit)
pygtkhacks.so()(64bit)
webkitgtkhacks.so()(64bit)
xlibhelper.so()(64bit)
miro = 5.0-12.70
miro(x86-64) = 5.0-12.70
python = 2.7
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
/bin/sh
libc.so.6(GLIBC_2.14)(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libm.so.6()(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libstdc++.so.6()(64bit)
libstdc++.so.6(GLIBCXX_3.4)(64bit)
libstdc++.so.6(CXXABI_1.3)(64bit)
libglib-2.0.so.0()(64bit)
libgobject-2.0.so.0()(64bit)
libgcc_s.so.1()(64bit)
libgcc_s.so.1(GCC_3.0)(64bit)
libX11.so.6()(64bit)
libz.so.1()(64bit)
libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
libgtk-x11-2.0.so.0()(64bit)
libgdk-x11-2.0.so.0()(64bit)
libpango-1.0.so.0()(64bit)
libpython2.7.so.1.0()(64bit)
/usr/bin/python
libsoup-2.4.so.1()(64bit)
gstreamer-0_10-plugins-bad
python-gtk
libtag.so.1()(64bit)
gstreamer-0_10-plugins-good
libavutil.so.50()(64bit)
libavutil.so.50(LIBAVUTIL_50)(64bit)
python-gnome
libavcodec.so.52()(64bit)
libavcodec.so.52(LIBAVCODEC_52)(64bit)
python-gnome-extras
gstreamer-0_10-plugins-ffmpeg
libavformat.so.52()(64bit)
libavformat.so.52(LIBAVFORMAT_52)(64bit)
libwebkitgtk-1.0.so.0()(64bit)
python-gstreamer-0_10
python-mutagen
python-webkitgtk
/usr/bin/ffmpeg
gstreamer-utils
python-curl
python-libtorrent-rasterbar
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsLzma) <= 4.4.6-1
python(abi) = 2.7
python = 2.7

mikrios 11-abr-2014 06:10

Las que puse fue las que saque de packman .

Creo que una de las cosas que oí comentar en el foro es de poner a packman la prioridad alta , porque puede que algunas librerías sean comunes entre otros proveedores y puedan crear problemas de dependencias .

Al poner 70 (un número mas bajo , indica que la prioridad en ese proveedor es mas alta que otro que tenga el valor de 99 ) y esto hace que todas las librerías de ese programa partan de el y no de otros .

¿cual fue la que tu le has puesto ?

Ejemplo de las mias :

Alias Name Enabled Refresh Priority
1 Index_of_/repositories/Kernel:/openSUSE-13.1/standard Index of /repositories/Kernel:/openSUSE-13.1/standard Yes No 99
2 Index_of_/repositories/Printing/openSUSE_13.1 Index of /repositories/Printing/openSUSE_13.1 Yes Yes 99
3 KDE:Current KDE:Current Yes Yes 99
4 KDE_Extra:Current KDE_Extra:Current Yes Yes 99
5 Kernel_estable_3.13 Kernel_estable_3.13 Yes Yes 99
6 download.opensuse.org-Education openSUSE BuildService - Educación Yes Yes 99
7 download.opensuse.org-Stable BuildService de openSUSE - LibreOffice Yes Yes 99
8 download.opensuse.org-Virtualization BuildService de openSUSE - Virtualización (VirtualBox) Yes Yes 99
9 download.opensuse.org-Wine BuildService de openSUSE - Revisiones CVS de Wine Yes Yes 99
10 download.opensuse.org-games BuildService de openSUSE - Juegos Yes Yes 99
11 download.opensuse.org-mozilla BuildService de openSUSE - Mozilla Yes Yes 99
12 ftp.gwdg.de-suse Packman Repository Yes Yes 70
13 home:XRevan86 home:XRevan86 Yes Yes 99
14 home:deltafox home:deltafox Yes Yes 99
15 home:fabio_s home:fabio_s Yes Yes 99
16 openSUSE:13.1 openSUSE:13.1 Yes Yes 99
17 opensuse-guide.org-repo libdvdcss repository Yes Yes 99
18 repo-debug openSUSE-13.1-Debug No Yes 99
19 repo-debug-update openSUSE-13.1-Update-Debug No Yes 99
20 repo-debug-update-non-oss openSUSE-13.1-Update-Debug-Non-Oss No Yes 99
21 repo-non-oss openSUSE-13.1-Non-Oss Yes Yes 99
22 repo-oss openSUSE-13.1-Oss Yes Yes 99
23 repo-source openSUSE-13.1-Source No Yes 99
24 repo-update openSUSE-13.1-Update Yes Yes 99
25 repo-update-non-oss openSUSE-13.1-Update-Non-Oss Yes Yes 99
Si no lo hubiera hecho así puede que algún componente de algún programa tenga una versión superior , y sea ese el que elija , provocando fallo en la aplicación .

Hay un par de comandos que se me olvidaron anotar en la agenda (una chuleta que hago para ir aprendiendo ) uno de ellos fuerza a actualizar la aplicación y el otro comprueba que no tiene fallos y cumple todas sus dependencias .

Como me falta experiencia , voy anotando los consejos y comandos para ir cogiendo soltura con la consola , pero esos dos se me olvido de anotarlos .

Te lo comento porque me gustaría saber si todos los que tienes instalados son del mismo proveedor (sobre todo por las diferencias que me comentas ) , pero también es importante que me digas si has cambiado la prioridad a packman (ya que es una de las primeras cosas que hago cuando termino una instalación y añado programas de ahí ) .

Saludos cordiales

DiabloRojo 11-abr-2014 11:21

Cita:

Iniciado por mikrios (Mensaje 176117)
Creo que una de las cosas que oí comentar en el foro es de poner a packman la prioridad alta , porque puede que algunas librerías sean comunes entre otros proveedores y puedan crear problemas de dependencias .

Otra afirmación gratuita como la que dijisteis sobre la swap.

Packman no usa librerías de sistema, las librerias que compilan son las referentes a Multimedia y algunas otras, no utiliza ninguna libreria Qt de KDE 4 por ejemplo. Mas que nada es un repositorio donde los programas no están capados por el tema de las licencias y no se encuentran en la distribución. Dejemos que sean los propios chicos de Packman que lo explique, el subrayado es mio:
Cita:

Iniciado por PackMan
Nos dedicamos a agrupar el software en paquetes para facilitar la instalación y la desinstalación en un entorno linux. Con ello pretendemos sobre todo publicar los paquetes de software que o bien no están incluidos en las distribuciones o bien la versión incluida está ya desfasada.

Si miras el repositorio Packman en el instalador de Yast y lees las descripciones en ingles, veras que casi todo son programas y las librerías que aparecen son de multimedia.

Veo que has puesto los repositorios de KDE Current y KDE Extra Current, los únicos conflictos que tendrás con Packman sera con los programas de KDE EXtra Current como k3b, amarok, smplayer, etc.... de multimedia, en cambio, ningún conflicto con el escritorio de KDE Current

Mirando tu listado cuanto mas repos mas posibilidades de que haya una actualización que desestabilice tu openSUSE, creo que es una perdida de tiempo actualizar los repos desactivados y habilitar los repos que no se actualizan.

PD: Lee esto: GUIA de Repositorios de openSUSE: Manejo y Funcionamiento

mikrios 12-abr-2014 03:06

Cierto estoy fallando mas que una escopeta (confundí un comentario de kde ) , eso me pasa por leer demasiado de prisa , o cuando estoy un poco cansado .

Efectivamente , eso fue lo que paso , pero solo con k3b , se cambio de proveedor , y el problema desapareció .

Lo que me extraño fue que le da una alternativa a ogg (vorbis ) y me despisto un poco .

Lo que hice fue imprimir las 2 listas la que el pone y la que obtuve de Yast y coinciden aunque cambia el orden (por esa parte no veo problema ; hasta python=2.7 contiene los mismos archivos , pero ordenados de distinta forma ) .

El problema lo veo después
En los requerimientos , los archivos aparecen en distintas rutas (supongo que deberían estar en las mismas y el programa las buscaría ahí ) .

Ejemplos :
La ruta de /bin/sh de programa en Yast :
Código:

/bin/sh
libc.so.6(GLIBC_2.14)(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libm.so.6()(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libstdc++.so.6()(64bit)
libstdc++.so.6(GLIBCXX_3.4)(64bit)
libstdc++.so.6(CXXABI_1.3)(64bit)
libgcc_s.so.1()(64bit)
libgcc_s.so.1(GCC_3.0)(64bit)
libglib-2.0.so.0()(64bit)
libgobject-2.0.so.0()(64bit)
libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
libX11.so.6()(64bit)
libz.so.1()(64bit)

La lista de /bin/sh de sus archivos :
Código:

/bin/sh
libc.so.6(GLIBC_2.14)(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libm.so.6()(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libstdc++.so.6()(64bit)
libstdc++.so.6(GLIBCXX_3.4)(64bit)
libstdc++.so.6(CXXABI_1.3)(64bit)
libglib-2.0.so.0()(64bit)
libgobject-2.0.so.0()(64bit)
libgcc_s.so.1()(64bit)
libgcc_s.so.1(GCC_3.0)(64bit)
libX11.so.6()(64bit)
libz.so.1()(64bit)
libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
libgtk-x11-2.0.so.0()(64bit)
libgdk-x11-2.0.so.0()(64bit)
libpango-1.0.so.0()(64bit)
libpython2.7.so.1.0()(64bit)

La ruta de usr/bin/python de Yast :
Código:

/usr/bin/python
libgtk-x11-2.0.so.0()(64bit)
gstreamer-0_10-plugins-bad
libgdk-x11-2.0.so.0()(64bit)
libpango-1.0.so.0()(64bit)
python-gtk
gstreamer-0_10-plugins-good
libpython2.7.so.1.0()(64bit)
libtag.so.1()(64bit)
python-gstreamer-0_10
python-mutagen
libavcodec.so.52()(64bit)
libavcodec.so.52(LIBAVCODEC_52)(64bit)
libavutil.so.50()(64bit)
libavutil.so.50(LIBAVUTIL_50)(64bit)
gstreamer-0_10-plugins-ffmpeg
gstreamer-utils
libsoup-2.4.so.1()(64bit)
libavformat.so.52()(64bit)
libavformat.so.52(LIBAVFORMAT_52)(64bit)
python-gnome
python-libtorrent-rasterbar

La ruta de /usr/bin/python de sus archivos :
Código:

/usr/bin/python
libsoup-2.4.so.1()(64bit)
gstreamer-0_10-plugins-bad
python-gtk
libtag.so.1()(64bit)
gstreamer-0_10-plugins-good
libavutil.so.50()(64bit)
libavutil.so.50(LIBAVUTIL_50)(64bit)
python-gnome
libavcodec.so.52()(64bit)
libavcodec.so.52(LIBAVCODEC_52)(64bit)
python-gnome-extras
gstreamer-0_10-plugins-ffmpeg
libavformat.so.52()(64bit)
libavformat.so.52(LIBAVFORMAT_52)(64bit)
libwebkitgtk-1.0.so.0()(64bit)
python-gstreamer-0_10
python-mutagen
python-webkitgtk

Y la última ruta de usr/bin/ffmpeg de Yast :
Código:

/usr/bin/ffmpeg
python-curl
libwebkitgtk-1.0.so.0()(64bit)
python-webkitgtk
python-gnome-extras
python(abi) = 2.7
python = 2.7

y su ruta de usr/bin/ffmepg

Código:

/usr/bin/ffmpeg
gstreamer-utils
python-curl
python-libtorrent-rasterbar
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsLzma) <= 4.4.6-1
python(abi) = 2.7
python = 2.7

Creo que la diferencia es bien clara , pero como no conozco el programa , no se que pensar (si supongo que sea el mismo , esas rutas deberían tener los mismos archivos , en cambio unos están cambiados o tienen menos y aparecen en rutas diferentes ,etc ...) .

Por lo que el comenta el programa es el mismo (en Yast solo me aparece esa versión ) y por las diferencias que vi , no se si son reales o es una mala interpretación de Yast , si son reales me supongo que el programa no debería funcionar , pero en eso tu tienes mas experiencia .

En temas de programación estoy a cero y lo que di fue ya hace muchos años y no de esos sistemas (con todos los que hay , me pierdo , por eso voy a paso de tortuga en muchas de esas cuestiones ) .

Saludos cordiales

PD. y por los comentarios que has hecho , tienes toda la razón del mundo , últimamente ando un poco por las nubes , estoy liado con bastantes cosas , que me despisto con facilidad (encuadernado un libro , montando un pc , esperando material, ordenado archivos , probando factory ..etc , así que no te asombres por los fallos , pido disculpas por ellos ) .

Haber si aligero un poco la carga y me pongo a estudiar y ponerme al día .

Edito :
A la espera de otros consejos , lo único que se me ocurre es copiar los archivos mencionados y poner lo en las rutas correspondientes , como indica en yast .
No se que opinaran , lo que saben ,mas de programación , si esas diferencias , pueden ser la causa del problema .

Saludos cordiales


La franja horaria es GMT +2. Ahora son las 02:41.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!