ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   Multimedia (http://www.forosuse.org/forosuse/forumdisplay.php?f=9)
-   -   Problema para reproducir MP4 y RMVB (http://www.forosuse.org/forosuse/showthread.php?t=32630)

surrender 31-may-2015 03:37

Problema para reproducir MP4 y RMVB [SOLUCIONADO]
 
Buenas tardes:
Vengo a ustedes con otra de mis dudas, hace poco instalé Opensuse 13.2 32b con KDE y tengo problemas con la reproducción de archivos RMVB y MP4 usando VLC.
Con los MP4 en algunos (descargados de youtube) solo reproduce audio, la pantalla queda negra.
Con los RMVB arroja el siguiente mensaje:

Códec no soportado:
VLC no puede decodificar el formato «cook» (Cook Audio)
Códec no soportado:
VLC no puede decodificar el formato «RV40» (RealVideo 9/10 (4.0))

Probé varios codecs, reinstalar el programa (con cambio de proveedor a packman) y no ha resultado.
:(

agradezco cualquier ayuda.

Saludos cordiales y muchas gracias

mikrios 31-may-2015 04:22

Hola:

Me supongo que usas la de packman, hasta la fecha me ha reproducido casi topo tipo de formatos, incluidos mkv de 10bit y formatos de vídeo de virtualbox .

En tumbleweed tengo este :
Código:

X79-PRO:~ # zypper se -si vlc
Loading repository data...
Reading installed packages...

S | Name        | Type    | Version    | Arch  | Repository     
--+--------------+---------+-------------+--------+------------------
i | vlc-noX      | package | 2.2.1-279.1 | x86_64 | (System Packages)
i | libvlc5      | package | 2.2.1-279.1 | x86_64 | (System Packages)
i | vlc-qt      | package | 2.2.1-279.1 | x86_64 | (System Packages)
i | vlc-codecs  | package | 2.2.1-279.1 | x86_64 | (System Packages)                                                                                                                         
i | vlc          | package | 2.2.1-279.1 | x86_64 | (System Packages)                                                                                                                         
i | libvlccore8  | package | 2.2.1-279.1 | x86_64 | (System Packages)                                                                                                                         
i | vlc-noX-lang | package | 2.2.1-279.1 | noarch | (System Packages)                                                                                                                         
i | libvlccore7  | package | 2.1.5-241.2 | x86_64 | (System Packages)

Otra opción creo que es smplayer (pero cuando lo probé con un strace, he visto que se come algunos recursos, mas que vlc) .

Otro es :
Cita:


kodi - Kodi Media center

KODI media center is a free cross-platform media-player jukebox and entertainment hub. KODI can play a spectrum of of multimedia formats, and featuring playlist, audio visualizations, slideshow, and weather forecast functions, together third-party plugins.
Que antes se conocía por XBMC , pero ahora se llama kodi.

Saludos cordiales

mad_soft 31-may-2015 12:15

yo todavía soy de los que todavia usan MPlayer + gnome-mplayer (mplayer por consola solo video sin nada mas que el uso de teclado para volumen, pausa, pantallacompleta..etc. y gmplayer para interfaz en gtk2).
Sino recuerdo mal vlc es muy bueno, pero a veces me he encontrado videos que mplayer reproduce y vlc no.
Prueba mplayer a ver que pasa

DiabloRojo 31-may-2015 16:27

Cita:

Iniciado por surrender (Mensaje 184944)
Códec no soportado:
VLC no puede decodificar el formato «cook» (Cook Audio)
Códec no soportado:
VLC no puede decodificar el formato «RV40» (RealVideo 9/10 (4.0))

Para reproducirlo solo necesitas VLC o MPlayer pero también necesitaras, ademas de vlc-codecs, los w32codec-all.

:adios:

surrender 01-jun-2015 01:52

Mikrios:

Esto tengo en VLC:

linux-e5i8:/home/jorge # zypper se -si vlc
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...

E | Nombre | Tipo | Versión | Arquitectura | Repositorio
--+-------------------+----------+-------------------+--------------+-------------------
i | libvlc5 | paquete | 2.2.1-285.1 | i586 | Packman Repository
i | libvlccore8 | paquete | 2.2.1-285.1 | i586 | Packman Repository
i | vlc | paquete | 2.2.1-285.1 | i586 | Packman Repository
i | vlc-codecs | paquete | 2.2.1-285.1 | i586 | Packman Repository
i | vlc-noX | paquete | 2.2.1-285.1 | i586 | Packman Repository
i | vlc-noX-lang | paquete | 2.2.1-285.1 | noarch | Packman Repository
i | vlc-qt | paquete | 2.2.1-285.1 | i586 | Packman Repository
i | libvlccore9 | paquete | 3.0.0+git3202-1.8 | i586 | Packman Repository
i | libvlc6 | paquete | 3.0.0+git3202-1.8 | i586 | Packman Repository


¿Está bien?

Diablo:
Intenté instalar w32codecs, pero me arroja el siguiente error 8desde consola y yast)
linux-e5i8:/home/jorge # zypper install w32codec-all
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...
Resolviendo dependencias...

Problema: no hay nada que proporcione libstdc++.so.5 y que lo necesita w32codec-all-20110131-1.1.i586
Solución 1: no instalar w32codec-all-20110131-1.1.i586
Solución 2: romper w32codec-all-20110131-1.1.i586 ignorando algunas de sus dependencias

Elija la solución usando '1'o cancele usando 'c' [1/2/c] (c): c


¿Qué puedo hacer?

mikrios 01-jun-2015 04:01

Hola:

He probado en la 13.2 64bit , mkv,divx,mp4,avi etc... y sin problemas.

La versión de la cual hice la prueba es esta:
Código:


RMP-IV-B-13-2:~ # zypper se -si vlc
Loading repository data...
Reading installed packages...

S | Name        | Type    | Version    | Arch  | Repository         
--+--------------+---------+-------------+--------+---------------------
i | vlc-noX      | package | 2.2.1-285.1 | x86_64 | Packman Repository 
i | libvlc5      | package | 2.2.1-285.1 | x86_64 | Packman Repository 
i | vlc-qt      | package | 2.2.1-285.1 | x86_64 | Packman Repository 
i | vlc-codecs  | package | 2.2.1-285.1 | x86_64 | Packman Repository 
i | vlc          | package | 2.2.1-285.1 | x86_64 | Packman Repository 
i | libvlccore8  | package | 2.2.1-285.1 | x86_64 | Packman Repository 
i | vlc-noX-lang | package | 2.2.1-285.1 | noarch | Packman Repository 
i | libvlccore7  | package | 2.1.5-2.4.1 | x86_64 | openSUSE-13.2-Update

Y está actualizado a fecha de hoy ( 01-06-2015) , veo que no coincide algunos paquetes; pero claro no estoy usando la versión de 32bit .

Pero en los listados me aparece esto para i586 y packman :

Código:

RMP-IV-B-13-2:~ # zypper se -s vlc |grep i586 |grep Packman
  | vlc-beta-qt                    | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
  | libvlc-qt-debugsource          | package    | 0.10.0-5.1        | i586  | Packman Repository 
  | libvlc-qt-widgets0_10          | package    | 0.10.0-5.1        | i586  | Packman Repository 
  | vlc-gnome                      | package    | 2.2.1-285.1      | i586  | Packman Repository 
  | libvlc-qt0_10-debuginfo        | package    | 0.10.0-5.1        | i586  | Packman Repository 
  | vlc-debugsource                | package    | 2.2.1-285.1      | i586  | Packman Repository 
  | vlc-debuginfo                  | package    | 2.2.1-285.1      | i586  | Packman Repository 
  | vlc-beta-devel                  | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
  | vlc-gnome-debuginfo            | package    | 2.2.1-285.1      | i586  | Packman Repository 
  | vlc-noX-debuginfo              | package    | 2.2.1-285.1      | i586  | Packman Repository 
  | vlc-qt-debuginfo                | package    | 2.2.1-285.1      | i586  | Packman Repository 
  | npapi-vlc-beta-debuginfo        | package    | 2.2.0-1.1        | i586  | Packman Repository 
  | libvlc-qt-qml0_10-debuginfo    | package    | 0.10.0-5.1        | i586  | Packman Repository 
  | npapi-vlc-beta                  | package    | 2.2.0-1.1        | i586  | Packman Repository 
  | libvlc-qt-devel                | package    | 0.10.0-5.1        | i586  | Packman Repository 
  | phonon-backend-vlc-debuginfo    | package    | 0.8.2-16.3        | i586  | Packman Repository 
  | phonon-backend-vlc              | package    | 0.8.2-16.3        | i586  | Packman Repository 
  | npapi-vlc-debuginfo            | package    | 2.2.0-1.1        | i586  | Packman Repository 
  | vlc-beta-qt-debuginfo          | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
v | vlc-noX                        | package    | 2.2.1-285.1      | i586  | Packman Repository 
  | libvlc-qt-widgets0_10-debuginfo | package    | 0.10.0-5.1        | i586  | Packman Repository 
  | vlc-beta-debugsource            | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
v | libvlc5                        | package    | 2.2.1-285.1      | i586  | Packman Repository 
v | vlc-qt                          | package    | 2.2.1-285.1      | i586  | Packman Repository 
  | vlc-beta-codecs-debuginfo      | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
  | libvlccore8-debuginfo          | package    | 2.2.1-285.1      | i586  | Packman Repository 
  | vlc-beta-gnome-debuginfo        | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
  | libvlccore9                    | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
  | vlc-beta-noX                    | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
  | vlc-devel                      | package    | 2.2.1-285.1      | i586  | Packman Repository 
  | libvlc-qt-qml0_10              | package    | 0.10.0-5.1        | i586  | Packman Repository 
v | vlc-codecs                      | package    | 2.2.1-285.1      | i586  | Packman Repository 
  | libvlc6-debuginfo              | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
  | vlc-beta-noX-debuginfo          | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
  | libvlc6                        | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
  | vlc-codecs-debuginfo            | package    | 2.2.1-285.1      | i586  | Packman Repository 
v | vlc                            | package    | 2.2.1-285.1      | i586  | Packman Repository 
  | vlc-beta                        | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
  | npapi-vlc                      | package    | 2.2.0-1.1        | i586  | Packman Repository 
  | phonon-backend-vlc-debugsource  | package    | 0.8.2-16.3        | i586  | Packman Repository 
  | npapi-vlc-debugsource          | package    | 2.2.0-1.1        | i586  | Packman Repository 
  | vlc-beta-debuginfo              | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
  | vlc-beta-codecs                | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
  | vlc-beta-gnome                  | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository 
  | libvlc-qt0_10                  | package    | 0.10.0-5.1        | i586  | Packman Repository 
  | libvlc5-debuginfo              | package    | 2.2.1-285.1      | i586  | Packman Repository 
v | libvlccore8                    | package    | 2.2.1-285.1      | i586  | Packman Repository 
  | npapi-vlc-beta-debugsource      | package    | 2.2.0-1.1        | i586  | Packman Repository 
  | libvlccore9-debuginfo          | package    | 3.0.0+git3202-1.8 | i586  | Packman Repository

Estas dos que tienes ¿no son betas?
Código:

i | libvlccore9 | paquete | 3.0.0+git3202-1.8 | i586 | Packman Repository
i | libvlc6 | paquete | 3.0.0+git3202-1.8 | i586 | Packman Repository

Ademas no son de la misma versión ,no se me parece un poco raro.

Mira de comprobar las dependencias con zypper ve , habría algún problema en que instalaras estas :

o sea las que ponen v :
Código:

v | libvlccore8                    | package    | 2.2.1-285.1      | i586  | Packman Repository 
v | libvlc5                        | package    | 2.2.1-285.1      | i586  | Packman Repository

Puedes hacerlo desde yast , pero procura que sean de las versiones 2.2.1-285.1 .

Saludos cordiales

DiabloRojo 01-jun-2015 10:02

Cita:

Iniciado por surrender (Mensaje 184964)
Diablo:
Intenté instalar w32codecs, pero me arroja el siguiente error 8desde consola y yast)
linux-e5i8:/home/jorge # zypper install w32codec-all
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...
Resolviendo dependencias...

Problema: no hay nada que proporcione libstdc++.so.5 y que lo necesita w32codec-all-20110131-1.1.i586
Solución 1: no instalar w32codec-all-20110131-1.1.i586
Solución 2: romper w32codec-all-20110131-1.1.i586 ignorando algunas de sus dependencias

Elija la solución usando '1'o cancele usando 'c' [1/2/c] (c): c


¿Qué puedo hacer?

Necesitas instalar el paquete libstdc++33-32bit

Pero debería haber instalado, ¿Que repositorios tienes?, danos la salida de zypper lr -u acotandolo con quotes o codes.

surrender 01-jun-2015 19:50

Mikrios:
Eliminé las versiones 3.0 e instalé las versiones 2.0
linux-e5i8:/home/jorge # zypper se -si vlc
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...

E | Nombre | Tipo | Versión | Arquitectura | Repositorio
--+--------------+----------+-------------+--------------+-------------------
i | libvlc5 | paquete | 2.2.1-285.1 | i586 | Packman Repository
i | libvlccore8 | paquete | 2.2.1-285.1 | i586 | Packman Repository
i | vlc | paquete | 2.2.1-285.1 | i586 | Packman Repository
i | vlc-codecs | paquete | 2.2.1-285.1 | i586 | Packman Repository
i | vlc-noX | paquete | 2.2.1-285.1 | i586 | Packman Repository
i | vlc-noX-lang | paquete | 2.2.1-285.1 | noarch | Packman Repository
i | vlc-qt | paquete | 2.2.1-285.1 | i586 | Packman Repository


Pero el problema persiste.


Diablo: Estos son mis repositorios
linux-e5i8:/home/jorge # zypper lr -u
# | Alias | Nombre | Habilitado | Actualizar | URI
---+-------------------------------+---------------------------------------------------+------------+------------+--------------------------------------------------------------------------------------
1 | SuSE | SuSE | Si | Si | http://download.videolan.org/SuSE/13.2/
2 | devel:languages:go | devel:languages:go | Si | Si | http://download.opensuse.org/reposit...nSUSE_Factory/
3 | devel:languages:perl | devel:languages:perl | Si | Si | http://download.opensuse.org/reposit...openSUSE_13.2/
4 | download.opensuse.org-4.4 | BuildService de openSUSE - LibreOffice | Si | Si | http://download.opensuse.org/reposit...openSUSE_13.2/
5 | download.opensuse.org-Extra | BuildService de openSUSE - KDE:Extra | Si | Si | http://download.opensuse.org/reposit...openSUSE_13.2/
6 | download.opensuse.org-KDE3 | BuildService de openSUSE - KDE:KDE3 | Si | Si | http://download.opensuse.org/reposit...openSUSE_13.2/
7 | download.opensuse.org-Wine | BuildService de openSUSE - Revisiones CVS de Wine | Si | Si | http://download.opensuse.org/reposit...openSUSE_13.2/
8 | download.opensuse.org-mozilla | BuildService de openSUSE - Mozilla | Si | Si | http://download.opensuse.org/reposit...openSUSE_13.2/
9 | ftp.gwdg.de-suse | Packman Repository | Si | Si | http://ftp.gwdg.de/pub/linux/packman...openSUSE_13.2/
10 | geogebra | geogebra | Si | Si | http://www.geogebra.net/linux/rpm/i386
11 | home:Kenzy:packages | home:Kenzy:packages | Si | Si | http://download.opensuse.org/reposit...openSUSE_13.2/
12 | home:Overman79:JDownloader | home:Overman79:JDownloader | Si | Si | http://download.opensuse.org/reposit...openSUSE_13.2/
13 | home:aevseev | home:aevseev | Si | Si | http://download.opensuse.org/reposit...openSUSE_13.2/
14 | home:smarty12 | home:smarty12 | Si | Si | http://download.opensuse.org/reposit...openSUSE_13.2/
15 | home:ykoba | home:ykoba | Si | Si | http://download.opensuse.org/reposit...openSUSE_13.2/
16 | multimedia:libs | multimedia:libs | Si | Si | http://download.opensuse.org/reposit...openSUSE_13.2/
17 | openSUSE-13.2-0 | openSUSE-13.2-0 | No | No | cd:///?devices=/dev/disk/by-id/ata-Optiarc_DVD_RW_AD-7700H
18 | opensuse-guide.org-repo | libdvdcss repository | Si | Si | http://opensuse-guide.org/repo/13.2/
19 | repo-debug | openSUSE-13.2-Debug | No | Si | http://download.opensuse.org/debug/d...13.2/repo/oss/
20 | repo-debug-update | openSUSE-13.2-Update-Debug | No | Si | http://download.opensuse.org/debug/update/13.2/
21 | repo-debug-update-non-oss | openSUSE-13.2-Update-Debug-Non-Oss | No | Si | http://download.opensuse.org/debug/update/13.2-non-oss/
22 | repo-non-oss | openSUSE-13.2-Non-Oss | Si | Si | http://download.opensuse.org/distrib.../repo/non-oss/
23 | repo-oss | openSUSE-13.2-Oss | Si | Si | http://download.opensuse.org/distrib...13.2/repo/oss/
24 | repo-source | openSUSE-13.2-Source | No | Si | http://download.opensuse.org/source/...13.2/repo/oss/
25 | repo-update | openSUSE-13.2-Update | Si | Si | http://download.opensuse.org/update/13.2/
26 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Si | Si | http://download.opensuse.org/update/13.2-non-oss/

mikrios 01-jun-2015 20:34

Hola :

Si tienes vlc de packman, por que has añadido el repositorio 1 de videolan ? .

Después tienes repositorios de usuarios añadidos a la lista , está bien que instales alguna aplicación de la página de descargas, pero creo recordar que no era aconsejable mantener el repositorio del mismo , de todas formas ya te responderá D.Rojo al respeto.

No tienes dependencias con todos los repos que tienes ? zypper ve

Saludos cordiales.

Edito :

Que prioridad le tienes puesto a packman (zypper lr -p) ? , en mi caso le he puesto 70 nº mas bajo prioridad mas alta (con eso me aseguro que los codecs y librerías se actualicen de ese proveedor )
Pienso que tienes repositorios de sobra y algunos que no son necesarios .

Mira de arreglar lo de la prioridad si es que la tienes mal y después no se si con un zypper ref y un zypper up te pueda solucionar el problema (ademas creo que deberías solucionar el tema de los repositorios ) .

Saludos

surrender 01-jun-2015 21:52

Mikrios:
Recomiendas eliminar algunos repositorios?
A qué te refieres con dependencias?

Saludos


La franja horaria es GMT +2. Ahora son las 07:20.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!