ForoSUSE

ForoSUSE (http://www.forosuse.org/forosuse/index.php)
-   General OpenSUSE (http://www.forosuse.org/forosuse/forumdisplay.php?f=23)
-   -   Actualización KDE 4.8 [solucionado] (http://www.forosuse.org/forosuse/showthread.php?t=27647)

manolobarea 27-ene-2012 22:27

Actualización KDE 4.8 [solucionado]
 
Hola estoy intentando actualizar a KDE 4.8 pero cuando ejecuto la orden obtengo la siguiente salida:


manolobarea@linux-7cqa:~> sudo zypper dup --from KDE:Release
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...
Calculando actualización...
2 Problemas:
Problema: qt4-qtscript-0.1.0-14.1.2.x86_64 requiere libqt4 = 4.7.4, pero este requisito no puede cumplirse
Problema: kdm-4.8.0-723.3.x86_64 requiere kdm-branding = 4.8.0, pero este requisito no puede cumplirse

Problema: qt4-qtscript-0.1.0-14.1.2.x86_64 requiere libqt4 = 4.7.4, pero este requisito no puede cumplirse
proveedores no instalables: libqt4-4.7.4-19.2.2.x86_64[openSUSE-12.1-12.1-1.4]
libqt4-4.7.4-19.2.2.i586[repo-oss]
libqt4-4.7.4-19.2.2.x86_64[repo-oss]
Solución 1: Se realizarán las siguientes acciones:
mantener el antiguo libqt4-4.7.4-19.4.1.x86_64
mantener el antiguo kde4-kgreeter-plugins-4.7.4-6.30.7.x86_64
mantener el antiguo kdebase4-workspace-liboxygenstyle-4.7.4-6.30.7.x86_64
Solución 2: desinstalación de qt4-qtscript-0.1.0-14.1.2.x86_64
Solución 3: mantener el antiguo libqt4-4.7.4-19.4.1.x86_64
Solución 4: romper qt4-qtscript ignorando algunas de sus dependencias

Elija la solución usando '1'u omitir, reintentar o cancelar [1/2/3/4/o/r/c] (c): 2

Problema: kdm-4.8.0-723.3.x86_64 requiere kdm-branding = 4.8.0, pero este requisito no puede cumplirse
proveedores no instalables: kdm-branding-upstream-4.8.0-723.3.i586[KDE:Release]
kdm-branding-upstream-4.8.0-723.3.x86_64[KDE:Release]
kdm-branding-basedonopensuse-12.1-6.1.2.i586[repo-oss]
kdm-branding-basedonopensuse-12.1-6.1.2.x86_64[repo-oss]
Solución 1: Se realizarán las siguientes acciones:
mantener el antiguo kdm-4.7.4-6.30.7.x86_64
mantener el antiguo kdm-branding-openSUSE-12.1-15.4.22.noarch
mantener el antiguo libkdeedu4-data-4.7.4-2.10.3.noarch
Solución 2: Se realizarán las siguientes acciones:
mantener el antiguo kdm-4.7.4-6.30.7.x86_64
mantener el antiguo kde4-kgreeter-plugins-4.7.4-6.30.7.x86_64
mantener el antiguo kdm-branding-openSUSE-12.1-15.4.22.noarch
mantener el antiguo libkdeedu4-data-4.7.4-2.10.3.noarch
Solución 3: Se realizarán las siguientes acciones:
mantener el antiguo kdm-4.7.4-6.30.7.x86_64
mantener el antiguo kde4-kgreeter-plugins-4.7.4-6.30.7.x86_64
mantener el antiguo libkdeedu4-data-4.7.4-2.10.3.noarch
Solución 4: desinstalación de kdm-4.7.4-6.30.7.x86_64
Solución 5: desinstalación de kdm-branding-openSUSE-12.1-15.4.22.noarch
Solución 6: romper kdm ignorando algunas de sus dependencias


He leído en el foro en inglés que para el primer caso la opción a seleccionar es la 2, pero en esta segunda pregunta ya no sé cuál elegir, si alguien ha realizado la actualización podría ser tan amable de explicarnos como lo hizo.

Gracias

jcsl 27-ene-2012 22:43

Hola.

Yo usé la 5. Para la primera yo habría elegido 3 o 4, no es lo más seguro pero siempre se puede deshacer en caso de problema.

Un saludo.

manolobarea 27-ene-2012 22:52

He encontrado una forma más cómoda de hacerlo lo acabo actualizar, está en el foro en inglés:

hay que desinstalar :

sudo zypper rm kdm-branding-openSUSE

Después:

sudo zypper rm kdm-branding-basedonopensuse

con esto ya no nos saldrán los mensajes de dependencias, por último:

sudo zypper dup

En caso de no hacerlo así, a mí me salió un login antiguo fvwm2.

Suerte y a disfrutar.

sieg84 28-ene-2012 09:07

intente actualizar, pero me salio eso de las dependencias, mejor me espero unos días a que los paquetes estén completos [o tal vez al 4.8.1].
me paso lo mismo cuando recién salio opensuse 12.1 y quise actualizar.

sieg84 29-ene-2012 02:08

pues como dije antes, algo parecido me paso cuando recien salio opensuse 12.1 y quise actualizarlo a kde 4.7.3, daba problemas de dependencias con kwin y algo mas.
mejor esperaré kde 4.8.1

moray33 29-ene-2012 17:35

¿Cuando se podrá actualizar desde los repositorios "normales"? Para no andarme con rollos de dependencias de estas si se actualizará pronto...

sieg84 30-ene-2012 04:46

Cita:

Iniciado por moray33 (Mensaje 149371)
¿Cuando se podrá actualizar desde los repositorios "normales"? Para no andarme con rollos de dependencias de estas si se actualizará pronto...

en los repos "normales" solo quedara kde 4.7.2 el que trae de serie openSUSE, solo se añaden correcciones y actualizaciones de seguridad.

para actualizar KDE4 están estos:
http://en.opensuse.org/KDE_repositories

solo es esperar un poco para que añadan todos los paquetes de KDE4.8.X

xisco 30-ene-2012 10:16

hola,
me pasa solo a mi o al actualizar se pierde la pantalla de inicio de suse?? ahora me sale una de kde bastante mas fea.
Se puede solucionar?? porque cuando agrego el branding de suse me quita el de kde y entonces me arranca con el gestor de las X11 mas feo aun :(

Salu2

sieg84 30-ene-2012 10:19

Cita:

Iniciado por xisco (Mensaje 149396)
hola,
me pasa solo a mi o al actualizar se pierde la pantalla de inicio de suse?? ahora me sale una de kde bastante mas fea.
Se puede solucionar?? porque cuando agrego el branding de suse me quita el de kde y entonces me arranca con el gestor de las X11 mas feo aun :(

Salu2

es por lo mismo de las dependencias que faltan.
quitaste esto:
Cita:

Problema: kdm-4.8.0-723.3.x86_64 requiere kdm-branding = 4.8.0, pero este requisito no puede cumplirse
supongo que hay que esperar a que agreguen el branding de 12.1 a kde 4.8.X o regresar al 4.7.4.

manolobarea 30-ene-2012 11:08

Xisco, eso pasa por haberlo hecho de la primera forma directamente con zypper dup

Este es el orden correcto

sudo zypper rm kdm-branding-openSUSE

Después:

sudo zypper rm kdm-branding-basedonopensuse

con esto ya no nos saldrán los mensajes de dependencias, por último:

sudo zypper dup

Pero ahora primero debes colocar los repos del KDE 4.7 hacer un zypper dup para hacer un downdate y volver al 4.7 y luego volver a colocar los repos del KDE 4.8 y actualizar de la forma en que te he indicado. Así al menos lo he realizado y no me ha dado ningún problema. Un saludo


La franja horaria es GMT +2. Ahora son las 08:48.

Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.


Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!