PDA

Ver la Versión Completa : suse 10 - no inicia gnome


xma
04-nov-2006, 14:24
Hola,

Era para ver si a alguien le ha pasado lo mismo que a mi,

Algunas de las instalaciones que he hecho, no se muy bien porque de repente un dia voy a arrancar el ordenador y no me inicia sesion en el escritorio sino que se queda en una sesion de shell.

Por ejemplo, esto me ha pasado en una instalación desktop que tengo en mi portatil, la unica solución que encuentro es reinstalar el sistema, pero como no me parece muy buena idea, queria saber si a alguien mas le ha pasado y si alguien sabe como solucionarlo.

Muchas gracias a todos,

DiabloRojo
04-nov-2006, 15:00
Mira que fallo aparece en los ficheros /var/log/Xorg.0.log y kdm.log o gdm.log

natanmq
04-nov-2006, 15:27
no lo recuerdo muy bien, asi que no te puedo decir el archivo exacto, pero podria haber tenido algun error y haberse modificado el runlevel en /etc/init.d
lo veo poco probable, pero si el runlevel ha sido modificado a 3, has de cambiarlo a 5

de todas formas, después de que inicias sesión en modo texto, puedes arrancar las Xwindows? o es imposible arrancar el sistema gráfico?

que me corrijan si he dicho cosas sin mucho sentido, estoy desentrenado...

xma
04-nov-2006, 17:55
disculpad porque antes no he puesto muchos detalles (es que no tenia el portatil conmigo)

A ver,
cuando arranca pone

Skipped services in runlevel 5: nfs smbfs

Y luego e Xorg.0.log no si que aparecen algunos mensajes de error pero no me parecen muy graves (no se pueden cargar unas fuentes, etc...)

En gdm/0.log veo el siguiente error:

X Error of failed request: BadLength (poly requesr too large or internal Xlib length error).

Al intentar hacer "startx": me sale el error del Badlength

Muchas gracias

DiabloRojo
04-nov-2006, 18:00
http://www.google.es/search?hl=es&q=X+Error+of+failed+request%3A+BadLength+too+large +or+internal+Xlib+length+error%29.&btnG=B%C3%BAsqueda&meta=