PDA

Ver la Versión Completa : firefox 2.0


doctornaro
30-oct-2006, 13:13
Buenos dias a todos. Mi distro es suse 10.0, me acabo de bajar firefox 2.0 de la página de mozilla, en formato tar.gz, pero no se como instalarlo, he intentado buscarlo en rpm pero no lo he hallado, también lo he intentado usando apt-get, pero me sale lo siguiente:

gerard@linux:~> sudo -s
Password:
linux:/home/gerard # apt-get install firefox-2.0
Leyendo listas de paquetes... Done
Construyendo árbol de dependencias... Done
E: No se encontró el paquete firefox-2.0
linux:/home/gerard #

En la carpeta del fichero descomprimido sale el icono de archivo binario "firefox" y arranca firefox 2.0, pero sin tenerlo instalado. Alguien me puede ayudar? Gracias.

rocker_rose
30-oct-2006, 16:53
hola que tal master??
cuando tenes archivos .tar.gz son tenes que hacer primero esto para descomprimirlos

gunzip nombre.tar.gz ----- esto te lo va a dejar solo con el tar y haciendo lo siguiente
tar -xf nombre.tar lo descomprimis por completo y ahi te crea la carpeta

espero que te sirva master

s2

hurior
30-oct-2006, 17:51
Eso hace funcionar el firefox2 pero no te borra el anterior y lo sustituye por el nuevo, que creo que es lo que pregunta nuestro amigo. Además yo estoy en la misma situación. ¿alguien nos echa una mano?

Gracias

tomeu
30-oct-2006, 17:58
En la carpeta del fichero descomprimido sale el icono de archivo binario "firefox" y arranca firefox 2.0, pero sin tenerlo instalado. Alguien me puede ayudar? Gracias. El tar.gz bajado de mozilla se instala descomprimiendolo, no lleva un instalador propiamente dicho, luego no es correcto que digas que te arranca sin tenerlo instalado. Lo que sucede es que no tienes su binario asociado a /usr/bin y por lo que parece lo has descomprimido en un directorio de usuario

Arkantos_cero
30-oct-2006, 18:06
El tar.gz bajado de mozilla se instala descomprimiendolo, no lleva un instalador propiamente dicho, luego no es correcto que digas que te arranca sin tenerlo instalado. Lo que sucede es que no tienes su binario asociado a /usr/bin y por lo que parece lo has descomprimido en un directorio de usuario

Mmm a ver
¿Con esto quieres decir que debemos colocar el archivo a descomprimir dentro de /usr/bin , y desde allì ejecutar los comandos que indica rocker_rose?
¿Eso asocia "su binario a /usr/bin"?
¿Esto sustituirà a la vieja versiòn de Firefox?

Disculpa si las preguntas son tontas, apenas logrè conexion en Linux.

tomeu
30-oct-2006, 18:06
Para actualizar a firefox 2.0 con los rpm compilados para suse-10.0: http://ftp.opensuse.org/pub/opensuse/repositories/mozilla/SUSE_Linux_10.0/
Y ahí, miras en /i586 ó /x86_64 (según tu arquitectura) y te puedes bajar los rmps.

Si usas apt-get mira en la fuente "projects"

tomeu
30-oct-2006, 19:27
Mmm a ver
¿Con esto quieres decir que debemos colocar el archivo a descomprimir dentro de /usr/bin , y desde allì ejecutar los comandos que indica rocker_rose?
¿Eso asocia "su binario a /usr/bin"?
¿Esto sustituirà a la vieja versiòn de Firefox?

Disculpa si las preguntas son tontas, apenas logrè conexion en Linux.

No. No debes descomprimirlo en /usr/bin/ El lugar idóneo para instalar paquetes grandes de terceros es /opt/ . E instalarlo en ese directorio no significa una asociación automática

En tu /usr/bin actual está asociado el firefox de la distro (instalado en /usr/lib/firefox/). En todo caso podrías quitar su enlace su
cd /usr/bin
rm -r firefox Y poner el nuevoln -s /opt/firefox/firefox /usr/bin/ Para ver si ha funcionado, teclea firefox en un terminal o intérprete de comandos, si se abre el firefox-2.0 bajado de mozilla es que sí.

Ah, y desde luego que instalando el tar.gz NO sustituirás el firefox de la distro.

Arkantos_cero
30-oct-2006, 19:33
Gracias por tu ràpida respuesta (la esperaba), sin embargo,
¿Es necesaro hacer lo arriba señalado si tengo los RPMS?

Supongo que instalando dicho RPM asì directamente (ya me lo descarguè, por cierto, gracias a tu enlace lleguè al de 64 Bits), todo resulta màs sencillo.

¿Es asì? ¿Que opinan?

tomeu
30-oct-2006, 19:47
¿Es necesaro hacer lo arriba señalado si tengo los RPMS?No. Pues con un rpm -Uvih firefox-2.0.rpm actualizas el actual

Si te responde que fallan dependencias deberás bajarte los rpms faltantes. Lo mejor es añadir a Smart esa dirección como fuente (rpm - meta data)

Arkantos_cero
09-nov-2006, 03:21
Bueno muchachos les escribo la ùnica forma que logrè que funcionara, algo newbie pero efectiva. (Para 10.1)

1. Encuentro En otro Thread el repo : http://ftp4.gwdg.de/pub/linux/suse/opensuse/repositories/mozilla/SUSE_Linux_10.1/
lo agrego a el Yast.
2. En la lista de Repos ya estaba activo Pakman y Gurù, ademas de los acostumbrados Oss y Non-Oss (esto lo copio aca para decir el ambiente idèntico que tenìa mi maquina, por si acaso no funciona en ustedes)
2. Voy a agregar o quitar software, busco Mozilla en vez de Firefox.
3. Selecciono todos los paquetes de Mozilla, asì de una vez se instalan el Thunderbird. Con esto logrè solventar los tantos errores de dependencias que evitaba que pudiera instalar el Firefox.4. Compruebo que Mozilla Firefox tenga el icono de actualizacion, asi como cualquier otro en cuya comparacion el instalado en su pc es inferior al del repo.
5. Despues de la instalacion, Yast (buena esa por ellos:dedosarri) es capaz de asociar los iconos del viejo Firefox con el 2.0.
6. Finalmente en la ventana inicial o primera pestaña, aparecerà la pagina de Firefox indicando que se ha realizado la actualizaciòn. Aprovechan esa ventana para instalar el plugin del diccionario en español, de una vez..

Resultado:
Mozilla/5.0 (X11; U; Linux x86_64; es-ES; rv:1.8.1) Gecko/20061023 SUSE/2.0-37.1 Firefox/2.0 :durmiendo

Saludos.

head777
09-nov-2006, 09:01
hola que tal como estan la verdad es que no se que hacer con este bendito firefox 2 no lo puedo instalar de ningun modo por mas que trato no me lo permite si lo intento instalar por medio del rpm que me baje me dan estos errores :

linux-6wsd:/home/dahbura/Desktop # rpm -i MozillaFirefox-2.0-37.1.i586.rpm
error: Failed dependencies:
mozilla-nspr >= 4.6.3 is needed by MozillaFirefox-2.0-37.1.i586
mozilla-nss >= 3.11.3 is needed by MozillaFirefox-2.0-37.1.i586
libnss3.so(NSS_3.11.1) is needed by MozillaFirefox-2.0-37.1.i586

y si es problema de dependencias me baje las que me hacian falta como esa de mozilla-nspr y a la hora de instalarla me da este error:

linux-6wsd:/home/dahbura/Desktop # rpm -i mozilla-nspr-4.6.3-6.1.i586.rpm
file /usr/lib/libnspr4.so from install of mozilla-nspr-4.6.3-6.1 conflicts with file from package mozilla-nspr-4.6.1-20
file /usr/lib/libplc4.so from install of mozilla-nspr-4.6.3-6.1 conflicts with file from package mozilla-nspr-4.6.1-20
file /usr/lib/libplds4.so from install of mozilla-nspr-4.6.3-6.1 conflicts with file from package mozilla-nspr-4.6.1-20


y si quiero instalar la otra bendita dependencia me da este error:

linux-6wsd:/home/dahbura/Desktop # rpm -i mozilla-nss-3.11.3-3.1.i586.rpm
error: Failed dependencies:
mozilla-nspr >= 4.6.3 is needed by mozilla-nss-3.11.3-3.1.i586


hey de verdad si alguien me podria ayudar le estaria muy agradecido por su amabilidad

xisco
09-nov-2006, 10:07
Instalalos con la opcion --nodeps o algo asi para que ignore dependencias ademas yo pondria -Uvh en lugar de -i. Como yo te digo se supone que actualiza paquetes.
Salu2

tomeu
09-nov-2006, 15:10
Para resolver dependencias, mejor usas un gestor de paquetes como Smart; hay varios posts en el foro para su instalación y uso (entre ellos este mismo), y otros de cómo agregar la fuente donde esta el rpm de suse para ff-2.0

Y si prefieres usar los rpms descargados, y entre sí hay problemas de dependencias, pon todos esos en una carpeta aparte mkdir nombre_carpeta y luego como root:
rpm -Uvih *.rpm

Por cierto te olvidabas de U "update", es de suponer que ya tienes firefox 1.5.0.x ¿no?

Con *.rpm instalas/actualizas todos los rpm de un directorio.

Kurush_Ishraqi
11-nov-2006, 19:03
Bueno, ya instalé el Firefox 2.0 y hasta el momento sin problemas; tengo que configurar su corrector ortográfico y tal, pero con tiempo iré haciéndolo.

UN saludo.

tomeu
12-nov-2006, 07:44
.. tengo que configurar su corrector ortográfico y tal, ... Eso es tan fácil como lo siguiente:
1.- Abres cualquier página donde puedas escribir; por ejemplo un nuevo mensaje de forosuse.
2.- Con el cursor sobre el texto del mensaje, clic derecho, y del menú que se despliega, eliges: "Añadir diccionarios"
3.- Se te abrirá una página de "addons" de firefox, y si tienes firefox en español, ya te pondrá de forma ostensiblemente visible el botón para instalar el diccionario español, con simple clic sobre él se instala el diccionario como un complemento (extensión) más; reiniciar y listo.

Lo de "y tal" no sé a que te refieres :D (¿será que Jesús Gil dejó escuela?)

hela
12-nov-2006, 12:42
tomeu como puedo añadir esa fuente a YASTo APT para usarla? es que me esta dando error y no sé si es algo de mi configuración o queno he indicado bien los pasos

tomeu
12-nov-2006, 13:16
Perdón si creé confusión, no es "projects" sino "suse-projects"

Aquí tienes todo el listado de fuentes de apt para suse_10-i386:
ftp://ftp4.gwdg.de/pub/linux/suse/apt/SuSE/10.0-i386/

Aunque acabo de revisarlo, y no veo por ningún lado (en apt), al firefox-2.0, con lo que tendrías que instalarlo desde la otra fuente con YaST o Smart.

Para añadir fuentes a apt hay que editar su archivo "sources.list" como root: kate /etc/apt/sources.list Para añadir al YaST1.- YaST
2.- Software
3.- Cambiar fuente de instalación
4.- Añadir
5.- Eliges HTTP
6.- Url: ftp.opensuse.org/pub/opensuse/repositories/mozilla/SUSE_Linux_10.0/
Ojo que es un repositorio con paquetes inestables y betas (como el de thunderbird 1.99 entre otros), osea que después de instalar con él firefox (y solo firefox 2.0) mejor lo deshabilitas. Usalo a tu propio riesgo.

A mi me parece mejor opción, bajarse e instalar Swiftfox-2.0 www.getswiftfox.com creando para él un perfil diferente al de firefox-1.5.x (en otro post puse como crear un perfil nuevo y asociar cada perfil a la respectiva versión del firefox (el swiftfox es un firefox adaptado a linux y tipo de procesador)

hela
12-nov-2006, 13:33
en mi caso sería para la 10.1, me lo bajo de ahí?

Rekeb
12-nov-2006, 15:14
Si tienes la 10.1, mejor bajalos de aqui

ftp://ftp4.gwdg.de/pub/linux/suse/apt/SuSE/10.1-i386

Salu2

tomeu
12-nov-2006, 19:14
En la v 10.1 añadir fuentes de instalación al Yast sigue siendo un coñazo, mejor usa Smart

head777
19-nov-2006, 07:23
hola que tal mis amigos espero me puedan ayudar con mi problema aunque la verdad esta bastante raro mi problema:

bueno el primero es que yo tengo instalado la version 1.7 de firefox, pero cuando lo quiero ejecutar me da este error:
usr/bin/mozilla: line 259: 4912 violacion de segmento $MOZ_PROGRAM $MOZ_LANG

bueno ese es el primero de varios el segundo es que cuando digito mozilla desde la terminal del root ahi si me abre el bendito mozilla otro problema que tengo es este:

me baje la version de 2 de firefox y cuando le digito:

linux-6wsd:/home/Dahbura/Desktop/fire # rpm -Uvih MozillaFirefox-2.0-37.1.i586.rpm
Preparing... ########################################### [100%]
1:MozillaFirefox ########################################### [100%]
error: unpacking of archive failed on file /usr/bin/firefox: cpio: rename failed - Is a directory

me da este problema y creanme que ya lo intente todo pero nada de nada no puedo instalar el bendito firefox 2 y con respecto de lo del firefox 1.7 si sabe por que da eso favor me avisa desde ya me encuentro muy agradecido.........................bye

tomeu
19-nov-2006, 10:49
No sé cuál es tu problema, pero de lo que expones se ven varios fallos e incongruencias, los revisas y luego aclaras, a saber:

1.- La versión del Firefox 1.7 no existe; pensé que podrías referirte a la 1.5.0.7, pero como hablas del /usr/bin/mozilla y no /usr/bin/firefox Aaaaa..migo, ¡tu estás usando mozilla suite!!

Si en lugar de digitar mozilla en un terminal escribes firefox o MozillaFirefox ¿qué pasa?

Con todo, parece que hay un problema de "locales" (idioma) entre el programa y el perfil. Además, lo intentas abrir como root :wacala:

2.- Nos aclara que tienes formado un buen lío con la instalación previa de firefox (/usr/bin/firefox). ¿no habrás desinstalado el firefox (no mozilla) precompilado para suse previamente?

Prueba de instalarlo, ya el 1.5.x ya el 2.0 (pon el repo que se comenta en el este post) con Smart.

head777
20-nov-2006, 01:45
hola que tal tomeu..........pues mira la verdad que lo que he hecho despues de bajarme el mozillafirefox 1.5 en un rpm pero cuando lo instalo con el yast me da este error :

"Subprocess failed. Error: RPM failed: error: unpacking of archive failed on file /usr/bin/firefox: cpio: rename failed - Is a directory


---
error: unpacking of archive failed on file /usr/bin/firefox: cpio: rename failed - Is a directory

2006-11-19 17:40:50 MozillaFirefox-1.5.0.7-1.5.i586.rpm install failed
rpm output:
error: unpacking of archive failed on file /usr/bin/firefox: cpio: rename failed - Is a directory

2006-11-19 17:40:50 MozillaFirefox-1.5.0.7-1.5.i586.rpm install failed
rpm output:
error: unpacking of archive failed on file /usr/bin/firefox: cpio: rename failed - Is a directory" .............y la verdad es que este mismo problema me da si quiero instalar el firefox 2.0 la verdad si me pueden ayudar lo agradeceria y por la pregunta que me hacias de lo teclear firefox o mizillafirefox a mi me dice que no encuentra el comando..................bye

tomeu
20-nov-2006, 15:51
Instala Firefox con los repositorios, o incluso con YaST desde el mismo cd/dvd.