PDA

Ver la Versión Completa : Tengo problemas con firefox 2.0


juanxfelipe
29-oct-2006, 11:27
Hola a todos, es mi primer tema en el foro suse

Bueno al grano tengo suse 10.1 y me baje el firefox 2.0 de la página oficial de firefox, lo que hice fue descomprimir el tar.gz, u cambiar la carpeta /usr/lib/firefox, por el que descomprimí y luego cambié el enlace simbólico en usr/bin, buen hasta aquí todo biennnn.

El problema es el siguiente, yo tenía firefox 1.5 con todas las cosas qque me gustaban, la barra de google y algunas otras extensiones como la barra de música desde el firefox la barra de clima las descargaas en la misma barra, y cosas así, el problema ahora es que el nuevo firefox no me reconoce nada de esto, entonces probé desinstalarlas e instalarlas de nuevo, cuando lo hice, me decía que reiniciara el firefox para desinstalar las extensiones antiguas, así lo hice pero no las desisntaló, entonces ni las desinstala ni permite usarlas, y cuando pruebo a instalarlas de nuevo me dice que hay un error y no me deja instalar nisiquiera ina nueva que no tenía antes.

Alguien me pueede ayudar, yo creo que es por no instalar el firefox con rpms, por lo que puede haber algún tipo de incompatibilidades, pero necesito ayuda.


Graciassss


De dónde puedo bajar los rpm de firefox 2.0 para suse 10.1??????

kilops
29-oct-2006, 11:40
Sigue los pasos detallados que postea Tomeu:
http://www.forosuse.org/forosuse/showthread.php?t=8924

joarey
29-oct-2006, 21:10
Hola,

Yo tenía ese mismo problema, la versión que te bajas de la web no conseguía que actualizase bien, hasta que hice esto:

a) Añade un nuevo repositorio al yast, dentro de "Cambiar fuente de instalación". Los datos son:

protocolo: HTTP
nombre del servidor: software.opensuse.org
directorio: download/mozilla/SUSE_Linux_10.1/

b) Una vez tengas esto, vas a la opción "Instalar/Desinstalar Software" y buscas el paquete: mozilla. Cuando lo localice, verás que te aparece en azul (siempre que no hayas desinstalado la versión 1.5), esto quiere decirte que ha encontrado una versión posterior a la que tienes instalada. Sólo tienes que marcarlo y escoger la opción actualizar.

c) Cuando haya terminado, arrancas el firefox y te preguntará si deseas que se actualicen todos los complementos y temas que tienes instalado; aceptas y ya lo tendrás.

Espero que te sirva de ayuda. Un saludo.

juanxfelipe
30-oct-2006, 09:06
Oye muchas gracias, mediante tu informaciòn no tengo ahora problemas con mi firefox2.0

tomeu
30-oct-2006, 18:20
a) Añade un nuevo repositorio al yast, dentro de "Cambiar fuente de instalación". Los datos son:

protocolo: HTTP
nombre del servidor: software.opensuse.org
directorio: download/mozilla/SUSE_Linux_10.1/
Ojito con ese repositorio. Aunque los paquetes correspondientes a firefox-2.0 seguramente serán los definitivos que se pondrán (en breve) en la fuente "update" o "base", es un sitio de versiones experimentales o "nighties". Baste ver las versiones de Thunderbird y Seamonkey que hay ahí.

joseluisbz
18-ene-2007, 00:49
Cordial Saludo:

Resulta que estuve disque actualizando el Firefox, pero luego de un rato no me arranca.
Despuès de darle y darle... me meti al directorio que lo aloja...
y para arrancarlo me meto por Krusader en modo root

/usr/lib/firefox

y selecciono el archivo firefox.sh y le doy ejecutar...

Como lo puedo arreglar?
Para poder arrancarlo desde el escritorio?

joseluisbz
22-ene-2007, 20:58
Estuve buscando los rpm para ver si lo reinstalaba en:

http://software.opensuse.org/download/mozilla/SUSE_Linux_10.1/i586/
http://ftp4.gwdg.de/pub/linux/suse/opensuse/repositories/mozilla/SUSE_Linux_10.1/i586/


Estos son los archivos necesarios:

flash-player-9.0.31.0-2.1.i586.rpm
MozillaFirefox-2.0.0.1-18.2.i586.rpm
MozillaFirefox-translations-2.0.0.1-18.2.i586.rpm

mozilla-nspr-4.6.5-2.1.i586.rpm
mozilla-nspr-devel-4.6.5-2.1.i586.rpm

mozilla-nss-3.11.5-3.1.i586.rpm
mozilla-nss-devel-3.11.5-3.1.i586.rpm


Ahora a instalarlos

linux-bz01:/home/Compartido # rpm -Uvh mozilla-nspr-4.6.5-2.1.i586.rpm mozilla-nspr-devel-4.6.5-2.1.i586.rpm
Preparing... ########################################### [100%]
1:mozilla-nspr ########################################### [ 50%]
2:mozilla-nspr-devel ########################################### [100%]
linux-bz01:/home/Compartido # rpm -iUvh mozilla-nss-3.11.5-3.1.i586.rpm
Preparing... ########################################### [100%]
1:mozilla-nss ########################################### [100%]
linux-bz01:/home/Compartido # rpm -Uvh mozilla-nss-devel-3.11.5-3.1.i586.rpm
Preparing... ########################################### [100%]
1:mozilla-nss-devel ########################################### [100%]

linux-bz01:/home/Compartido # rpm -Uvh MozillaFirefox-2.0.0.1-18.2.i586.rpm MozillaFirefox-debuginfo-2.0.0.1-18.2.i586.rpm MozillaFirefox-translations-2.0.0.1-18.2.i586.rpm
Preparing... ########################################### [100%]
1:MozillaFirefox ########################################### [ 33%]
2:MozillaFirefox-debuginf########################################## # [ 67%]
3:MozillaFirefox-translat########################################## # [100%]
linux-bz01:/home/Compartido #


No es necesario el archivo MozillaFirefox-debuginfo-2.0.0.1-18.2.i586.rpm y mejor porque es muy pesado.

Si necesita instalarle Java (Previamente instalado) a Firefox, podría hacerse así:
ln -s /usr/local/jre/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/firefox/plugins/libjavaplugin_oji.so

Donde /usr/local/jre/plugin/i386/ns7/libjavaplugin_oji.so es donde està la librería o componente real y /usr/lib/firefox/plugins/libjavaplugin_oji.so a donde debe quedar enlazado...

Darth_Vader02
15-may-2007, 00:55
HOLA tengo un problema con el firefox para el suse 10.2 la version que trae por default es la 2.0.

Al momento de ingresar a una pagina de internet o al hacer click a un hipervinculo se queda en la pagina anterior y en la barra del progreso me aparece terminado... en fin tengo que darle hasta 5 veces "actualizar" para que me muestre la pagina a la que quiero ingresar. Otras ocasiones inicio firefox y se cuelga :negar: no lo abre hasta que aparece un mensaje que indica que no responde y que hay que cerrarlo a la de :tstress: y reiniciar mi equipo.

Bueno esos son los padecimientos pelea: espero que alguien me pueda ayudar por que la verdad no se que hacer... (ya que lo he instalado y desinstalado mas de una vez) Saludos

DiabloRojo
15-may-2007, 09:26
Hazlo por consola y postea los errores o buscalos en Internet.

tomeu
15-may-2007, 11:12
* Puedes encontrar en el foro cómo añadir el repo mozilla al YaST o Smart y actualizar firefox a la versión actual 2.0.0.3

* Puedes probar si se repite el fallo lanzando firefox en modo segurofirefox -SafeMode
* También puedes probar quitando (con YaST o Smart) el plugin 'beagle' asociado a firefox, que con la versión de la distro se instala y sirve para más bien poco o nada.

* Si es un problema de perfil, puedes probar con un perfil nuevo firefox -ProfileManager
* Parece que con lo de reiniciar lo que haces es matar el proceso 'firefox' a las bravas. Puedes matar ese proceso sin necesidad de reiniciar con Ctr+Esc y desde la ventana de procesos que sale, o con Ctr+Esc+F1 y cuando el icono se convierte en calavera pirata clic con ella encima de la ventana del programa a matar.

* Dinos si las páginas que dan fallo usan flash o java; si no tienes los plugins que se queden bloqueadas es normal. Si tu arquitectura es de 64 bits y el firefox instalado es también el de 64 bits, encuentra en el foro cómo instalar plugins de 32 bits en firefox de 64 bits o planteate usar SwiftFox (http://www.getswiftfox.com/)

camelo
06-jun-2007, 04:57
HOLA tengo un problema con el firefox para el suse 10.2 la version que trae por default es la 2.0.

Al momento de ingresar a una pagina de internet o al hacer click a un hipervinculo se queda en la pagina anterior y en la barra del progreso me aparece terminado... en fin tengo que darle hasta 5 veces "actualizar" para que me muestre la pagina a la que quiero ingresar. Otras ocasiones inicio firefox y se cuelga :negar: no lo abre hasta que aparece un mensaje que indica que no responde y que hay que cerrarlo a la de :tstress: y reiniciar mi equipo.

Bueno esos son los padecimientos pelea: espero que alguien me pueda ayudar por que la verdad no se que hacer... (ya que lo he instalado y desinstalado mas de una vez) Saludos

Yo tambien tengo el mismo problema ahora utilizo el firefox 2.0.0.4 y suse 10.2 por eso subire este post, ahora mismo el firefox ya no me arranca me pegaba unos pantallazos terribles y en esta ultima direccion ha caido del todo ya no arranca con esta ultima direccion se queda bloqueado no da opciones de abrir pestañas o empezar de cero lo hacia segun donde te metias cuando caia esta ultima era un direccion del japon :) .

Empezare a hacer todo lo que habeis dicho puede ser que la haya cogido de un repositorio de betas o tester, haber si consigo un firefox estable.

Tambien he instalado y desinstalado el firefox.

Güeno pues aqui teneis el primer comando de consola y su respuesta:

Firefox -SafeMode

firefox -safemode
file: could not find any magic files!
/usr/bin/firefox: line 208: 17915 Violación de segmento $MOZ_PROGRAM "$@"


salu2

camelo
06-jun-2007, 19:32
Al final entre como root y desinstale el kerry ese del beagle el "perrito vamos" que me parece que indexa las paginas web solo el kerry por eso y ahora me va todo bien, va pa Tomeu, gracias

ejem, ejem se me ha vuelto a colgar el firefox al mandar este mensaje pelea:

salu2

camelo
10-jun-2007, 05:06
He echo de todo para intentar solucionar este problema de la desconexion mientras navego de Firefox, desde quitar todos los complementos que tenia puestos (menos mal que guarde la carpeta: ".Mozilla" del home de usuario), hasta desinstalar e instalar de nuevo el firefox,y seguia el mismo problema con los pantallazos de desconexion fulminante.

Pues todos estos problemas eran porque por defecto el firefox en el apartado preferencias dentro de la ventana de "contenido" viene marcada la opcion "ACTIVAR JAVASCRIPT" ya sabemos que por seguridad hay que tenerla desmarcada ( je, je ahora me hago el listo :( ) no me he tirado horas haciendo de todo menos lo que tenia que hacer que era desmarcar esa casilla y de esa forma evitar que se ejecuten comandos automaticamente en el navegador.

Aun asi os podeis encontrar webs que os dupliquen las ventanas y no podais acceder a su contenido al no tener marcado "activar javascript" para solucionarlo nos vamos a la pestaña avanzado del submenu y deseleccionamos " Desactivar o reemplazar menus contextuales " solucionando igualmente el problema de los pantallazos de Firefox pero siendo mas vulnerable nuestra navegacion por la web.

Uno de los sitios donde saltaba siempre el firefox era nada mas y nada menos que cuando te conectas a Gmail.

Ha sido duro...........................

salu2