PDA

Ver la Versión Completa : como es de compatible los 64 con los 32 bits?


arlick
16-oct-2006, 20:39
hola he tenido problemas a la hora de intentar instalarme un par juegos en linux, desde su version nativa. Estos juegos son el quake 3 y el savage para linux.

El error que me dan es de incompatibilidad con el paquete glibc-2.1 de la arquitectura para 64. Anque supongo que es una burrada intente borrar dicho paquete y substituirlo por la version de 32 pero cuando lo seleccion para borrar el yast me anucio que eso podria desencadenar en una instabilidad en el sistema o algo asi.

que puedo hacer ante esto para poder correr estos programas? tambien he tenido problemas al intentar usar practicas de la universidad en mi maquina, el mismo tipo de incompatiblidad. Se puede emular un sistema de 32 bits para estos casos?

Muchas gracias.

tomeu
16-oct-2006, 20:51
Si en lugar de intentar 1º borrar el paquete glibc-x86_64, intentas instalar el glibc-i586:
a) Yast no pone pegas, y deja tener instalados ambos (como en otros casos).
b) Yast te resuelve las dependencias, de modo que borra el de 64b. e instala el de 32b, y en su caso atláteres y dependientes.
c) Yast sigue diciéndote que va a quedar un sistema sin dependencias resueltas e inestable.