PDA

Ver la Versión Completa : Problema al instalar con rpm


0zzy0sbourne
13-oct-2006, 20:45
Hola chicos de un tiempo a esta parte cada vez que quiero instalar algo con rpm siempre me sale esto:
libc.so.6 is needed by apt-0.5.15cnc7-24.i586
libc.so.6(GLIBC_2.0) is needed by apt-0.5.15cnc7-24.i586
libc.so.6(GLIBC_2.1) is needed by apt-0.5.15cnc7-24.i586
libc.so.6(GLIBC_2.1.3) is needed by apt-0.5.15cnc7-24.i586
libc.so.6(GLIBC_2.2) is needed by apt-0.5.15cnc7-24.i586
libc.so.6(GLIBC_2.3.4) is needed by apt-0.5.15cnc7-24.i586
libdl.so.2 is needed by apt-0.5.15cnc7-24.i586
libm.so.6 is needed by apt-0.5.15cnc7-24.i586
libpthread.so.0 is needed by apt-0.5.15cnc7-24.i586
libpthread.so.0(GLIBC_2.0) is needed by apt-0.5.15cnc7-24.i586
librt.so.1 is needed by apt-0.5.15cnc7-24.i586
libc.so.6 is needed by apt-libs-0.5.15cnc7-24.i586
libc.so.6(GLIBC_2.0) is needed by apt-libs-0.5.15cnc7-24.i586
libc.so.6(GLIBC_2.1) is needed by apt-libs-0.5.15cnc7-24.i586
libc.so.6(GLIBC_2.1.3) is needed by apt-libs-0.5.15cnc7-24.i586
libc.so.6(GLIBC_2.3) is needed by apt-libs-0.5.15cnc7-24.i586
libc.so.6(GLIBC_2.3.4) is needed by apt-libs-0.5.15cnc7-24.i586
libdl.so.2 is needed by apt-libs-0.5.15cnc7-24.i586
libdl.so.2(GLIBC_2.0) is needed by apt-libs-0.5.15cnc7-24.i586
libdl.so.2(GLIBC_2.1) is needed by apt-libs-0.5.15cnc7-24.i586
libm.so.6 is needed by apt-libs-0.5.15cnc7-24.i586
libm.so.6(GLIBC_2.0) is needed by apt-libs-0.5.15cnc7-24.i586

Este es un ejemplo cuando intento instalar el apt, pero me ocurre con todo.
y lo cierto es que creo que si tengo instaladas todas estas librerias, me podriais echar
una mano?

graciñas

RedDwarf
13-oct-2006, 21:10
Si no tuvieses esas librerías Suse ni arrancaría.
Algo muy malo le ha pasado a tu base de datos de RPMs. Prueba con http://en.opensuse.org/SDB:RPM_database_corrupted y si no creo que tendrás que reinstalar Suse.