PDA

Ver la Versión Completa : SMB-Client no puede entrar en Win XP


FelixThot
25-sep-2006, 12:41
Hola a todos!!
Despues de poder arrancar SUSE correctamente (se me colgaba la maquina), por supuesto con la ayuda de la Comunidad!!!, me ha surgido un problema con Samba :mad:
El problema es el siguiente:
Desde Win XP puedo ver la red y acceder a mi maquina SUSE y compartir archivos, NINGÜN PROBLEMA! Pero cuando quiero acceder desde SUSE a Win Xp, puedo ver el grupo de trabajo, en este caso denominado "Linux-red", pero cuando quiero acceder me sale un cartel que dice:
"Tiempo Agotado en el Servidor" :tstress:
Debo aclarar (por si tiene algo que ver) que en Win XP esta corriendo el Firewall de ZoneAlarm (en éste configuré en la Zona protegida, la maquina con SUSE poniendo la IP de la misma). Resultado : NADA!!!!!!!!!!!!
Que puede estar pasando??

Por otra parte quisiera preguntarles como puedo instalar LinNeighborhood-0.6.4.tar.gz ( sé que sirve para navegar y acceder en la LAN interna. Me lo bajé pero no sé como instalarlo).

Desde ya les agradezco infinitamente que puedan ayudarme!!!!!!!!!!!!!!!!!! :)

kilops
25-sep-2006, 12:47
Te lo ha hecho siempre lo de acceder a win?tienes la ip del pc de win en /etc/samba/lmhosts?

sobre el paquete,tendria que haber un readme dentro que explica los pasos para instalar.saludos

FelixThot
25-sep-2006, 22:26
Gracias Kilops por responder!!!!!!!!!!

Te cuento que siempre me lo ha hecho, nunca pude ingresar a la maquina Win. Me fijé en /etc/samba/lmhosts y la unica IP que figura es 127.0.0.1 localhost. No tengo idea de como editar esto y agregar la IP del Win XP.
Con respecto al paquete de LinNeighborhoos he "leido" el README y la verdad para ser totalmente sincero NO ME ENTERË DE NADA!!! Asumo mí ignorancia en inglés!
Si alguien me puede especificar los parametros que tengo que poner para instalarlo se lo agradezco de corazón!!!
Como siempre les agradezco toda ayuda que me puedan dar!!

kilops
25-sep-2006, 22:40
Gracias Kilops por responder!!!!!!!!!!

Te cuento que siempre me lo ha hecho, nunca pude ingresar a la maquina Win. Me fijé en /etc/samba/lmhosts y la unica IP que figura es 127.0.0.1 localhost. No tengo idea de como editar esto y agregar la IP del Win XP.
Con respecto al paquete de LinNeighborhoos he "leido" el README y la verdad para ser totalmente sincero NO ME ENTERË DE NADA!!! Asumo mí ignorancia en inglés!
Si alguien me puede especificar los parametros que tengo que poner para instalarlo se lo agradezco de corazón!!!
Como siempre les agradezco toda ayuda que me puedan dar!!
añade debajo de "127.0.0.1 localhost." la ip del pc que tengas en win y el nombre del pc separado por el tabulador entre uno y otro.

sobre lo del paquete seguramente tendras un "install" que te dara las instrucciones con los comandos por ejemplo:
1- ./configure
2- make
y por ultimo make install

repasate-lo. :adios:

FelixThot
25-sep-2006, 23:11
Kilops Gracias por tu paciencia!!

He puesto la IP de Win seguido del "Localhost" y ........... NADA! me sigue saliendo el mismo cartel "Tiempo de espera agotado en el Servidor"

Con respecto al paquete, me fije en el archivo INSTALL lo abrí y sale esto (te pongo una parte NO todo porque es muy largo:

Basic Installation
==================

These are generic installation instructions.


Special Packages needed to compile and install
==============================================

*) GNU gettext
*) Gimp Toolkit GTK+ (1.2.0 or higher)
*) GNU autoconf + automake


Files being installed
=====================

The following files will be installed using 'make install'
to the following directories by default:


'LinNeighborhood' [executable]
--bindir ("/usr/local/bin/")

localization files '*.mo' [language files]
--datadir/locale/... ("/usr/local/share/locale/...")

'LinNeighborhood.xpm' [icon]
--datadir/icons/ ("/usr/local/share/icons/")


Perdón, pero no tengo ni idea de lo que hay que hacer!
Si me hechas una mano vos que sabés más te lo SUPER AGRADECERÏA!!!!!!!!!!!!!!!!!!!

kilops
25-sep-2006, 23:23
detras de localhost no,debajo."Añade una linea nueva."
luega reinicia samba para que los canvios tengan efecto con:
/etc/init.d/smb restart

Con lo que has puesto no hacemos nada.

FelixThot
26-sep-2006, 22:35
Kilops!! (que paciencia infinita tenés GRACIAS!!)
Te cuento que hice esto (y te muestro):

# This file provides the same function that the lmhosts file does for
# Windows. It's another way to map netbios names to ip addresses.
#
# See section 'name resolve order' in the manual page of smb.conf for
# more information.

127.0.0.1 localhost
192.168.1.2 Hermes

Escriba :quit<enter> para terminar la ejecución de Vim. 8,18-22 Todo

Luego hice esto:

ISISLINUX:/home/userisis # /etc/init.d/smb restart
Shutting down Samba SMB daemon done
Starting Samba SMB daemon done
ISISLINUX:/home/userisis #


Resultado: NADA!! :confused:
Que puede ser?, me sigue saliendo: "Tiempo de espera agotado en el Servidor"

Creo que tengo SAMBA bien configurado ya que de WIN XP puedo ingresar a mí maq. SUSE sin problemas!

Culaquier idea que se te ocurra ( o a cualquiera que lea esto ) bienvenida sea! Si tengo que estar un año intentando lo HAGO! ya que mi idea es que si logro configurar bien SUSE , en la otra maquina que tengo WIN XP lo saco y pongo SUSE!

Desde ya a todos MUCHAS GRACIAS!!!!!!!!!!!!!!

kilops
26-sep-2006, 22:59
yo lo tengo como te digo y me funciona perfectamente,solo que uso smb4k como explorador de redes,es muy util,puedes probar-lo.Postea tu /etc/samba/smb.conf.

FelixThot
26-sep-2006, 23:16
Acá te mando mi smb.conf:

# Samba config file created using SWAT
# from 127.0.0.1 (127.0.0.1)
# Date: 2006/09/24 17:57:54

[global]
workgroup = LINUX-RED
netbios name = USERISIS
interfaces = eth0, eth1
map to guest = Bad User
server signing = Auto
printcap name = cups
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
logon path = \\%L\profiles\.msprofile
logon drive = P:
logon home = \\%L\%U\.9xprofile
domain master = No
ldap ssl = No
usershare allow guests = Yes
guest ok = yes
hosts allow = 192.168.1.2/255.255.255.0
cups options = raw
include = /etc/samba/dhcp.conf
winbind gid = 10000-20000
winbind uid = 10000-20000
usershare max shares = 100
restrict anonymous = no
max protocol = NT
domain logons = No
idmap gid = 10000-20000
idmap uid = 10000-20000
security = user

[homes]
comment = Home Directories
valid users = %S, %D%w%S
read only = No
inherit acls = Yes
browseable = No

[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/

[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

[printers]
comment = All Printers
path = /var/tmp
create mask = 0600
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin, root
force group = ntadmin
create mask = 0664
directory mask = 0775

[documents]
comment = /home/userisis/Documents
path = /home/userisis/Documents/
read only = no
wide links = no
case sensitive = no
msdfs proxy = no


[is_documents]
path = /home/userisis/Documents
comment = /home/userisis/Documents
wide links = no

[compartir]
path = /home/userisis/Compartir/
comment = /home/userisis/Compartir
wide links = no
case sensitive = no
msdfs proxy = no
read only = no


A ver si ves una cagada que hice y yo no la veo?? (en realidad me costó un huevo y la mitad del otro configurarlo por lo menos para que desde Win Xp pudiera entrar a SUSE!!!).

Hasta el cansancio: GRACIAS; GRACIAS ; GRACIAS!!!!!!!!!!!!!!!!

Kunael
27-sep-2006, 10:03
Empieza por aquí:
http://us2.samba.org/samba/docs/using_samba/ch12.html

Y acaba con este, que está especialmente bien escrito y es muy muy ordenadito en los pasos a seguir (aunque es viejo):
http://us2.samba.org/samba/docs/Samba24Hc13.pdf

FelixThot
28-sep-2006, 22:21
Gracias KUNAEL por los enlaces!!!
Estoy tratando de descifrarlos porque están en ingles y la verdad que mís conocimientos de la lengua son bastante básicos, pero sé que con un pequeño esfuerzo lo LOGRARÉ!!!!!!!

Cuando tenga novedades les aviso OK?!!
Lo bueno de todo esto es que no solo se aprende un nuevo sistema operativo sino también una lengua!!!.
Otra cosa que esta posponiendo mís avances es que mí maquina Win Xp le entró un virus y está jodida, así que le tengo que dedicar un poco de tiempo a la misma!. No veo la hora de aprender bien Linux y dejar para siempre Winfuks!!!!