PDA

Ver la Versión Completa : Actualizar glibc


jjgracia
20-sep-2006, 17:30
Pretendo instalar glibc-2.4-40.i586.rpm y me suelta:

# rpm -Uvh glibc-2.4-40.i586.rpm
error: Failed dependencies:
glibc = 2.3.5 is needed by (installed) glibc-devel-2.3.5-40
glibc = 2.3.5 is needed by (installed) glibc-locale-2.3.5-40

Según el yast tengo instalado glibc 2.3.5-40 y también glibc-devel-2.3.5-40 y glibc-locale-2.3.5-40. No instalo glibc 2.4-40 desde yast porque no lo he sacado de ningún repositorios sino googleando. No entiendo que pasa. :chillando Alguna ayuda?

Gracias.

DiabloRojo
20-sep-2006, 19:52
Desinstala glibc2.3.5

jjgracia
20-sep-2006, 23:31
Ya lo hice, pero luego no me arrancaba el sistema y tuve que restaurarlo con el DVD, glibc es un paquete esencial. ¿alguna otra idea? :confused:

DiabloRojo
21-sep-2006, 19:04
Forzar la instalacion con la opcion --force o --replacepkgs.

tomeu
22-sep-2006, 01:10
Vamos a ver, fíjate cuales son las fallas de dependencias que te dice: Que no puedes tener instalada la versión 2.4 y mantener los paquetes -devel y -locale de la versión 2.3.5.

Creo que lo más limpio sería que desde el mismo sitio desde el que te bajaste el paquete glibc2.4 te bajases también los rpms -devel2.4 y locale2.4, los pones en una misma carpeta o directorio (solo ellos) y rpm -Uvih *.rpm

Si no los encuentras, en vez de desinstalar glibc2.3.5, puedes probar desinstalando solo los -devel (no siempre los paquetes "devel" -desarrollo-son necesarios) y el locale (idioma), y entonces actualiza como hiciste al principio.