PDA

Ver la Versión Completa : problemas con los RPM


ShotoKAN_
18-sep-2006, 15:02
hola, soy novatin en linux; migre totalmente a suse 9.3, ya que era la version que tenia descargada.

Andaba instalando muchos paquetes y funcionaba bien... sin embargo, de repente ya todos los que queria instalar me sacaban errores
ERROR(InstTarget:E_RpmDB_subprocess_failed)
---
error: db4 error(-30978) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30978) from dbenv->close: DB_RUNRECOVERY: Fatal error, run database recovery

la verdad no se que es este error.

De antemano, gracias por la ayuda.

RedDwarf
18-sep-2006, 15:15
http://www.rpm.org/hintskinks/repairdb/

ShotoKAN_
19-sep-2006, 05:28
Muchas gracias por la pagina. Lo malo es que mi ingles es bastante malo y me toca traducir... por eso te agradeceria si pudieras decirme en cuall parte de la pag. dice lo de mi error, ya que me parece que muestran la manera de arreglar diferentes errores.

Sin embargo seguire viendo con mi diccionario googlero; pero en verdad me ayudarian mucho si me dicen.

DiabloRojo
19-sep-2006, 21:53
Como superusuario root, ejecuta: rpm --rebuilddb o rpm --initdbl

ShotoKAN_
20-sep-2006, 03:45
muchas gracias, si me funciono.