PDA

Ver la Versión Completa : Deshabilitar peticion contraseña root al montar discos



MicroHome
16-mar-2013, 19:04
Buenas Tardes a todos, necesitaría que me echarais una mano si pudierais para eliminar
la petición del password de root a la hora de montar un disco o partición en mi sistema.

En su momento ya lo hize pero actualmente he reinstalado con OpenSuse 12.3 y no soy capaz de encontrar la política de sistema que regula esta opción.

Hasta ahora he estado modificando algunas politicas de sistema desde

Preferencias de Sistema>Administrador de Sistema>Políticas de Acciones

y dentro de esta seleccionando las sub-entradas

org.freedesktop>The udisk project

Una vez aqui he ido modificando las que hacían referencia al montaje de discos y particiones, modificando los parametros Any y Active Console, sustituyendo Administrator authentification por el valor Si en ambas entradas, pero soy incapaz de solucionarlo y necesitaría si pudierais que me echarais una mano porque ya no se ni por donde seguir.

Saludos!!

Tripanarium
16-mar-2013, 19:45
Porque no lo haces con yast?
Yast -> Particionador
Seleccionas la partición y la montas.

MicroHome
16-mar-2013, 21:24
Porque solo me interesa que no me pida la contraseña, ya que si conecto otro disco duro para salvar informacion de el me volvera a pedir la contraseña de root, de todos modos gracias por la idea. :)

sieg84
16-mar-2013, 21:27
modifica:

/var/lib/polkit-1/localauthority/10-vendor.d/org.freedesktop.udisks.filesystem-mount-system-internal.pkla

This is the original contents:

[org.freedesktop.udisks.filesystem-mount-system-internal] Identity=unix-group:* Action=org.freedesktop.udisks.filesystem-mount-system-internal ResultAny=auth_admin ResultInactive=auth_admin ResultActive=auth_admin_keep Updated:

[org.freedesktop.udisks.filesystem-mount-system-internal] Identity=unix-group:* Action=org.freedesktop.udisks.filesystem-mount-system-internal ResultAny=auth_admin ResultInactive=auth_admin ResultActive=yes


http://forums.opensuse.org/english/get-technical-help-here/applications/457235-udisks-kde4-6-1-suse-11-4-authorization-required-issue.html

mikrios
17-mar-2013, 00:08
Hola lee esto a lo mejor te interesa :
http://www.forosuse.org/forosuse/showthread.php?t=29534

Saludos cordiales

sieg84
17-mar-2013, 00:26
Hola lee esto a lo mejor te interesa :
http://www.forosuse.org/forosuse/showthread.php?t=29534

Saludos cordiales

intenta con la solución que puse en el mensaje #4, así no tendrás necesidad de cambiar el propietario y hace lo que pide el autor de este tema, ya sea discos ntfs, ext3/4, btrfs, etc.

el cambio es inmediato, no hay necesidad de reiniciar.

mikrios
17-mar-2013, 01:00
Ok.
Cuando lo hago no necesito reiniciar , pero la solución que puse es la de un novato , a mi me funciona , por comando la verdad se muy poca cosa .
Siempre intento hacerlo lo mas fácil posible ,cuando adquiera mas experiencia intentare hacerlo como tu dices que va directo al grano y a tu manera me ahorro varios pasos .
Gracias Sieg84.
Saludos cordiales a todos .

MicroHome
17-mar-2013, 02:31
Hola lee esto a lo mejor te interesa :
http://www.forosuse.org/forosuse/showthread.php?t=29534

Saludos cordiales

Gracias por la ayuda mikirios, pero opino igual que Sieg84 y prefiero no modificar el propietario ni permisos...

Sieg84 muchisimas gracias, lo he resuelto modificando el fichero que me has indicado, pero antes he tenido que instalar el paquete polkit-default-privs-12.3-5.1.noarch.rpm ya que al introducirme en la carpeta para editar el fichero que gestiona la politica de sistema la carpeta estaba vacia y hasta que no he instalado ese paquete no me ha aparecido ninguno de los ficheros para editar las politicas.

La página desde la que he descargado el paquete por si alguno lo necesitara a sido:
http://rpm.pbone.net/index.php3/stat/4/idpl/19441205/dir/opensuse/com/polkit-default-privs-12.3-5.1.noarch.rpm.html

Edito: Rectifico, la solución no funciona he mirado bastante por google y parece que hay un fallo generalizado con esta politica bajo suse.

Un Saludo!!

mikrios
18-mar-2013, 11:50
Hola :
Perdón estaba equivocado como nunca apago la Pc no me pedía el Password ,para montarlo si me pide contraseña , para lo demás no .

De todas formas el que estoy usando es de quitar y poner en caliente ,creo que tiene que haber otra solución , estoy probando en preferencias del sistema , en dispositivos extraibles y marco y selecciono los nombre de los distintos discos que conecto en ese puerto sata dock station de la caja del Pc .
Y en la bios esta seleccionado para quitar y poner en caliente ,creo que en suse vi algo en alguna configuración que hablaba de ello ; pero no me acuerdo donde .

De todos modos muchas gracias y perdonar la equivocación .

Saludos cordiales

karlggest
19-mar-2013, 02:26
Gracias por la ayuda mikirios, pero opino igual que Sieg84 y prefiero no modificar el propietario ni permisos...

Sieg84 muchisimas gracias, lo he resuelto modificando el fichero que me has indicado, pero antes he tenido que instalar el paquete polkit-default-privs-12.3-5.1.noarch.rpm ya que al introducirme en la carpeta para editar el fichero que gestiona la politica de sistema la carpeta estaba vacia y hasta que no he instalado ese paquete no me ha aparecido ninguno de los ficheros para editar las politicas.

La página desde la que he descargado el paquete por si alguno lo necesitara a sido:
http://rpm.pbone.net/index.php3/stat/4/idpl/19441205/dir/opensuse/com/polkit-default-privs-12.3-5.1.noarch.rpm.html

Edito: Rectifico, la solución no funciona he mirado bastante por google y parece que hay un fallo generalizado con esta politica bajo suse.

Un Saludo!!

Sí que os complicáis algunos xdd

http://software.opensuse.org/package/polkit-default-privs

Salud!!

MicroHome
20-mar-2013, 12:01
Sí que os complicáis algunos xdd

http://software.opensuse.org/package/polkit-default-privs

Salud!!

Hola karlgest en el post #8 comente que ya lo habia instalado pero sigo sin resultado alguno. De todos modos creo que la versión 12.3 tiene que estar mas cerrada de lo normal
ya que instalando los drivers nativos de nvidia aunque están instalados hay cosas que no
me terminan de cuadrar como que para configurar los 2 monitores que tengo opensuse le
haga mas caso a la configuracion realizada desde Preferencias del Sistema> Pantalla que
desde la configuración que se pueda realizar desde el panel Nvidia. Haber si en esta semana tengo un rato y virtualizo una 12.2 para ver si hace lo mismo.

Saludos!!

mikrios
21-mar-2013, 05:27
Hola a todos :
Gracias Karlggest por la información (de un orensano a otro ) :

otro buen tutorial :

http://yourmediafiles.net/content/VMFQ4iB0AOdwBbchsrtP/SuSE-Linux-Adminguide-9.0.0.0x86.pdf.html

En este tema en lo que me toca a mi es que el disco se comporte como si fuese un pendrive usb ,es un sata que se conecta en caliente y lo mismo también se desconecta en caliente ,no hay que expulsarlo si no que lo quitas y lo pones y el solo aparece visible en "mi equipo" y cuando lo quitas desaparece .

El tema es quitarle el pass cada vez que quieras acceder a el .
Se que en algún lado he visto algo por el estilo cuando lo encuentre lo pongo en el post.

Ahí dejo un buen tuto para que la gente se entretenga ,ya mas tarde me lo estudiare y haber si encuentro otras soluciones.

También me gustaría proponer algo sobre los discos ssd y en redes sobre IPV6 pero este no es el sitio adecuado ,aunque en la dirección de Ipv6 ya viene implementado la seguridad y otras muchas opciones .(pero no es tema para tratarlo aquí así que lo dejare para mas adelante cuando instale el DSL-N55U de Asus).

Saludos cordiales a todos

yomismo
08-ene-2016, 01:00
Utilizo este hilo porque es mas o menos lo que me pasa a mí, aunque este es muy antiguo espero que alguien lo lea y me ayude con la solución.
Tengo dos discos duros instalados: uno ssd donde está el sistema operativo opensuse 13.2 y otro sata donde almaceno mis documentos. Mi problema es que cada vez que intento abrir el disco duro sata me pide contraseña para montarlo y el segundo es que cuando descargo cualquier cosa de internet y elijo el disco sata para las descargas no me las guarda porque, supongo, no está montado. Se podría hacer algo para que el disco donde tengo todos mis documentos estuviera montado siempre y pudiera acceder a él sin poner contraseña?
Saludos.

gvcastellon
08-ene-2016, 01:44
Utilizo este hilo porque es mas o menos lo que me pasa a mí, aunque este es muy antiguo espero que alguien lo lea y me ayude con la solución.
Tengo dos discos duros instalados: uno ssd donde está el sistema operativo opensuse 13.2 y otro sata donde almaceno mis documentos. Mi problema es que cada vez que intento abrir el disco duro sata me pide contraseña para montarlo y el segundo es que cuando descargo cualquier cosa de internet y elijo el disco sata para las descargas no me las guarda porque, supongo, no está montado. Se podría hacer algo para que el disco donde tengo todos mis documentos estuviera montado siempre y pudiera acceder a él sin poner contraseña?
Saludos.

Tu problema es de permisos en el punto de montaje que tienes asignado al disco sata, por eso te pide el password cada vez que intentas montarlo y si no estas en condición de root. no te va a dejar crear/copiar ni nada parecido. Varios temas aquí en el Foro hablan de eso, por lo pronto y si no estas practico con la linea de comandos, puedes entrar a Dolphin como super usuario buscas el punto de montaje asignado al sata, click derecho propiedades vas a donde están los permisos y los cambias.

Te dejo uno de los tantos temas en que se habla al respecto aqui en el Foro.
http://www.forosuse.org/forosuse/showthread.php?t=32546&highlight=segundo+disco

PD: casi seguro te van a rastrillar por reflotar temas viejos, a mi me a pasado, mejor empieza uno nuevo, ....es solo un consejo.

Saludos.

soyasi
08-ene-2016, 02:18
Para solucionar tu problema sigue el ultimo post de este hilo (https://forums.opensuse.org/showthread.php/484311-org-freedesktop-udisks2-filesystem-mount-system-not-working-in-openSUSE-12-3-KDE)


para mas información mírate esto (http://udisks.freedesktop.org/docs/1.96.0/udisks-polkit-actions.html)

Básicamente es:

añadir la linea
org.freedesktop.udisks2.filesystem-mount-system auth_admin:auth_admin:yes al archivo

/etc/polkit-default-privs.local

y en consola teclear como root:
set_polkit_default_privs

si sigues leyendo el hilo comprobaras que el cambio en el archivo que te indica Sieg84, no se puede hacer, ya que no existe a partir de las versiones 12.X

No he podido comprobarlo ya que no tengo ninguna 12.3 instalada.

Saludos :adios:

DiabloRojo
08-ene-2016, 10:36
yomismo, lo que te dice gvcastellon tiene razón. Mejor habría sido abrir un tema nuevo que reflotar uno viejo porque openSUSe cambia en las versiones.

Tenlo en cuenta en lo sucesivo.

Otra cosa, si no consigues solucionarlo con la chuleta de sieg84 y soyasi, aporta información de como están tus particiones y donde has instalado openSUSE. comandos a reportar su salida, copia y pega y acotarlo con la etiqueta CODE de esta Lista de Códigos BB (http://www.forosuse.org/forosuse/misc.php?do=bbcode#code)
fdisk -l
cat /etc/fstab

Demente
04-feb-2016, 19:48
Buen día, acabo de instalarme openSuse Leap 41.2 y tengo el mismo problema, no quiero estar introduciendo el pass de root cada vez que intento ver el contenido de mis discos, ya intenté lo que viene aquí y no he podido realizar las tareas (soy novato, por cierto). Me pudieran decir si hay alguna forma más para novatos de realizar esto?

Yo se que no es ningún problema estar introduciendo el pass, pero se hace tedioso y molesto hacerlo cada vez con cada disco y cada que inicio la sesión o el equipo.

karlggest
05-feb-2016, 00:27
Hola.

Un disco duro SATA generalmente está enchufado, así que doy por supuesto que es un disco interno, que está siempre en el equipo y en el que incluso puedes tener o no otros sistemas operativos. La idea es simplemente guardar cosas en él en lugar de guardarlas en alguna partición del disco donde tienes el sistema.

Bien, tomas su partición y la montas en algún lugar. Te aseguras de que tanto el montaje como la carpeta donde se monte tienen los permisos adecuados. Y lo haces siempre, aunque a mí me gusta más hacerlo con autofs.

Puedes hacerlo:



Con YaST->Sistema->Particionador
Editanto /etc/fstab (o bien buscando un tema mío para hacerlo con autofs).


Salud!!

DiabloRojo
05-feb-2016, 09:32
Bienvenido al foro, por favor, lee las normas del foro donde aprenderás cosas útiles como aportar datos, hacer preguntas, como buscar.... es como una guía para los novatos. Fíjate lo que dice resaltado y en negrita la norma 5 y sobre todo la norma 7 de escribir.


.... Me pudieran decir si hay alguna forma más para novatos de realizar esto?Como dice karlggest, suponemos que es un disco duro interno, ¿o no?. :scratchch Habra que hacerlo con una de las dos maneras que dice, la mas sencilla es la de Yast.

Como eres nuevo, preséntate en la sección de Presentaciones y, por favor, lee las normas.

http://images2.hiboox.com/images/0610/18461a8ea8dd89e0f03b56a01a15fff2.gif

LUKE10
06-feb-2016, 00:32
Hola¡¡

Bienvenido¡¡

Una pista para que busques en el foro y a la vez te documentes, así aprenderás mas y te valdrás por ti mismo..


Umask=0

Un saludo y diviértete usando tu pc ¡¡.
;)