PDA

Ver la Versión Completa : Instalar ALN 101-C


loboalpha
07-mar-2007, 17:55
Buenos Dias, Soy un novato en esto de la administracion de servidores y tengo un problema. el cual les detallo a continuacion:
Tengo un Suse Server 10.1 y deseo instalar una tarjeta de red ALN 101-C, como tercera tarjeta de red, tengo 2 proveedores de internet y deseo montar un balanceador de carga.

Esta tarjeta no me la reconocio SUSE al momento de la instalacion. tengo el kernel 2.6.16.21-0.8, y he encontrado soluciones para otros kernel, pero no para el que uso.

He visto que tengo el sundance ya instalado y lo he montado con modprobe -a sundance y cuando ejecuto lsmod lo veo ejecutandose, pero no se como activar la tarjeta de red, que en este caso seria la eth2.
Pero con ifconfig no me la muestra y ni siquiera me acepta el ifconfig eth2 up el sistema responde eth2: unknown interface: No such device

de verdad espero que me ayuden, y gracias de antemano

DiabloRojo
07-mar-2007, 18:27
http://www.advanteknetworks.com/spanish/products/networkadapters/aln101c.html

Da la salida de "hwinfo --netcard", ifconfig y route.

loboalpha
07-mar-2007, 18:56
La salida de hwinfo --netcard
18: PCI 101.0: 0200 Ethernet controller
[Created at pci.305]
UDI: /org/freedesktop/Hal/devices/pci_10ec_8169
Unique ID: rBUF.f+zznVHfYnF
Parent ID: 6NW+.c7JTK_YUBi2
SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:01:01.0
SysFS BusID: 0000:01:01.0
Hardware Class: network
Model: "CNet ProG-2000L"
Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
Device: pci 0x8169 "RTL-8169 Gigabit Ethernet"
SubVendor: pci 0x1371 "CNet Technology Inc"
SubDevice: pci 0x434e "ProG-2000L"
Revision: 0x10
Driver: "r8169"
Device File: eth0
I/O Ports: 0xa000-0xafff (rw)
Memory Range: 0xf9000000-0xf90000ff (rw,non-prefetchable)
Memory Range: 0x60000000-0x6001ffff (ro,prefetchable,disabled)
IRQ: 169 (2624 events)
HW Address: 00:08:a1:97:ed:1e
Link detected: yes
Module Alias: "pci:v000010ECd00008169sv00001371sd0000434Ebc02sc00 i00"
Driver Info #0:
Driver Status: r8169 is active
Driver Activation Cmd: "modprobe r8169"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #12 (PCI bridge)

19: PCI 103.0: 0200 Ethernet controller
[Created at pci.305]
UDI: /org/freedesktop/Hal/devices/pci_13f0_200
Unique ID: kX1R.IJgyKPu+YhA
Parent ID: 6NW+.c7JTK_YUBi2
SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:01:03.0
SysFS BusID: 0000:01:03.0
Hardware Class: network
Model: "Sundance Technology Inc / IC Plus IC Plus IP100A Integrated 10/100 Ethernet MAC + PHY"
Vendor: pci 0x13f0 "Sundance Technology Inc / IC Plus Corp"
Device: pci 0x0200 "IC Plus IP100A Integrated 10/100 Ethernet MAC + PHY"
SubVendor: pci 0x13f0 "Sundance Technology Inc / IC Plus Corp"
SubDevice: pci 0x0201
Revision: 0x31
I/O Ports: 0xa400-0xa47f (rw)
Memory Range: 0xf9001000-0xf90011ff (rw,non-prefetchable)
Memory Range: 0x60020000-0x6002ffff (ro,prefetchable,disabled)
IRQ: 5 (no events)
Module Alias: "pci:v000013F0d00000200sv000013F0sd00000201bc02sc00 i00"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #12 (PCI bridge)

20: PCI 109.0: 0200 Ethernet controller
[Created at pci.305]
UDI: /org/freedesktop/Hal/devices/pci_10ec_8139
Unique ID: JNkJ.IQxIdIhhuH7
Parent ID: 6NW+.c7JTK_YUBi2
SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:01:09.0
SysFS BusID: 0000:01:09.0
Hardware Class: network
Model: "Realtek RT8139"
Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
Device: pci 0x8139 "RTL-8139/8139C/8139C+"
SubVendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
SubDevice: pci 0x8139 "RT8139"
Revision: 0x10
Driver: "8139too"
Device File: eth1
I/O Ports: 0xa800-0xa8ff (rw)
Memory Range: 0xf9002000-0xf90020ff (rw,non-prefetchable)
IRQ: 177 (23101 events)
HW Address: 00:16:ec:51:c5:e3
Link detected: yes
Module Alias: "pci:v000010ECd00008139sv000010ECsd00008139bc02sc00 i00"
Driver Info #0:
Driver Status: 8139too is active
Driver Activation Cmd: "modprobe 8139too"
Driver Info #1:
Driver Status: 8139cp is not active
Driver Activation Cmd: "modprobe 8139cp"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #12 (PCI bridge)


la salida de ifconfig

eth0 Link encap:Ethernet HWaddr 00:08:A1:97:ED:1E
inet addr:10.0.0.2 Bcast:10.0.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2342 errors:0 dropped:0 overruns:0 frame:0
TX packets:341 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:710830 (694.1 Kb) TX bytes:38802 (37.8 Kb)
Interrupt:169 Base address:0x6000

eth1 Link encap:Ethernet HWaddr 00:16:EC:51:C5:E3
inet addr:200.62.25.46 Bcast:255.255.255.255 Mask:255.255.255.240
inet6 addr: fe80::216:ecff:fe51:c5e3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:13423 errors:0 dropped:0 overruns:0 frame:0
TX packets:10547 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:10550384 (10.0 Mb) TX bytes:1911117 (1.8 Mb)
Interrupt:177 Base address:0x6000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:489 errors:0 dropped:0 overruns:0 frame:0
TX packets:489 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:50030 (48.8 Kb) TX bytes:50030 (48.8 Kb)

y esta es la de route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
ccscliente032.i * 255.255.255.240 U 0 0 0 eth1
10.0.0.0 * 255.255.0.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default ccscliente033.i 0.0.0.0 UG 0 0 0 eth1

DiabloRojo
07-mar-2007, 21:16
default ccscliente033.i 0.0.0.0 UG 0 0 0 eth1Esto no es correcto, aparte de que eth1 tiene una IP publica. Y no te detecta la tarjeta "Sundance". Haz un esquema de tu red para aclarar.

Busca en el foro, tenemos casos de 2 o mas tarjetas de red.